cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
lalitbhambhani
Adventurer
Adventurer
625 Views
Registered: ‎07-23-2015

libtbb.so.2: undefined reference

Jump to solution

I'm getting the following error when I run CSim using Vitis HLS 2020.2. I have this file in the location shown by the error message and assuming its not the correct version. I don't see a version supplied by Vitis HLS 2020.2 and couldn't find a solution for this.

/usr/lib/x86_64-linux-gnu/libtbb.so.2: undefined reference to `__cxa_init_primary_exception@CXXABI_1.3.11'
/usr/lib/x86_64-linux-gnu/libtbb.so.2: undefined reference to `std::__exception_ptr::exception_ptr::exception_ptr(void*)@CXXABI_1.3.11'
collect2: error: ld returned 1 exit status
make: *** [csim.exe] Error 1
ERROR: [SIM 211-100] 'csim_design' failed: compilation error(s).

Any suggestions would be appreciated. Thanks!

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
lalitbhambhani
Adventurer
Adventurer
292 Views
Registered: ‎07-23-2015

@nikotesla 

I launched my old VM and uninstalled OpenCV and then tried your solution.
I already had TBB turned off but I had CUDA ON so decided to turn that OFF and installed OpenCV. After that I was able to get CSim and CoSim to compile and show simulations properly.

Thanks!

View solution in original post

4 Replies
nikotesla
Visitor
Visitor
414 Views
Registered: ‎06-02-2021

I'm getting the same problem when running Csim on vitis HLS 2020.2

Did you resolve the problem yet?

NT

0 Kudos
lalitbhambhani
Adventurer
Adventurer
393 Views
Registered: ‎07-23-2015

I'm running 2020.2 on Linux OS in virtual machine. I decided to create a new VM and did a fresh install of the OS and 2020.2 then got it to work.
I'm still looking for answer for this problem.

nikotesla
Visitor
Visitor
352 Views
Registered: ‎06-02-2021

I have also resolved the problem.

In my case, just need to turn off TBB when configuring CMAKE. My previous configuration was

cmake -D CMAKE_BUILD_TYPE=RELEASE \
            -D CMAKE_INSTALL_PREFIX=$cwd/installation/OpenCV-"$cvVersion" \
            -D INSTALL_C_EXAMPLES=ON \
            -D INSTALL_PYTHON_EXAMPLES=ON \
            -D WITH_TBB=ON \
            -D WITH_V4L=ON \
            -D OPENCV_PYTHON3_INSTALL_PATH=$cwd/OpenCV-$cvVersion-py3/lib/python3.5/site-packages \
        -D WITH_QT=ON \
        -D WITH_OPENGL=ON \
        -D OPENCV_EXTRA_MODULES_PATH=../../opencv_contrib/modules \
        -D BUILD_EXAMPLES=ON ..

 

My current configuration is:

cmake -D CMAKE_BUILD_TYPE=RELEASE \
		-D CMAKE_INSTALL_PREFIX=/home/tesla/Tools/opencv/OpenCV-3.4.4 \
		-D WITH_CUDA=OFF \
		-D INSTALL_C_EXAMPLES=ON \
		-D INSTALL_PYTHON_EXAMPLES=ON \
		-D OPENCV_EXTRA_MODULES_PATH=../../opencv_contrib/modules \
		-D OPENCV_ENABLE_NONFREE=ON \
		-D BUILD_EXAMPLES=ON ..

Then reinstall OpenCV.

 

PS: I followed the guide here (https://learnopencv.com/install-opencv-3-4-4-on-ubuntu-18-04/) to install OpenCV.

Hope that can help.

TN

 

lalitbhambhani
Adventurer
Adventurer
293 Views
Registered: ‎07-23-2015

@nikotesla 

I launched my old VM and uninstalled OpenCV and then tried your solution.
I already had TBB turned off but I had CUDA ON so decided to turn that OFF and installed OpenCV. After that I was able to get CSim and CoSim to compile and show simulations properly.

Thanks!

View solution in original post