cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
904 Views
Registered: ‎11-16-2017

synthesis pass but post synthesis simulation fail

Jump to solution

I am following trd03 to generate bitstream under Ubuntu. After generating the bitstream file, it showed synthesis failed. The message is as follows:

  • [Common 17-345] A valid license was not found for feature 'Synthesis' and/or device 'xcku040'. Please run the Vivado License Manager for assistance in determining which features and devices are licensed for your system. Resolution: Check the status of your licenses in the Vivado License Manager. For debug help search Xilinx Support for "Licensing FAQ".

I have double checked the license, it's totally OK. And when I change to Win10, there is no problem with it. I believe Ubuntu and win10 are sharing the same host IP of the computer.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Adventurer
Adventurer
815 Views
Registered: ‎11-16-2017

Re: synthesis pass but post synthesis simulation fail

Jump to solution

You are right, but the solution of the link has some little details to add.

The solution for Ubuntu 18.04.1 LTS:

Get the Ethernet Adapter renamed to eth0 (Ubuntu 18.04.1 LTS):
1: cd /etc/default
sudo vi grub
2: press "i" to get into insert mode of vi editor
change [GRUB_CMDLINE_LINUX=""] to [GRUB_CMDLINE_LINUX="net.ifnames=0 biosdevname=0"] (add 'net.ifnames=0 biosdevname=0')
Esc, ':', 'x' to save and exit
3: sudo grub-mkconfig -o /boot/grub/grub.cfg (to generate a new grub file)
4: reboot

Of course you need to open the terminal with Ctrl+Alt+T first.

Hope that will help all the people facing the same problem.

View solution in original post

0 Kudos
3 Replies
Highlighted
Adventurer
Adventurer
898 Views
Registered: ‎11-16-2017

Re: synthesis pass but post synthesis simulation fail

Jump to solution

The total Tcl Console is attached.

0 Kudos
Highlighted
Moderator
Moderator
843 Views
Registered: ‎05-31-2017

Re: synthesis pass but post synthesis simulation fail

Jump to solution

Hi @yzzhsx12345,

At first from the title and the description of the post, the issue is not clear. I think that you are facing issues in Vivado. Tool will not give errors regarding synthesis after generating bitstream as synthesis takes places at the earlier flow itself.

As I understand that for the same machine if you are using windows 10 then you are facing no issues and when changed to Linux you are facing issues with license then it might be the scenario of Ubuntu machine unable to detect the Host ID of the machine. Please follow the AR#60510 and see if it helps.

0 Kudos
Highlighted
Adventurer
Adventurer
816 Views
Registered: ‎11-16-2017

Re: synthesis pass but post synthesis simulation fail

Jump to solution

You are right, but the solution of the link has some little details to add.

The solution for Ubuntu 18.04.1 LTS:

Get the Ethernet Adapter renamed to eth0 (Ubuntu 18.04.1 LTS):
1: cd /etc/default
sudo vi grub
2: press "i" to get into insert mode of vi editor
change [GRUB_CMDLINE_LINUX=""] to [GRUB_CMDLINE_LINUX="net.ifnames=0 biosdevname=0"] (add 'net.ifnames=0 biosdevname=0')
Esc, ':', 'x' to save and exit
3: sudo grub-mkconfig -o /boot/grub/grub.cfg (to generate a new grub file)
4: reboot

Of course you need to open the terminal with Ctrl+Alt+T first.

Hope that will help all the people facing the same problem.

View solution in original post

0 Kudos