cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jagron
Adventurer
Adventurer
7,349 Views
Registered: ‎01-04-2008

10.1.3 Floorplanner on RHEL 5.0 (64-bit)

Jump to solution

I am having trouble running floorplanner, and I get the following error when launching the tool:

 

 [my@machine]$ floorplanner
/opt/Xilinx/10.1/ISE/bin/lin64/_floorplanner: error while loading shared libraries: libXm.so.3: wrong ELF class: ELFCLASS32

 

All of the other Xilinx tools (ISE, EDK, Impact, ChipScope, XST, etc.) work perfectly, but floorplanner always fails.

 

Here is some additional info if that helps:

 

echo $LD_LIBRARY_PATH


/opt/Xilinx/10.1/EDK/lib/lin64:/opt/Xilinx/10.1/ISE/lib/lin64:/usr/X11R6/lib:/opt/Xilinx/10.1/ISE/smartmodel/lin64/installed_lin64:/opt/Xilinx/10.1/ISE/smartmodel/lin64/installed_lin64/lib/linux.lib:/opt/Xilinx/10.1/ISE/smartmodel/lin64/installed_lin64:/opt/Xilinx/10.1/ISE/smartmodel/lin64/installed_lin64/lib/amd64.lib:/opt/Xilinx/10.1/ChipScope/lib/lin64:/opt/Xilinx/10.1/ChipScope/xilinx/lib/lin64:/sbin:/lib:/usr/lib64:/usr/lib:/opt/Xilinx/10.1/EDK/lib/lin64:/opt/Xilinx/10.1/ISE/lib/lin64:/usr/X11R6/lib:/opt/Xilinx/10.1/ISE/smartmodel/lin64/installed_lin64/lib/linux.lib:/opt/Xilinx/10.1/ISE/smartmodel/lin64/installed_lin64/lib/amd64.lib:/opt/Xilinx/10.1/ChipScope/lib/lin64:/opt/Xilinx/10.1/ChipScope/xilinx/lib/lin64:/sbin:/lib:/usr/lib64:/usr/lib:

0 Kudos
1 Solution

Accepted Solutions
jagron
Adventurer
Adventurer
8,867 Views
Registered: ‎01-04-2008

I ended up installing libXmu-devel.x86_64 0:1.0.2-5 and adding a symbolic link from the new libXm to the libXm.so.3, but now I get the following error...

 

$> floorplanner

 Wind/U X-toolkit Error: wuDisplay: Can't open display

 

I found an older Answer Record (http://www.xilinx.com/support/answers/20172.htm) about this error, and it suggests setting the environment vaiable DISPLAY to ":0" instead of ":0.0"

 

After this, floorplanner successfully started, however it took about 2 minutes for the GUI to load (pretty slow for a 2.5 GHz Dual Core Intel with 4 GB of RAM with nothing else running but a web browser).

 

In general, shouldn't the Xilinx tools run perfectly under RHEL-5.0, as this is the recommended OS for the 10.1 toolset?

 

 

View solution in original post

0 Kudos
4 Replies
kpatel
Xilinx Employee
Xilinx Employee
7,347 Views
Registered: ‎07-30-2007
It might be that the libXm.so.3 you are pointing to is 32-bit and needs to be 64-bit.  What does 'ldd libXm.so.3' return?
0 Kudos
jagron
Adventurer
Adventurer
7,345 Views
Registered: ‎01-04-2008

It returns the following:

 

 ldd /usr/lib/libXm.so.3
        linux-gate.so.1 =>  (0xffffe000)
        libXmu.so.6 => /usr/lib/libXmu.so.6 (0xf7cdb000)
        libXt.so.6 => /usr/lib/libXt.so.6 (0xf7c83000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0xf7c7a000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0xf7c5f000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xf7c4f000)
        libXp.so.6 => /usr/lib/libXp.so.6 (0xf7c47000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xf7b44000)
        libc.so.6 => /lib/libc.so.6 (0xf7a00000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xf79fc000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xf79f6000)
        libdl.so.2 => /lib/libdl.so.2 (0xf79f2000)
        /lib/ld-linux.so.2 (0x002ff000)
 

I haven't yet figured out where to get a 64-bit version of libXm.  Is there a specific library package that includes it?

 

-Jason

0 Kudos
jagron
Adventurer
Adventurer
8,868 Views
Registered: ‎01-04-2008

I ended up installing libXmu-devel.x86_64 0:1.0.2-5 and adding a symbolic link from the new libXm to the libXm.so.3, but now I get the following error...

 

$> floorplanner

 Wind/U X-toolkit Error: wuDisplay: Can't open display

 

I found an older Answer Record (http://www.xilinx.com/support/answers/20172.htm) about this error, and it suggests setting the environment vaiable DISPLAY to ":0" instead of ":0.0"

 

After this, floorplanner successfully started, however it took about 2 minutes for the GUI to load (pretty slow for a 2.5 GHz Dual Core Intel with 4 GB of RAM with nothing else running but a web browser).

 

In general, shouldn't the Xilinx tools run perfectly under RHEL-5.0, as this is the recommended OS for the 10.1 toolset?

 

 

View solution in original post

0 Kudos
Anonymous
Not applicable
4,129 Views

how does libXmu-devel.x86_64 0:1.0.2-5 have anything to do with libXm.so.3?

 

i can't start fpga_editor on slackware 12.1 either. well i install openmotif-2.2.3,

and i did not realize what openmotif package actually do.

 

 

tia

 

 

0 Kudos