UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
9,929 Views
Registered: ‎08-13-2007

12.1 ignoring .ucf ( works under 11.4)

Jump to solution

Trying 12.1 for the first time. I've copied an existing 11.4 directory and made a new one for 12.1 to import / convert project. 11.4 Build fine in under 10 mins ( target XC3S400A). 12.1 appear to ignore the .ucf file ( if i type fjkdsfksdhfjk in it I don't get any errors)

It takes over 30min on map stage 4.2 and says it can't find and IOB place solution. this is becuase it hasn't got the correct voltage levels for the IOBs set from the ucf. I can't see any option like ignore ucf set.

 

Ideas on where to look next ?

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
11,896 Views
Registered: ‎01-07-2009

Re: 12.1 ignoring .ucf ( works under 11.4)

Jump to solution

In order for a UCF file to be passed to ngdbuild by Project Navigator, the UCF file must be added to the ISE project as a source.  If you don't have a UCF file in the project, Project Navigator will pass the -i to ngdbuild to ensure that no constraints file is used, since you did not add one to the project.  Otherwise, as a result of ngdbuild default behavior, if a UCF existed in the project directory with the same base name as the top-level source netlist, it would be automatically picked up by ngdbuild regardless of whether it was in the ISE project or not.  Therefore, in an attempt to have more explicit control over the passing of files to the tools, Project Navigator passes UCF files which are part of the project via the -uc, and if there are no UCF files in the project, it passes -i. 

 

So, the bottom line here I think is that you should simply add the UCF to the project, and not use the -uc in the ngdbuild (Translate) Other Command Line options. 

0 Kudos
12 Replies
Xilinx Employee
Xilinx Employee
9,914 Views
Registered: ‎12-17-2007

Re: 12.1 ignoring .ucf ( works under 11.4)

Jump to solution

A change was made in 12.1 where the .ISE and _xdb are no longer the driving force for passing constraints into NGDBuild.  NGDBuild now _must_ have a -uc specified for the constraints that you wish it to parse.

 

Do you see an appropriate reference in the Translate report to your constraints file?

-------------------------------------------
this space intentionally left blank
0 Kudos
Adventurer
Adventurer
9,901 Views
Registered: ‎08-13-2007

Re: 12.1 ignoring .ucf ( works under 11.4)

Jump to solution

Thanks for that.

 

In the gui when I add -uc top.ucf to the other options. How do I stop all the "-i" switches appearing ?

 

 

 

Command Line: ngdbuild -intstyle ise -dd _ngo -nt timestamp -i -i -i -p xc3s400a-ft256-4 "top.ngc" top.ngd -uc top.ucf
ERROR:NgdBuild:580 - Conflicting NGDBUILD options:  Cannot specify the UCF file
   (-uc option) and ignore the UCF file (-i option) at the same time. 

 

Command Line: ngdbuild -intstyle ise -dd _ngo -nt timestamp -i -i -i -p xc3s400a-ft256-4 "top.ngc" top.ngd -uc top.ucfERROR:NgdBuild:580 - Conflicting NGDBUILD options:  Cannot specify the UCF file   (-uc option) and ignore the UCF file (-i option) at the same time. 

 

 

Also, how as a new 12.1 user should I have found this out ?

 

0 Kudos
Xilinx Employee
Xilinx Employee
9,889 Views
Registered: ‎12-17-2007

Re: 12.1 ignoring .ucf ( works under 11.4)

Jump to solution

The -i switch tells NGDBuild to ignore the constraints file.  This was how we told NGDBuild in 11.x and prior to ignore the UCF and do what was specified in the _XDB/.ISE locations.  Given that your design was migrated, I'm suspecting that the migration process simply carried some settings forward that it should not have.

 

For this aspect, you might want to file a WebCase with technical support so that we can look into it in case this is a real bug and we need to file a defect against it.

 

As to how to learn about these changes, we always document the valid options for our tools in the Development System Reference Guide. It can be found on the web at http://www.xilinx.com/support/documentation/sw_manuals/xilinx12_1/devref.pdf

 

We also deploy a copy of it as part of your ISE installation.  The default location for it (on Windows) is C:\Xilinx\12.1\ISE_DS\ISE\doc\usenglish\isehelp\devref.pdf

-------------------------------------------
this space intentionally left blank
0 Kudos
Adventurer
Adventurer
9,885 Views
Registered: ‎08-13-2007

Re: 12.1 ignoring .ucf ( works under 11.4)

Jump to solution

I've just created a whole new project left all options as default and added -uc top.ucf. I still get a -i in the command line.

 

 

ommand Line: ngdbuild -intstyle ise -dd _ngo -nt timestamp -i -p xc3s400a-ft256-4 "top.ngc" top.ngd -uc top.ucf
ERROR:NgdBuild:580 - Conflicting NGDBUILD options:  Cannot specify the UCF file
   (-uc option) and ignore the UCF file (-i option) at the same time. 

 

Command Line: ngdbuild -intstyle ise -dd _ngo -nt timestamp -i -p xc3s400a-ft256-4 "top.ngc" top.ngd -uc top.ucfERROR:NgdBuild:580 - Conflicting NGDBUILD options:  Cannot specify the UCF file   (-uc option) and ignore the UCF file (-i option) at the same time.  

 

 

0 Kudos
Xilinx Employee
Xilinx Employee
9,856 Views
Registered: ‎11-28-2007

Re: 12.1 ignoring .ucf ( works under 11.4)

Jump to solution

Do you happen to have spaces in the directory path to the UCF?

Cheers,
Jim
0 Kudos
Xilinx Employee
Xilinx Employee
11,897 Views
Registered: ‎01-07-2009

Re: 12.1 ignoring .ucf ( works under 11.4)

Jump to solution

In order for a UCF file to be passed to ngdbuild by Project Navigator, the UCF file must be added to the ISE project as a source.  If you don't have a UCF file in the project, Project Navigator will pass the -i to ngdbuild to ensure that no constraints file is used, since you did not add one to the project.  Otherwise, as a result of ngdbuild default behavior, if a UCF existed in the project directory with the same base name as the top-level source netlist, it would be automatically picked up by ngdbuild regardless of whether it was in the ISE project or not.  Therefore, in an attempt to have more explicit control over the passing of files to the tools, Project Navigator passes UCF files which are part of the project via the -uc, and if there are no UCF files in the project, it passes -i. 

 

So, the bottom line here I think is that you should simply add the UCF to the project, and not use the -uc in the ngdbuild (Translate) Other Command Line options. 

0 Kudos
Visitor ga_stein
Visitor
9,783 Views
Registered: ‎05-11-2010

Re: 12.1 ignoring .ucf ( works under 11.4)

Jump to solution

I too am seeing the exact same behavior that DP11 reported.  Translate is issued with four -i options (" -i -i -i -i").  The .ucf is part of the project, it shows Implementation association, but still translate issues -i.  This occurs whether the project was migrated from 11.4 or is created new.

0 Kudos
Xilinx Employee
Xilinx Employee
9,772 Views
Registered: ‎01-07-2009

Re: 12.1 ignoring .ucf ( works under 11.4)

Jump to solution

My explanation above does explain how it's intended to behave, but yes, this issue (bug) of multiple -i options being passed has recently been reported and it's being looked into now.  We hope to have an update on the issue shortly.

0 Kudos
Adventurer
Adventurer
9,767 Views
Registered: ‎08-13-2007

Re: 12.1 ignoring .ucf ( works under 11.4)

Jump to solution

To me this is a critical bug. What are the timescales to get this sorted ?

 

ps can you remove the nice green tick that has been added to this thread.?

0 Kudos
Xilinx Employee
Xilinx Employee
3,875 Views
Registered: ‎01-07-2009

Re: 12.1 ignoring .ucf ( works under 11.4)

Jump to solution

After some further investigation, it does appear that this issue (that of multiple -i switches being passed to ngdbuild even when UCF is added to the project) is caused by having the source UCF file residing in a *remote* (outside the project directory) directory that also contains spaces.  Does this account for your situation as well? 

 

We've identified a fix and it will be in 12.2.  The workaround at this point should be to remove the spaces from the directory path to the UCF, or put the UCF into the project directory (to make it a local source).  I realize this is not ideal, but hope this at least allows you to get past the issue at this time.  Do you want to confirm for me that you can in fact get around the problem using one of these workarounds? 

0 Kudos
Adventurer
Adventurer
3,863 Views
Registered: ‎08-13-2007

Re: 12.1 ignoring .ucf ( works under 11.4)

Jump to solution

Yes, removing the spaces from the path fixes the problem.

thanks

 

0 Kudos
Visitor dafeldib
Visitor
2,870 Views
Registered: ‎03-05-2014

Re: 12.1 ignoring .ucf ( works under 11.4)

Jump to solution

Yes, putting the .ucf file in the same directory with the project files solved the issue although there are spaces in the path. So, it seems, either way, the issue is resolved.

 

Thanks!

0 Kudos