cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
3,836 Views
Registered: ‎04-20-2011

Infinite mapping

Hi

 

I'm trying to implement a design. Translation works fine (with some warnings, though), the mapping process, however, does never finish. I ran it over night and it didn't came farther than this log message:

 

"Phase 4.2  Initial Placement for Architecture Specific Features"

 

I'm using ISE 12.4 on Fedora release 15 64 bit (2.6.40-4.fc15.x86_64). Did anyone have similar problems?

 

 

Basil

0 Kudos
3 Replies
Highlighted
3,829 Views
Registered: ‎04-20-2011

Here's some additional information. I think it's a problem with the operating system as I was able to map the same project on Windows 7 and on Ubuntu. An ldd gives the following:

 

[root@lheppc29 lin64]# ldd ise
    linux-vdso.so.1 =>  (0x00007fff94bff000)
    libdl.so.2 => /lib64/libdl.so.2 (0x0000003cfc400000)
    libpthread.so.0 => /lib64/libpthread.so.0 (0x0000003cfc000000)
    libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x0000003d08000000)
    libm.so.6 => /lib64/libm.so.6 (0x0000003cfcc00000)
    libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x0000003cfd400000)
    libc.so.6 => /lib64/libc.so.6 (0x0000003cfbc00000)
    /lib64/ld-linux-x86-64.so.2 (0x0000003cfb800000)

Does this look correct? It seems at least I am not mixing 32 bit libraries with a 64 bit program...

0 Kudos
Highlighted
3,827 Views
Registered: ‎04-20-2011

Sorry for spamming, but here's some more information: When I try to run ISE from a terminal I get the following message:

 

Couldn't load XPCOM

 

Maybe it has something to do with my error?

0 Kudos
Highlighted
3,803 Views
Registered: ‎04-20-2011

Solved!

 

Some libraries which couldn't be loaded caused the problem. Apparently this issue is known with a proper error message.

 

You can check this thread, how it can be solved:

http://forums.xilinx.com/t5/Implementation/ISE-13-1-MAP-crashes-on-Ubuntu-11-04/td-p/156398

0 Kudos