UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor rfjhh_utsjr
Visitor
7,520 Views
Registered: ‎09-18-2017

Plan ahead doesn't start

I'm implementing a vhdl project in ISE web pack. The synthesize process is ok, but the plan ahead doesn't start. I have the same  ISE installation in other laptop an I don't have problems in Implementing design. 

My students have the same problem.

Somebody may tell me what's going on please.

 

0 Kudos
18 Replies
Moderator
Moderator
7,518 Views
Registered: ‎09-15-2016

Re: Plan ahead doesn't start

Hi @rfjhh_utsjr,

 

Which OS are you running the tool in?

 

--------------------------------------------------------------
Please mark the appropriate answer as "Accept as solution" if information provided is helpful.
Give 'Kudos' to a post which you think is useful and reply oriented.
--------------------------------------------------------------

0 Kudos
Moderator
Moderator
7,508 Views
Registered: ‎09-15-2016

Re: Plan ahead doesn't start

Hi @rfjhh_utsjr,

 

Also did you invoke Planahead from tool? Try to run it standalone?

Any messages in console?

 

Did you try invoking for IO planning pre-synthesis?

 

--------------------------------------------------------------
Please mark the appropriate answer as "Accept as solution" if information provided is helpful.
Give 'Kudos' to a post which you think is useful and reply oriented.
--------------------------------------------------------------

0 Kudos
Moderator
Moderator
7,507 Views
Registered: ‎01-16-2013

Re: Plan ahead doesn't start

@rfjhh_utsjr,

 

Can you open the ISE command prompt and type "planAhead" and see if it opens the planahead GUI..

Capture.JPG

 

-_Syed

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------
0 Kudos
Visitor rfjhh_utsjr
Visitor
7,504 Views
Registered: ‎09-18-2017

Re: Plan ahead doesn't start

Windows 10 in both laptops.

In my laptop ("old one") I've been working well, not in the new one, same OS.

0 Kudos
Moderator
Moderator
7,501 Views
Registered: ‎09-15-2016

Re: Plan ahead doesn't start

Hi @rfjhh_utsjr,

 

Xilinx does not officially support using Windows 8.1 or Windows 10 with ISE Design Suite AR18419.

 

Since the factory have not tested ISE in Win10, they are not sure of the stability of the tool in unsupported OS. Thus even if it gets installed, it becomes very difficult to debug especially in case of any issue related to crash/hang, tool does not start etc.

 

Are there any messages you see in console? Did you try what @syedz suggested?

 

--------------------------------------------------------------
Please mark the appropriate answer as "Accept as solution" if information provided is helpful.
Give 'Kudos' to a post which you think is useful and reply oriented.
--------------------------------------------------------------

0 Kudos
Visitor rfjhh_utsjr
Visitor
7,480 Views
Registered: ‎09-18-2017

Re: Plan ahead doesn't start

I can't access c:\xilinx\14.7

A message is displayed: "can't find the specified path"

 

0 Kudos
Visitor rfjhh_utsjr
Visitor
7,471 Views
Registered: ‎09-18-2017

Re: Plan ahead doesn't start

I performed C:\Xilinx\14.7\ISE_DS>planahead and a message is displayed

"planAhead stopped working, Windows is looking for a solution" 

0 Kudos
Visitor rvictor
Visitor
6,866 Views
Registered: ‎12-04-2017

Re: Plan ahead doesn't start

  Have the same problem with Windows 10 64 bit. Everything was working OK in August, now it does not start - the dialog with options "Close / Debug" is displayed immediately after start.

  Choosing the "Debug" option results in "Unhandled exception at 0x00007ffcd405775f in planAhead.exe: 0xC0000374: A heap has been corrupted." message and after the "Continue" button is pressed the application starts. The stack does not shows any useful information on the first look, but at least it works for me in this ugly way.

 

  

 

0 Kudos
Moderator
Moderator
6,619 Views
Registered: ‎09-15-2016

Re: Plan ahead doesn't start

Hi @rvictor,

 

Sorry for the inconvenience caused in running ISE/PlanAhead in Win10 system which is not supported OS. (link). As discussed above, since factory have not tested ISE in Win10, they are not sure of the stability of tool in this OS. 

 

Thanks,

prathikm

0 Kudos
Visitor rvictor
Visitor
4,444 Views
Registered: ‎12-04-2017

Re: Plan ahead doesn't start

  Yes, I quite understand that you do not support Windows 10, but the current situation is that you cannot use Windows 7/2008 on modern computers (the Microsoft does not support Windows 7/2008 for "new" CPUs, so it refuses to run on my uprated i7-7700 PC). The result is that the PlanAhead is effectively becomes unusable under Windows OS, which makes it a bit painful for developers which requires Windows OS as their primary development environment.

  To continue the use of PA requires some additional workarounds, like using it under Linux in VM, or, as in my case - ignoring exceptions in debugger.

 

0 Kudos
4,271 Views
Registered: ‎02-07-2018

Re: Plan ahead doesn't start

For anyone finding this Thread via Google (like me):

 

A solution is to go to [ISE install dir]/14.7/ISE_DS/PlanAhead/bin and open planAhead.bat in an editor.

Then change the last line to

call "%RDI_BINROOT%/loader.bat" -exec %RDI_PROG% %* -m32

by appending the -m32 in the end. This will make ISE open PlanAhead's 32bit Version which works fine on my Win 10 x64

 

Hope I could help,

Felix

Visitor lf.xilinx
Visitor
4,085 Views
Registered: ‎03-14-2018

Re: Plan ahead doesn't start

 

This worked for me. No more "planAhead has stopped working" messages .Thank you!


A solution is to go to [ISE install dir]/14.7/ISE_DS/PlanAhead/bin and open planAhead.bat in an editor.

Then change the last line to

call "%RDI_BINROOT%/loader.bat" -exec %RDI_PROG% %* -m32

 

0 Kudos
Highlighted
3,676 Views
Registered: ‎06-08-2018

Re: Plan ahead doesn't start

 
It seems to me that I've seen this very late, but I wanna post the best solution that worked for me, so maybe it can help others :)
 
1)Open C:\Xilinx\14.7\ISE_DS\PlanAhead\bin and rename rdiArgs.bat to rdiArgs.bat.orig
2)Download the zip file from : https://www.eevblog.com/forum/microcontrollers/guide-getting-xilinx-ise-to-work-with-windows-8-64-bit/?action=dlattach;attach=102040
3)Extract it. You should now have a file named rdiArgs.bat
4)Copy the new rdiArgs.bat file to C:\Xilinx\14.7\ISE_DS\PlanAhead\bin
Newbie buttercup
Newbie
3,243 Views
Registered: ‎10-28-2018

Re: Plan ahead doesn't start

hanieh,

 

Just wanted to thank you for doing this. I too am late to this issue, but your fix worked perfectly for me 

 

Thank you for taking the time to document this.

 

Cheers

0 Kudos
3,179 Views
Registered: ‎06-08-2018

Re: Plan ahead doesn't start

your welcome, I'm glad I could help you:)

0 Kudos
Visitor vishnu27@n
Visitor
1,417 Views
Registered: ‎03-13-2019

Re: Plan ahead doesn't start

in planahead there is no file like .bat

0 Kudos
Visitor vishnu27@n
Visitor
1,415 Views
Registered: ‎03-13-2019

Re: Plan ahead doesn't start

it is rdiArgs.sh file

0 Kudos
Visitor obi007
Visitor
504 Views
Registered: ‎12-11-2018

Re: Plan ahead doesn't start

Works perfectly for me. Thanks for sharing your experience
0 Kudos