cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
1,952 Views
Registered: ‎11-06-2017

Problem regarding Vivado 2017.3 bitstream generation

Jump to solution

Hi, 

I have a problem at bitstream generation in Vivado 2017.3.  I am using the same project which has already worked in Vivado 2017.2, In the other words, I am migrating my project from 2017.2 to 2017.3. But in Vivado 2017.3 I have following errors: 

[DRC NSTD-1] Unspecified I/O Standard: 8 out of 12 logical ports use I/O standard (IOSTANDARD) value 'DEFAULT', instead of a user assigned specific value. This may cause I/O contention or incompatibility with the board power or connectivity affecting performance, signal integrity or in extreme cases cause damage to the device or the components to which it is connected. To correct this violation, specify all I/O standards. This design will fail to generate a bitstream unless all logical ports have a user specified I/O standard value defined. To allow bitstream creation with unspecified I/O standard values (not recommended), ... . . . . . ...  

In fact I have defined for all ports their related IO Standards. But I don't know why the vivado shows this error! 

P.S. The platform that I use is " xczu9eg-ffvc900-1-e-es2" 

Thank you 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Moderator
Moderator
3,024 Views
Registered: ‎11-09-2015

Re: Problem regarding Vivado 2017.3 bitstream generation

Jump to solution

Hi @fkhalili,

 

Could you share a log file?

 

The log file should tell you if there are constraints that are not taken in account.

 

What if you open the implemented design an you select the IO planning view? Do you see the IO standard are still Default?

 

Hope that helps,

 

Regards,

 

Florent


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**

View solution in original post

5 Replies
Highlighted
Adventurer
Adventurer
1,950 Views
Registered: ‎11-06-2017

Re: Problem regarding Vivado 2017.3 bitstream generation

Jump to solution

Sorry, I forgot to mention that I also updated the version to 2017.3.1 but the problem still exists! 

0 Kudos
Highlighted
Moderator
Moderator
1,925 Views
Registered: ‎09-15-2016

Re: Problem regarding Vivado 2017.3 bitstream generation

Jump to solution

Hi @fkhalili

 

Can you share the project to reproduce it at our end? Once we reproduce it we can report it to the factory.

Meanwhile you can work around this following the steps in the AR below:

https://www.xilinx.com/support/answers/56354.html

 

Regards

Rohit

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

 

Regards
Rohit
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

Highlighted
Adventurer
Adventurer
1,903 Views
Registered: ‎11-06-2017

Re: Problem regarding Vivado 2017.3 bitstream generation

Jump to solution

Dear @thakurr,

Thanks for your reply. I am so sorry, because of respecting to the regulations of my employer, I cannot share the project! So, I am switching back to 2017.2 . I would also give a feedback about this issue. 

Kinds,
Farnam

0 Kudos
Highlighted
Moderator
Moderator
3,025 Views
Registered: ‎11-09-2015

Re: Problem regarding Vivado 2017.3 bitstream generation

Jump to solution

Hi @fkhalili,

 

Could you share a log file?

 

The log file should tell you if there are constraints that are not taken in account.

 

What if you open the implemented design an you select the IO planning view? Do you see the IO standard are still Default?

 

Hope that helps,

 

Regards,

 

Florent


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**

View solution in original post

Highlighted
Adventurer
Adventurer
1,682 Views
Registered: ‎11-06-2017

Re: Problem regarding Vivado 2017.3 bitstream generation

Jump to solution

Dear @florentw

Sorry for the delayed reply. Due to lack of time to deliver the project I had to switch back to 2016.3 version and unfortunately I have not access to the log files since the project using in 2017.3 is deleted! 

Regards,
Farnam

0 Kudos