UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer skor
Observer
429 Views
Registered: ‎12-21-2015

[Pwropt 34-321] HACOOException: Too many fanin/fanouts in design, exiting pwropt. You can change this limit with the param pwropt.maxFaninFanoutToNetRatio

Jump to solution

Hello

 

I am using VIVADO 2018.3 . Design optimisation stops and I get following message :

[Pwropt 34-321] HACOOException: Too many fanin/fanouts in design, exiting pwropt. You can change this limit with the param pwropt.maxFaninFanoutToNetRatio.

I started to get this message when I removed from my memory block the safety logic. i do not use RSTA_BUSY signal, so i got a warning about unused signal. tried to remove that but now optimisation fails.

What is the best way to proceed? take back the unused RSTA_Busy or try to set the param as indicated in the vivado message. How can I change the param and what shoul be a reasonable value.?

 

Regards,  skor

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
404 Views
Registered: ‎05-08-2012

Re: [Pwropt 34-321] HACOOException: Too many fanin/fanouts in design, exiting pwropt. You can change this limit with the param pwropt.maxFaninFanoutToNetRatio

Jump to solution

Hi @skor 

The error is caused by a threshold limit being exceeded. For a net, the number of total fanin or fanout is greater than 1000. I would suggest setting this to 2000, and then 5000.

 

set_param pwropt.maxFaninFanoutToNetRatio 2000


-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

 

---------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
---------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
1 Reply
Xilinx Employee
Xilinx Employee
405 Views
Registered: ‎05-08-2012

Re: [Pwropt 34-321] HACOOException: Too many fanin/fanouts in design, exiting pwropt. You can change this limit with the param pwropt.maxFaninFanoutToNetRatio

Jump to solution

Hi @skor 

The error is caused by a threshold limit being exceeded. For a net, the number of total fanin or fanout is greater than 1000. I would suggest setting this to 2000, and then 5000.

 

set_param pwropt.maxFaninFanoutToNetRatio 2000


-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

 

---------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
---------------------------------------------------------------------------------------------

View solution in original post

0 Kudos