UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
656 Views
Registered: ‎05-09-2014

SmartXplorer Problems - Looking for a Workaround

All:

 

     I'm doing some maintenance work on an older project that uses ISE 13.2.  Timing Closure has always been an issue so I have to use SmartXplorer.  My company, a while back, upgraded out servers to newer version of software.  Our scheduler is called "PBS Torgue".  The operating system supported are RedHat 6 and RedHat 5.

 

     My installed version of SmartXplorer doesn't support our new scheduler.  The error message I get says it's looking for a path to the Sun Grid tools which has been obsoleted by our system Admins.  Skipping the configuration check doesn't work since SmartXplorer can't spawn any jobs (can't find qmon).

 

     Does anyone know of a workaround for this issue?  I'm guessing the issue is with "PBS Torque" .  The error message I get is listed below.

 

ERROR: Could not find qmon. Please make sure Sun Grid Engine tools are in your PATH.

Please set this env XIL_SX_SKIP_CLUSTER_CONFIG_CHECK if you want to bypass this error.

0 Kudos
2 Replies
Moderator
Moderator
595 Views
Registered: ‎01-16-2013

Re: SmartXplorer Problems - Looking for a Workaround

@marvinscheinbart,

 

Did you try setting the env variable mentioned in error message?

XIL_SX_SKIP_CLUSTER_CONFIG_CHECK

 

--Syed

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------
0 Kudos
Adventurer
Adventurer
559 Views
Registered: ‎05-09-2014

Re: SmartXplorer Problems - Looking for a Workaround

Syed:

 

     I spoke to my system administrator about this issue.  The error is not being able to find the function qmon.  This program is part of the Sun Grid tools which are no longer supported by our system.  The Sun Grid tools have been replaced with PBS Torque which uses the command qsub to dispatch jobs.

 

     Setting XIL_SX_SKIP_CLUSTER_CONFIG_CHECK would not be of any help.

 

        Marv

 

0 Kudos