UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Instructor
Instructor
4,514 Views
Registered: ‎08-14-2007

SmartXplorer copy issue and AR #33219

I'm running a lot of builds on a project in ISE 11.5 and can't upgrade to 12.x because of

purchased IP.  I ran into the issue of AR #33219:

 

11.2 Smartxplorer - ERROR "Could not determine cost table value from strategy name" while copying the best strategy

 

This happens when using SmartXplorer in the increment cost table only mode.  The problem is

that all runs except the first have "CTnn" appended where "nn" is the cost table number for

that run, but the first run does not.  So if the first run happens to be the best, then you try to

copy the results and you get this error.  In the answer record you are advised as a workaround

to "manually copy over the options from that run," but doesn't give any information on how to do that.

 

So - first I tried to just copy all files in the "run1" subdirectory of the SmartXplorer_results folder.  That

just seemed to confuse the Navigator so I could never coerce it to generate the bitstream.

 

Finally I saw "smartxplorer.xml" in the SmartXplorer_results folder and opened it with a text editor.

By changing the first instance of "CurrentProjectNavigatorSettings" to "CurrentProjectNavigatorSettingsCTnn",

where nn is the cost table starting point for the run, I could use the normal copy results button

from smartxplorer within the Project Navigator.  I hopes this helps anyone else who runs into

the issue.

 

-- Gabor

11.2 Smartxplorer - ERROR "Could not determine cost table value from strategy name" while copying the best strategy

-- Gabor
3 Replies
Xilinx Employee
Xilinx Employee
4,490 Views
Registered: ‎02-11-2010

Re: SmartXplorer copy issue and AR #33219

For your information, this issue has been fixed in 13.1

0 Kudos
Observer linhu
Observer
4,461 Views
Registered: ‎12-21-2009

Re: SmartXplorer copy issue and AR #33219

I also encoutner the SmartXplorer copy issue in ISE12.X. It's good to hear it has been fixed in 13.X

0 Kudos
Highlighted
Visitor user4fpga
Visitor
4,384 Views
Registered: ‎06-30-2012

Re: SmartXplorer copy issue and AR #33219

Hi

I have a problem with smartxplorer in ISE 12.3.

ISE doen't show smartxplorer results and can't copy best strategy to project?

Please help me.

 

Tags (1)
0 Kudos