UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
9,800 Views
Registered: ‎04-20-2009

SmartXplorer launces more jobs than hosts in host list

Jump to solution

Hi all!

I just ran into a new quirk in SmartXplorer. I have a script to set up the tool that generates a host list file with a number of "localhost" lines to control the number of parallel lines. In this case 3 since I have 4 cores in my PC and want to save one for background activity. Moreover I set the number of passes to a large number to assure all built-in strategies will get run. This set up a 7-pass session and kicked off 3 parallel runs as expected, but when all of these where killed (for exceeding the timing score I set), the remaining 4 runs where all started at once, swamping my poor PC.

 

Has anyone seen this behavior before? It was new to me and I wonder what could have caused it. The command line executed was:

 

smartxplorer design.ngd -to "-v 10" -max_score 1000 -max_time "03:00:00" -p xc6slx100t-2-csg484 -area_report "slice;slice_reg;lut;bram;dsp48" -l hostlist -vp 10

 

...and the hostlist file contains this:

 

localhost

localhost

localhost

 

I run ISE 14.7 on a Windows-7 Professional PC.

 

I will give it a new try with “-vp 7” to specify the exact number of built-in strategies available and also experiment a bit to get it to perform extra runs with different cost tables for the best strategy, but I haven't gotten around to that yet.

 

Thanks!

/Lars

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Adventurer
Adventurer
16,785 Views
Registered: ‎04-20-2009

Re: SmartXplorer launces more jobs than hosts in host list

Jump to solution

Aha!

I think I got the coin to drop, finally! The script I am using is perfectly fine and the -vp 7 (or 10 or whatever) has nothing to do with the number of strategies run, but as stated in the documentation, decides how many extra runs of the best strategy will be run using different cost tables. It all became clear when I let the job run a little longer so it produced valid results and observed the 7 built-in strategies run, followed by 7 more runs of the “best” strategy with different cost tables.

 

So omitting -m results in all strategies to be run and (assuming at least one of them produced a valid result and was not cancelled by i.e. -max_score or -max_time) to be followed by the number of addition cost table altered runs as specified by the -vp. Sorry for being thick, but I still think it was a genuine bug that started me on this track. I just hadn’t seen this behavior before.

 

Cheers!

/Lars

0 Kudos
4 Replies
Xilinx Employee
Xilinx Employee
9,787 Views
Registered: ‎04-16-2012

Re: SmartXplorer launces more jobs than hosts in host list

Jump to solution
Hello,

Can you try turning off multi-threading option in map and P&R?

Thanks,
Vinay
--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Adventurer
Adventurer
9,780 Views
Registered: ‎04-20-2009

Re: SmartXplorer launces more jobs than hosts in host list

Jump to solution

Hi!

I am pretty sure multi-threading is off. The default is off according to the user guide (UG628) and there are no –mt in the command lines reported by SmartXplorer. Here are the lines for the currently best strategy:

 

map design.ngd -ol high -xe n -register_duplication on -w -p xc6slx100t-2-csg484 -o design_map.ncd .\run4\design.pcf

par design_map.ncd -ol high -xe n -w design.ncd .\run4\design.pcf

 

..well, more or less the command lines, I doctored the file name slightly not to reveal my project.

 

Now I’m even more confused, but at least I found that specifying the same number of runs as the number of built-in strategies seemed to cure the problem. I am not 100% sure as in the latest test I used the timeout number to get the first three jobs to terminate quickly and in the original case I let them continue until the -max_score kicked in, but I am reasonably confident this is what caused it.

 

My new confusion stems from the fact that according to the command-line user guide, I should have used the -m switch instead of the -vp switch to have the tool cycle through the strategies. At least according to this thread: http://forums.xilinx.com/t5/Implementation/Smartxplorer-Maximum-Parallel-Runs/m-p/354469/highlight/true#M6905, the -vp should use one and only one strategy and instead cycle through different cost tables for the number of runs specified. It is a bit unclear; one post in the above thread claims that specifying more runs than available strategies should produce additional variability passes once the strategies have been exhausted, but I have not seen this in my jobs.

 

I will replace –vp with –m in my script and have a go, and possibly follow another advice in the above thread and use the –mo and –po options in a second SmartXplorer run with options copied from the best strategy in the initial (-m) run.

 

Does that make sense?

 

Cheers!

/Lars

 

0 Kudos
Highlighted
Adventurer
Adventurer
16,786 Views
Registered: ‎04-20-2009

Re: SmartXplorer launces more jobs than hosts in host list

Jump to solution

Aha!

I think I got the coin to drop, finally! The script I am using is perfectly fine and the -vp 7 (or 10 or whatever) has nothing to do with the number of strategies run, but as stated in the documentation, decides how many extra runs of the best strategy will be run using different cost tables. It all became clear when I let the job run a little longer so it produced valid results and observed the 7 built-in strategies run, followed by 7 more runs of the “best” strategy with different cost tables.

 

So omitting -m results in all strategies to be run and (assuming at least one of them produced a valid result and was not cancelled by i.e. -max_score or -max_time) to be followed by the number of addition cost table altered runs as specified by the -vp. Sorry for being thick, but I still think it was a genuine bug that started me on this track. I just hadn’t seen this behavior before.

 

Cheers!

/Lars

0 Kudos
Adventurer
Adventurer
9,710 Views
Registered: ‎04-20-2009

Re: SmartXplorer launces more jobs than hosts in host list

Jump to solution

Just a small update: I think I can now confirm that is when (possibly two) strategy pass(es) is(are) killed by the "-max_time" parameter that SmartXplorer goes over the top and kicks off more runs than hosts in the list. It happened again just now, must be some kind of race condition inside the program since it only ever occurs if two or more jobs terminate at (almost) the same moment (which is the case when two of the initial jobs are killed by timeout). Really annoying bug, I think I will have to remove the -max_time from my scripts.

/Lars

 

0 Kudos