UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor dafeldib
Visitor
6,544 Views
Registered: ‎03-05-2014

The implementation process keeps ignoring my ucf file when running my tcl script!!

Jump to solution

Hi,

 

I do implement my design using GUI with no problems. Sometimes, the tools just ignores the ucf file. I just remove it from the project then add it again and rerun the implementation and voila it is seen and taken into consideration.

 

However, now I want to run the same using tcl script. I add the ucf file to my project and run implementation. No error /warning messages are given, but my .ucf file is totally ignored. It contains some LOC and some net assignment constraints.

Attached are my ucf and tcl files.

 

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
10,000 Views
Registered: ‎07-16-2008

Re: The implementation process keeps ignoring my ucf file when running my tcl script!!

Jump to solution

Trying adding option -uc in Translate process.

project set "Other Ngdbuild Command Line Options" "uc xxx.ucf" -process "Translate"

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

0 Kudos
3 Replies
Explorer
Explorer
6,524 Views
Registered: ‎04-28-2013

Re: The implementation process keeps ignoring my ucf file when running my tcl script!!

Jump to solution

Which version of vivado do you use ?

Why you don't use read_xdc command tcl?

nonsense
0 Kudos
Xilinx Employee
Xilinx Employee
10,001 Views
Registered: ‎07-16-2008

Re: The implementation process keeps ignoring my ucf file when running my tcl script!!

Jump to solution

Trying adding option -uc in Translate process.

project set "Other Ngdbuild Command Line Options" "uc xxx.ucf" -process "Translate"

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

0 Kudos
Visitor dafeldib
Visitor
6,510 Views
Registered: ‎03-05-2014

Re: The implementation process keeps ignoring my ucf file when running my tcl script!!

Jump to solution

Thanks Moderator, this solved my issue, I just had to add a dash before uc such that the command looks like this:

project set "Other Ngdbuild Command Line Options" "-uc xxx.ucf" -process "Translate"

 

 

Please, mark the post as solved.

Thanks again!!!

0 Kudos