cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
1,493 Views
Registered: ‎02-23-2016

Vivado stuck in implementation phase 4.1.1

Jump to solution

Hi,

 

Vivado (1016.04) implementation sometimes gets stuck in route_design (-directive default) during phase 4.1.1 even though there is no indications on any problems. It never continues after this message:

 

Phase 4.1.1 Update Timing
Phase 4.1.1 Update Timing | Checksum: 2ed6bd8c0

Time (s): cpu = 00:27:51 ; elapsed = 00:17:09 . Memory (MB): peak = 4908.734 ; gain = 390.227
INFO: [Route 35-416] Intermediate Timing Summary | WNS=0.077 | TNS=0.000 | WHS=-0.163 | THS=-17.992|

 

Does anyone know what causes this and is there any solution/workaround?

 

Br. Jacob

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Visitor
Visitor
1,750 Views
Registered: ‎02-23-2016

Re: Vivado stuck in implementation phase 4.1.1

Jump to solution

Hi Syed,

 

I couldn't find a proper solution so I rolled back my latest updates and re-implemented which actually solved the problem. I am unsure what caused the problem but the problem went away after re-implementation.

 

Br. Jacob

View solution in original post

0 Kudos
5 Replies
Highlighted
Mentor
Mentor
1,467 Views
Registered: ‎02-24-2014

Re: Vivado stuck in implementation phase 4.1.1

Jump to solution

The THS value of -17.992 indicates you have a lot of hold violations, perhaps many hundreds of them, and the router may be stuck trying to resolve them.   I suggest that you review your clocking structure, especially verifying that you have clock buffers in the right places.   Look in the synthesis log for warnings about this, that may help pinpoint the problem.

Don't forget to close a thread when possible by accepting a post as a solution.
Highlighted
Moderator
Moderator
1,419 Views
Registered: ‎01-16-2013

Re: Vivado stuck in implementation phase 4.1.1

Jump to solution

jkk@ms3e.dk,

 

did you fix hold violation? Are you still seeing the tool hang during routing?

 

--Syed

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------
0 Kudos
Highlighted
Visitor
Visitor
1,751 Views
Registered: ‎02-23-2016

Re: Vivado stuck in implementation phase 4.1.1

Jump to solution

Hi Syed,

 

I couldn't find a proper solution so I rolled back my latest updates and re-implemented which actually solved the problem. I am unsure what caused the problem but the problem went away after re-implementation.

 

Br. Jacob

View solution in original post

0 Kudos
Highlighted
Moderator
Moderator
1,412 Views
Registered: ‎01-16-2013

Re: Vivado stuck in implementation phase 4.1.1

Jump to solution

jkk@ms3e.dk,

 

Compare the log and utilization report file with and without latest updates which caused an increase in runtime.

 

--Syed

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------
0 Kudos
Highlighted
Visitor
Visitor
1,351 Views
Registered: ‎02-23-2016

Re: Vivado stuck in implementation phase 4.1.1

Jump to solution

I unfortunately deleted the log without the latest updates... I'll close the subject.

 

Thanks for the inputs.

0 Kudos