UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Participant sjg69
Participant
8,585 Views
Registered: ‎03-29-2012

XST crashing when I click 'play'

Whenever I click on the green 'play' icon to try and compile my verilog design targetting an XC9572XL, I get:

 

...

lots of stuff...

...

Design top has been optimized and fit into device XC9572XL-5-TQ100.
ERROR:ProjectMgmt:387 - TOE: ITclInterp::ExecuteCmd gave Tcl result 'can't read "iFileType": no such variable'.
Tcl_ErrnoId: unknown error
Tcl_ErrnoMsg: No error
_cmd: ::xilinx::Dpm::dpm_chTransformExecute dpm_fitterRun $piThisInterface
errorInfo: can't read "iFileType": no such variable
while executing
"if { $iFileType eq "UNKNOWN" } {
continue ; # unknown is just ignored, its probably .txt
}"
("foreach" body line 3)
invoked from within
"foreach sItem $lOutputFileList {
if { ![dpm_parseOutputFile $sItem $iDesign sFile iFileType fileOrigination] } {
if { $iFile..."
(procedure "dpm_chTransformOutput" line 15)
invoked from within
"dpm_chTransformOutput $iTranInst $lOutputFileList"
(procedure "dpm_fitterRun" line 477)
invoked from within
"$sCmd $iTransformInstance $sCmdArgs"
(procedure "dpm_chTransformExecuteEngine" line 100)
invokedTransformExecuteEngine $sFlowProc $iInterface $bRunTransformWithEmptyInputSet "
(procedure "::xilinx::Dpm::dpm_chTransformExecute" line 3)
invoked from within
"::xilinx::Dpm::dpm_chTransformExecute dpm_fitterRun $piThisInterface"

 

Any hints as to what's going wrong ? There are various warning about ports not being used (which is fair enough, I'm only about halfway through designing it) but it shouldn't crash, should it ?

 

Simon

0 Kudos
7 Replies
Participant sjg69
Participant
8,582 Views
Registered: ‎03-29-2012

Re: XST crashing when I click 'play'

Should probably mention that this is using ISE 14.5 (running on XP). The machine has plenty of RAM (16GB) and ISE is the only application installed on it.

 

Simon

0 Kudos
Xilinx Employee
Xilinx Employee
8,576 Views
Registered: ‎05-14-2008

Re: XST crashing when I click 'play'

It is not clear from the messages you gave that in which process this error occurred. Can you post more messages before the line "Design top has been optimized and fit into device XC9572XL-5-TQ100." so that we know what process was running at that time.

 

Vivian

-------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------------------------------
如果提供的信息能解决您的问题,请标记为“接受为解决方案”。
如果您认为帖子有帮助,请点击“奖励”。谢谢!
-------------------------------------------------------------------------------------------------
0 Kudos
Participant sjg69
Participant
8,572 Views
Registered: ‎03-29-2012

Re: XST crashing when I click 'play'

It was cpldfit.exe, from memory - there was a dialog box that came up asking me if I wanted to report it to Microsoft ... I can check tomorrow and get more log and maybe a screenshot because it reproduces every time.
0 Kudos
Participant sjg69
Participant
8,554 Views
Registered: ‎03-29-2012

Re: XST crashing when I click 'play'

Ok, I've attached 2 images, the first is the warning dialogue when cpldfit.exe crashes, the second is the result of clicking in that dialogue to see more info. The third is the entire log in the console. It's just 'fit' because everything worked up until then.

 

Cheers

Simon.

0 Kudos
Teacher eteam00
Teacher
8,535 Views
Registered: ‎07-21-2009

Re: XST crashing when I click 'play'

Try this solution (which disables Windows SmartHeaps).  It's very simple, and easy to undo.

 

-- Bob Elkind

SIGNATURE:
README for newbies is here: http://forums.xilinx.com/t5/New-Users-Forum/README-first-Help-for-new-users/td-p/219369

Summary:
1. Read the manual or user guide. Have you read the manual? Can you find the manual?
2. Search the forums (and search the web) for similar topics.
3. Do not post the same question on multiple forums.
4. Do not post a new topic or question on someone else's thread, start a new thread!
5. Students: Copying code is not the same as learning to design.
6 "It does not work" is not a question which can be answered. Provide useful details (with webpage, datasheet links, please).
7. You are not charged extra fees for comments in your code.
8. I am not paid for forum posts. If I write a good post, then I have been good for nothing.
0 Kudos
Xilinx Employee
Xilinx Employee
8,519 Views
Registered: ‎07-01-2008

Re: XST crashing when I click 'play'

I'm not sure you'll find much expertise here on CPLD tool issues. You might want to try the CPLD forum as well.

0 Kudos
Participant sjg69
Participant
8,512 Views
Registered: ‎03-29-2012

Re: XST crashing when I click 'play'

Well, I tried the approach suggested by eteam00, but it didn't seem to help me. cpldfit is still running, some 8 hours later, which seems excessive for a design that, according to the last time it did run, only took about 50% of the resources of the device and mapped in ~20 secs.

 

So I think I'll revert the change.

 

What caused it was when I expanded the state machine to include some more signals in the always @(...) block. Over the weekend I've re-jigged that anyway, so when I try the new code tomorrow, perhaps it won't be an issue again...

 

Simon.

0 Kudos