UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor cocies
Visitor
8,785 Views
Registered: ‎08-15-2013

apply the following bitgen swith "-g UnconstrainedPins:Allow"

Jump to solution

 Hallo Everyone,

I got an error by “Generate Programming File”. The error number is “Bitgen:342”.  I don’t want to assign the location for every Pin. I have tried the “bitgen -g UncontrainedPins:Allow” in the command line. But it doesn’t work. It is very hard for me, because I have never really worked with command line.

Thanks for all the help

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
13,468 Views
Registered: ‎06-05-2013

Re: apply the following bitgen swith "-g UnconstrainedPins:Allow"

Jump to solution

Hi,

 

Go to Generate Programing File & right click & check the process properties.

In general options you will find other bitgen command line option.

write the command there

 -g UnconstrainedPins:Allow

 

Thanks

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
6 Replies
Moderator
Moderator
8,776 Views
Registered: ‎06-05-2013

Re: apply the following bitgen swith "-g UnconstrainedPins:Allow"

Jump to solution

Hi Vintu,

 

It is recommended to do that. If you want to overcome the error message without specifying the LOCs as said before you can specify the switch  -g UnconstrainedPins:Allow in More options field of Bitstream settings and re-running bitgen.

 

Check the attachment.

 

thanks

-------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
sadd.PNG
0 Kudos
Xilinx Employee
Xilinx Employee
8,772 Views
Registered: ‎04-16-2012

Re: apply the following bitgen swith "-g UnconstrainedPins:Allow"

Jump to solution
Hi,

Use this command in Tcl console:

set_property BITSTREAM.General.UnconstrainedPins {Allow} [current_design]

Thanks.
--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Visitor cocies
Visitor
8,766 Views
Registered: ‎08-15-2013

Re: apply the following bitgen swith "-g UnconstrainedPins:Allow"

Jump to solution
I actually use ISE Navigator. Can I change it in Navigator.
0 Kudos
Moderator
Moderator
13,469 Views
Registered: ‎06-05-2013

Re: apply the following bitgen swith "-g UnconstrainedPins:Allow"

Jump to solution

Hi,

 

Go to Generate Programing File & right click & check the process properties.

In general options you will find other bitgen command line option.

write the command there

 -g UnconstrainedPins:Allow

 

Thanks

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Explorer
Explorer
401 Views
Registered: ‎12-08-2007

Re: apply the following bitgen swith "-g UnconstrainedPins:Allow"

Jump to solution

Is this Vivado?

 

I tried what you suggested but I get the following error (see attached)

 

How to assign this option in the Vivado?

Screen Shot 2018-12-28 at 13.52.05.png
0 Kudos
Explorer
Explorer
394 Views
Registered: ‎12-08-2007

Re: apply the following bitgen swith "-g UnconstrainedPins:Allow"

Jump to solution

I think I solved it as follows:

 

I created a .tcl file with :

 

set_property SEVERITY {Warning} [get_drc_checks NSTD-1]
set_property SEVERITY {Warning} [get_drc_checks UCIO-1]

 

then in the Bitstream settings, I pointed to this file in the first item called tcl.pre

0 Kudos