UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
6,652 Views
Registered: ‎04-28-2013

vivado 2013.3 's debug core is different from vivado 2013.2's ?

vivado 2013.3 's debug core is different from vivado 2013.2's ?

eg.

 

 with 2013.3 : create_debug_port  u_ila_0   probe

 with 2013.2:   create_debug_port  u_ila_0  PROBE

 

lowercase in 2013.3 , upcase in 2013.2 ?

 

I test my three cases , I also found 2013.3's timing results are worse than 2013.2's.  Did anybody has the same result with me ?

nonsense
0 Kudos
3 Replies
Xilinx Employee
Xilinx Employee
6,647 Views
Registered: ‎10-24-2013

Re: vivado 2013.3 's debug core is different from vivado 2013.2's ?

Hi,
This might be a typo. Is this causing any issues in your design?

Are you running with the same strategies in both versions and still seeing the timing issues?
Thanks,Vijay
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Xilinx Employee
Xilinx Employee
6,636 Views
Registered: ‎11-28-2007

Re: vivado 2013.3 's debug core is different from vivado 2013.2's ?

Hi nonsense,

 

Yes, I noticed this as well: in 2013.3 the ILA port names (clk, probe) are now lower-case.

I think this is related to the implementation of a corporate guideline for common naming of Xilinx IP.

 

Regarding your performance: this is a known issue. 2014.1 will have a lot of improvement in this area.

What you could try in the meantime is disable the advanced trigger feature.

 

 

Best regards

Dries

--------------------------------------------------------------------------------------------------------------------
Please mark the Answer as "Accept as solution" if the information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented by clicking the star next to the post.
Explorer
Explorer
6,614 Views
Registered: ‎04-28-2013

Re: vivado 2013.3 's debug core is different from vivado 2013.2's ?

My three cases are all run in  vivado tcl mode with the same tcl scripts .

 

The timing results  of vivado 2013.3's are all worse than the timing results of vivado2013.2's.

 

 

nonsense
0 Kudos