cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
1,225 Views
Registered: ‎04-28-2013

A question occured in installing Hardware server 2017.4

Jump to solution

When installing hardware server,  It always warning " VC ++ runtime lib error".

My OS windows7 SP1, 64 bit.

nonsense
0 Kudos
Reply
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
1,580 Views
Registered: ‎08-01-2008

The following options have been used to successfully launch Vivado IDE:

 

Running Vivado as Administrator.


Launching Vivado via TCL mode first:

  1. Click Start -> All Programs -> "Xilinx Design Tools" -> "Vivado <version number>" -> "Vivado <version number> Tcl Shell"
  2. Type vivado -mode tcl
  3. In the prompt type start_gui

Removing a corrupt vivado.ini file:

  1. Navigate to C:\Users\(Username)\AppData\Roaming\Xilinx\vivado\<version number>.
  2. Rename (or backup) the vivado.ini file.
  3. Re-launch Vivado and a new .ini will be created with default settings.

 


Ensuring that vvgl is a recognized executable:

 

To prevent an extra command window from being opened when the Vivado IDE is launched, the command line in the Start menu and Vivado Icon uses the "vvgl" command.  

If vvgl is not found or recognized, Vivado does not launch.

  • Try running the vivado.bat file from the command line (for example C:\Xilinx\Vivado\2013.4\.\bin\vivado.bat).
  • Try explicitly running vvgl from the Vivado install directory (for example  C:\Xilinx\Vivado\2013.4\bin\unwrapped\win64.o\vvgl.exe C:\Xilinx\Vivado\2013.4\.\bin\vivado.bat).

Removing a corrupt default.layout file:

    1. Navigate to C:\Users\(Username)\AppData\Roaming\Xilinx\vivado\<version number>.
    2. Rename (or backup) the default.layout file.
    3. Re-launch Vivado and a new layout file will be created with default settings.


Note: 
The vivado.ini and the default.layout files have been found to be out of sync or corrupt on some user systems.  

Therefore, they are specifically mentioned above.  

To be thorough, you could rename the entire directory (for example C:\Users\(Username)\AppData\Roaming\Xilinx\vivado\2013.4_bac).
 


Ensuring that the Microsoft Redistributable runtime library has been properly installed:

Note: If the redistributable library is missing, the failed launch is usually accompanied by an application error message window that states; "The application failed to initialize properly (0xc0150002). Click on OK to terminate the application."

  • Run both of the Visual C++ redistribution exes located at:

    • <installpath>\tps\win32\vcredist_x86.exe
    • <installpath>\tps\win64\vcredist_x64.exe


  1. Reboot the operating system 
    See (Xilinx Answer 45411) for more information.

 


Disabling the Digital Guardian Agent tool:

Multiple customers have seen that when they had Digital Guardian enabled, that Vivado 64 bit tool fails to launch, with no error message. 

All ISE tools work along with Vivado 32 bit open and run correctly.

In these cases, Having their IT Set Digital Guardian to ignore Vivado files or disabling it on the machine allowed the Vivado 64 bit tools to successfully launch.

 

 


 

Reset Flex Net Service

 

On some systems, a previously running Flex Net service prevented Vivado from opening.

See (Xilinx Answer 63279)  

 

 


 

Troubleshooting

 

If Vivado still fails to open after verifying the information above, the following actions may help in troubleshooting.

  1. Provide log and dmp files to Xilinx.  See (Xilinx Answer 55854) 
  2. Open Vivado when running Windows OS in safe mode and msconfig
    1. Open Windows in safe mode without networking and then launch and run Vivado.  
    2. If Vivado opens and runs successfully, start windows normally (using the msconfig configuration tool without system services or startup programs) and then launch and run Vivado.
    3. If Vivado continues to open and runs successfully, enable Microsoft services (note: other services are still disabled) and then launch and run Vivado.
    4. If Vivado continues to open and runs successfully, enable the remaining services one by one.

 

Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.

View solution in original post

2 Replies
Highlighted
Xilinx Employee
Xilinx Employee
1,581 Views
Registered: ‎08-01-2008

The following options have been used to successfully launch Vivado IDE:

 

Running Vivado as Administrator.


Launching Vivado via TCL mode first:

  1. Click Start -> All Programs -> "Xilinx Design Tools" -> "Vivado <version number>" -> "Vivado <version number> Tcl Shell"
  2. Type vivado -mode tcl
  3. In the prompt type start_gui

Removing a corrupt vivado.ini file:

  1. Navigate to C:\Users\(Username)\AppData\Roaming\Xilinx\vivado\<version number>.
  2. Rename (or backup) the vivado.ini file.
  3. Re-launch Vivado and a new .ini will be created with default settings.

 


Ensuring that vvgl is a recognized executable:

 

To prevent an extra command window from being opened when the Vivado IDE is launched, the command line in the Start menu and Vivado Icon uses the "vvgl" command.  

If vvgl is not found or recognized, Vivado does not launch.

  • Try running the vivado.bat file from the command line (for example C:\Xilinx\Vivado\2013.4\.\bin\vivado.bat).
  • Try explicitly running vvgl from the Vivado install directory (for example  C:\Xilinx\Vivado\2013.4\bin\unwrapped\win64.o\vvgl.exe C:\Xilinx\Vivado\2013.4\.\bin\vivado.bat).

Removing a corrupt default.layout file:

    1. Navigate to C:\Users\(Username)\AppData\Roaming\Xilinx\vivado\<version number>.
    2. Rename (or backup) the default.layout file.
    3. Re-launch Vivado and a new layout file will be created with default settings.


Note: 
The vivado.ini and the default.layout files have been found to be out of sync or corrupt on some user systems.  

Therefore, they are specifically mentioned above.  

To be thorough, you could rename the entire directory (for example C:\Users\(Username)\AppData\Roaming\Xilinx\vivado\2013.4_bac).
 


Ensuring that the Microsoft Redistributable runtime library has been properly installed:

Note: If the redistributable library is missing, the failed launch is usually accompanied by an application error message window that states; "The application failed to initialize properly (0xc0150002). Click on OK to terminate the application."

  • Run both of the Visual C++ redistribution exes located at:

    • <installpath>\tps\win32\vcredist_x86.exe
    • <installpath>\tps\win64\vcredist_x64.exe


  1. Reboot the operating system 
    See (Xilinx Answer 45411) for more information.

 


Disabling the Digital Guardian Agent tool:

Multiple customers have seen that when they had Digital Guardian enabled, that Vivado 64 bit tool fails to launch, with no error message. 

All ISE tools work along with Vivado 32 bit open and run correctly.

In these cases, Having their IT Set Digital Guardian to ignore Vivado files or disabling it on the machine allowed the Vivado 64 bit tools to successfully launch.

 

 


 

Reset Flex Net Service

 

On some systems, a previously running Flex Net service prevented Vivado from opening.

See (Xilinx Answer 63279)  

 

 


 

Troubleshooting

 

If Vivado still fails to open after verifying the information above, the following actions may help in troubleshooting.

  1. Provide log and dmp files to Xilinx.  See (Xilinx Answer 55854) 
  2. Open Vivado when running Windows OS in safe mode and msconfig
    1. Open Windows in safe mode without networking and then launch and run Vivado.  
    2. If Vivado opens and runs successfully, start windows normally (using the msconfig configuration tool without system services or startup programs) and then launch and run Vivado.
    3. If Vivado continues to open and runs successfully, enable Microsoft services (note: other services are still disabled) and then launch and run Vivado.
    4. If Vivado continues to open and runs successfully, enable the remaining services one by one.

 

Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.

View solution in original post

Highlighted
Explorer
Explorer
1,128 Views
Registered: ‎04-28-2013

Thanks  for your help !

It had made success on installing server according to your suggestion!

 

Best regards,

 

Bo Liu

nonsense
0 Kudos
Reply