UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer quiksuuver
Observer
5,764 Views
Registered: ‎08-03-2007

Cannot launch FPGA Editor in Suse 11.0

I am able to run the rest of the ISE (10.1.03) process in SUSE 11.0 (64-bit) but cannot get FPGA Editor to launch.  It fails launch the tools but there is no error message.  Any ideas?

0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
5,755 Views
Registered: ‎08-10-2007

Re: Cannot launch FPGA Editor in Suse 11.0

Suse 11.0 is not a supported OS.  Are you launching FPGA Editor from within ISE or on command line?  Have you tried launching the 32-bit version of FPGA Editor?  I'm not sure the exact name of the folder for Suse, but for RHEL it would be in the bin/lin folder.  If you launch it from there does it work?
0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
5,737 Views
Registered: ‎08-10-2008

Re: Cannot launch FPGA Editor in Suse 11.0

SUSE 11.0 is not offically supported for ISE10.1.  I have a workaround for this particular issue:

The Window Manager code requires the motif shared library support. LibXm.so.3 or higher, and uses the Microsoft Windows way of addressing display coordinates.
1.  Run Yast2 and install the openmotif package.
2.  Add a libXm.so.3 symbolic link to the /usr/lib64/
     $ cd /usr/lib64
     $ ln -s ./libXm.so.4.0.0 ./libXm.so.3
3.  Create a filter for the EXPORT parameter in /ISE/settings64.sh. Add the following to line 8
   # FIX FPGA_EDITOR motif dependencies issues
   export DISPLAY=`echo $DISPLAY|sed s/'\.0'//`

Tags (2)
0 Kudos