UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer themoonboy
Observer
341 Views
Registered: ‎08-19-2019

Cannot scan any license after loading into $HOME/.Xilinx

Jump to solution

I have successfully load my license into $HOME/.Xilinx, but cannot see any license in my local machine, through License Manager. As pictures show below.

Screenshot from 2019-09-27 13-55-19.pngScreenshot from 2019-09-27 13-54-56.png

Since there is no license, I cannot run code on Vivado since there is always error message shows "no valid license".

Anyone knows what's the problem ?

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Scholar watari
Scholar
206 Views
Registered: ‎06-16-2013

回复: Cannot scan any license after loading into $HOME/.Xilinx

Jump to solution

Hi @themoonboy 

 

Would you run the following command to check permission again ? Because you had a typo.

 

$ ls -lA $HOME/.Xilinx

 

=> "l" of ls command's option is not "I". It's small "L".

 

> Also, after runnig echo $LM_LICENSE_FILE, I get nothing. Also the $LM_LICENSE_FILE cannot be set in LVM under Linux, is this the ultimate reason of license loading problem?

 

That's right. You need to define LM_LICENSE_FILE like below.

 

ex)

export LM_LICENSE_FILE=/opt/license/nodelock/Xilinx.lic

 

Best regards,

8 Replies
Xilinx Employee
Xilinx Employee
290 Views
Registered: ‎07-16-2008

回复: Cannot scan any license after loading into $HOME/.Xilinx

Jump to solution

Does $HOME variable point to /root directory in the machine?

From the terminal, please try to set environment variable XILINXD_LICENSE_FILE to point to the Xilinx.lic and re-launch license manager for a check.

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Observer themoonboy
Observer
273 Views
Registered: ‎08-19-2019

回复: Cannot scan any license after loading into $HOME/.Xilinx

Jump to solution

Hi,

I install Vivado under sudo mode, then the default $HOME variable is /root/, and now could successfully load license into /root/.Xilinx/.  However, when running code, there still shows an error said invalid license.

I activate a divice-locked license by the UltraScale+ VCU 128 Evaluation Kit, and it should could be used in all kinds of platforms in Vivado, is there any problem about my account or license?

0 Kudos
Scholar watari
Scholar
265 Views
Registered: ‎06-16-2013

回复: Cannot scan any license after loading into $HOME/.Xilinx

Jump to solution

Hi @themoonboy 

 

Because user (Vivado was installed by root and Vivado was run by you) are different and I guess it has permission issue, too.

So, I suggest reinstalling Vivado by normal user or change the permission from root to normal user in your license directory.

 

Best regards,

 

Observer themoonboy
Observer
261 Views
Registered: ‎08-19-2019

回复: Cannot scan any license after loading into $HOME/.Xilinx

Jump to solution

Thanks,

Now I reinstall the Vivado (I am using HLx edition) by user mode, without sudo command in installation, and now the $HOME/.Xilinx/ is ~/Deskop/.Xilinx/, not root. However, when using VLM to load license, there is always permission issues said unable to load into $HOME/.Xilinx/ without any explanation, that is very strange.

0 Kudos
Scholar watari
Scholar
257 Views
Registered: ‎06-16-2013

回复: Cannot scan any license after loading into $HOME/.Xilinx

Jump to solution

Hi @themoonboy 

 

Would you run the following commands ?

 

$ ls -lA $HOME/.Xilinx/

$ echo $LM_LICENSE_FILE

 

Best regards,

Observer themoonboy
Observer
216 Views
Registered: ‎08-19-2019

回复: Cannot scan any license after loading into $HOME/.Xilinx

Jump to solution

Yes, and here is the what I get:

The current license file in $HOME/.Xilinx (which is under /home folder, not root) is not loaded by LVM, but by myself (using sudo mv /source/path/lincese /destination/path/), but seems like this is not a solution.

Also, after runnig echo $LM_LICENSE_FILE, I get nothing. Also the $LM_LICENSE_FILE cannot be set in LVM under Linux, is this the ultimate reason of license loading problem?

Screenshot from 2019-09-30 15-07-00.png

0 Kudos
Highlighted
Scholar watari
Scholar
207 Views
Registered: ‎06-16-2013

回复: Cannot scan any license after loading into $HOME/.Xilinx

Jump to solution

Hi @themoonboy 

 

Would you run the following command to check permission again ? Because you had a typo.

 

$ ls -lA $HOME/.Xilinx

 

=> "l" of ls command's option is not "I". It's small "L".

 

> Also, after runnig echo $LM_LICENSE_FILE, I get nothing. Also the $LM_LICENSE_FILE cannot be set in LVM under Linux, is this the ultimate reason of license loading problem?

 

That's right. You need to define LM_LICENSE_FILE like below.

 

ex)

export LM_LICENSE_FILE=/opt/license/nodelock/Xilinx.lic

 

Best regards,

Observer themoonboy
Observer
177 Views
Registered: ‎08-19-2019

回复: Cannot scan any license after loading into $HOME/.Xilinx

Jump to solution

Thank you very much, solution accepted!

0 Kudos