cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
9,528 Views
Registered: ‎02-27-2009

Command line installation linux

Jump to solution

Hi,

 

I would like to install a minimal set of Xilinx tools to a linux server, for using only the command line tools to build my projects automatically with scripts. The setup in the webinstaller of the Webpack 10.1 however stops immediately, because it needs an X server. Is there any way to install it from a simple terminal?

Or if I have to download the files manually, copy them to a certain directory, and set some environment variables, is there any documentation, or description of what to do exactly?

 

Thanks,

Istvan

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Observer
Observer
11,467 Views
Registered: ‎02-27-2009

Just copy your ISE install directory after it has been installed on a non-headless machine, and modify the 'settings32.sh' as necessary.  I have run the ISE tools successfully over NFS over a cell modem link, although it was quite slow...

 

Alternatively, you can X forward the install process, i.e.

laptop$ ssh -C -Y headless

Password for you@headless:

...

headless$ ./ise-install.sh

which should also work. (If -Y doesn't work on your machine, try -X.)

View solution in original post

2 Replies
Highlighted
Observer
Observer
11,468 Views
Registered: ‎02-27-2009

Just copy your ISE install directory after it has been installed on a non-headless machine, and modify the 'settings32.sh' as necessary.  I have run the ISE tools successfully over NFS over a cell modem link, although it was quite slow...

 

Alternatively, you can X forward the install process, i.e.

laptop$ ssh -C -Y headless

Password for you@headless:

...

headless$ ./ise-install.sh

which should also work. (If -Y doesn't work on your machine, try -X.)

View solution in original post

Highlighted
Visitor
Visitor
9,467 Views
Registered: ‎02-27-2009

Thanks, that worked.

 

I just copied the files from an other machine, and changed only the value of the XILINX environment variable in the beginning of the settings.sh, ran the script and the I could use my builder scripts. (I first tought there might be lots of other settings I have to do...)

 

Istvan

0 Kudos