cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
petgu
Visitor
Visitor
7,937 Views
Registered: ‎04-22-2015

[Common 17-345] A valid license was not found for feature 'Synthesis' and/or device 'xc7z010'

Hi,

I get the following error message when I try to synthesize:

 

"[Common 17-345] A valid license was not found for feature 'Synthesis' and/or device 'xc7z010'. Please run the Vivado License Manager for assistance in determining which features and devices are licensed for your system.

 

I cant return my license, when I try VLM says: "invalid option specified".

I cant manage licenses in the vivado webpage, the option is greyed out.

 

Running "report_environment -file <directory_name>/env.txt"   in the tcl log generates the attached file.

It looks like something is wrong but I dont now how to fix it.
I have made exceptions in my virus program for Xilinx related products.And I have tried with the firewall off.

 

I have the free WebPack version.

It worked fine for a couple of hours after I got the licenses, synthesis, simulating, implementing and generating bitstream.
Looking in VLM under view license status I think there was three activation based licenses from the beginning, I cant remember what they were called but currently there are just two called "Embedded_SDK" and "Vivado_WebPACK".

 

I run Vivado 2014.4 on windows 8.1 64-bit.

 

Would be great if someone could help me get going again.
Thank you!

 

 

0 Kudos
4 Replies
ashishd
Xilinx Employee
Xilinx Employee
7,930 Views
Registered: ‎02-14-2014

Hello,

Can you please follow below steps and share the result.

1. Open windows command prompt and navigate to <VIvado_installation_directory>\bin

2. Type command : xlicclientmgr -v "format=long" and share the output

3. Type command : xlicclientmgr -l and share the results
Regards,
Ashish
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
petgu
Visitor
Visitor
7,922 Views
Registered: ‎04-22-2015

Hi,
The results are attached.

Regards

Peter

0 Kudos
ashishd
Xilinx Employee
Xilinx Employee
7,881 Views
Registered: ‎02-14-2014

Hello @petgu,

 

From the output of these commands, it seems like the trusted storage on your machine is corrupted (there can be several reasons for it). To recover the trusted storage please refer below thread -

 

http://forums.xilinx.com/t5/Installation-and-Licensing/Vivado-License-Manager-will-not-allow-me-to-return-license/td-p/527697

Regards,
Ashish
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
seanz
Moderator
Moderator
7,880 Views
Registered: ‎03-27-2012

Hi Peter,

It seems your Trusted Storage has been corrupted. For the possible cause of this problem please refer to:
http://www.xilinx.com/support/answers/63683.html
You may need to regenerate and re-install your license.
As you are using free licenses, which can be found in every Xilinx account, you can easily generate a new one.
Regards,
Sean
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos