cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Participant
Participant
2,093 Views
Registered: ‎10-24-2008

[Common 17-345] A valid license was not found for feature 'Synthesis' and/or device 'xcvu9p-es1

Jump to solution

I've downloaded a sample design which is set to use the XCVU9P part. I've got a valid license for it, but Vivado is refusing to run. I've seen other posts, and it seems to point to the use of Vivado_HLS vs Vivado. I believe my license is for Vivado.

Screenshot.png

Screenshot-1.png

 

Screenshot.png
Screenshot-1.png
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Participant
Participant
2,743 Views
Registered: ‎10-24-2008

Re: [Common 17-345] A valid license was not found for feature 'Synthesis' and/or device 'xcvu9p-es1

Jump to solution

I was able to identify the problem. I had to run the application as root as Vivado couldn't see the boards otherwise. However, the license was installed as another user. When Vivado looked for the license, it didn't see it. I ran the license manager as root and reran Vivado. It now works.

View solution in original post

5 Replies
Highlighted
Moderator
Moderator
2,057 Views
Registered: ‎05-31-2017

Re: [Common 17-345] A valid license was not found for feature 'Synthesis' and/or device 'xcvu9p-es1

Jump to solution

Hi @ccdoss,

 

As, you are targeting the design to Engineering Sample device (es1). I would suggest you to get the license of xcvu9p-es1.

 

Thanks & Regards,
A.Shameer.

0 Kudos
Highlighted
Moderator
Moderator
2,036 Views
Registered: ‎11-09-2015

Re: [Common 17-345] A valid license was not found for feature 'Synthesis' and/or device 'xcvu9p-es1

Jump to solution

Hi @ccdoss,

 

You should change the project target to xcvu9p production silicon (not es1 or es2). Then it will work (it is harder to get an es1 silicon and this is unlikely that you will get it if you don't have an ES1 silicon).

 

Regards,

 

Florent


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
Highlighted
Participant
Participant
2,016 Views
Registered: ‎10-24-2008

Re: [Common 17-345] A valid license was not found for feature 'Synthesis' and/or device 'xcvu9p-es1

Jump to solution

I am not seeing an option to select a typical production part. It is either es1 or eval. When I specified eval before, I got the same error.

0 Kudos
Highlighted
Participant
Participant
2,744 Views
Registered: ‎10-24-2008

Re: [Common 17-345] A valid license was not found for feature 'Synthesis' and/or device 'xcvu9p-es1

Jump to solution

I was able to identify the problem. I had to run the application as root as Vivado couldn't see the boards otherwise. However, the license was installed as another user. When Vivado looked for the license, it didn't see it. I ran the license manager as root and reran Vivado. It now works.

View solution in original post

Highlighted
Moderator
Moderator
1,947 Views
Registered: ‎11-09-2015

Re: [Common 17-345] A valid license was not found for feature 'Synthesis' and/or device 'xcvu9p-es1

Jump to solution

Hi @ccdoss,

 

Thank you for sharing your observations.

 

As the issue is fixed, could you mark this issue as solved by marking a response a solution?

 

Thanks,

 

Florent


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos