cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
helmut.rathgen
Observer
Observer
4,831 Views
Registered: ‎11-10-2010

ERROR: [Common 17-1374] Display test failed. Please check DISPLAY environment variable and X server permissions for remote display

I have two up-to-date arch linux installations.

 

On one of them Vivado runs fine, on the other I get (since a package update run today) this error when I start vivado:

 

ERROR: [Common 17-1374] Display test failed. Please check DISPLAY environment variable and X server permissions for remote display

 

The display variable is set properly and is the same (on both installations).

 

Can you help me with further debugging?

 

Thank you for your help!

 

- Helmut

0 Kudos
3 Replies
balkris
Xilinx Employee
Xilinx Employee
4,824 Views
Registered: ‎08-01-2008

In you Linux OS, if you display the environment variable $DISPLAY you should get host name 

You can try to change it to localhost as per $DISPLAY commend 

Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
helmut.rathgen
Observer
Observer
4,812 Views
Registered: ‎11-10-2010

As I said, the DISPLAY environment variable is set correctly on both machines. Vivado works on one machine and doesn't on the other. So, it cannot be a problem with the DISPLAY environment variable.

0 Kudos
msdarvishi
Explorer
Explorer
3,958 Views
Registered: ‎03-06-2014

Hi

I just tumbled into this post while I encountered the same problem and I was looking for a solution for it.

 

Here is what to do in order to solve the problem. I just write it here for future users  to solve their problems quickly and save their time.

 

Pleasenote that in remote connection to another computer if you put the following command

ssh IP_addr_of_host_machine

you will get the ERROR message regarding the environment variable settings for DISPLAY.

 

In order to let the localhost to set this parameter, just run the following command

 

ssh   -X    IP-addr_of_host_machine

Now it works and you won't get the error message!

Enjoy!

 

Regards,

MD