cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Explorer
Explorer
378 Views
Registered: ‎05-03-2018

Encryption IP no license while implementation

Jump to solution

Hello,
I am trying to download and install the IP encryption license for my account.
On successful downloading, it shows (see screenshot attached) it has been installed.
But, when I try to implement it using the encrypt command it says I do not have the license.
Further, I cannot find the license in my license manager either.

Do you have any suggestion on what to do ?
BR
Andrea

ProdLicens.jpg
0 Kudos
Reply
1 Solution

Accepted Solutions
Participant
Participant
305 Views
Registered: ‎11-21-2020

@andreac_avnet 

I had a similar issue which puzzled me quite a lot You have to had a couple of lines before the key

`protect version = 2
`protect encrypt_agent = "XILINX"
`protect encrypt_agent_info = "Xilinx Encryption Tool 2017"
`protect begin_commonblock
`protect control error_handling = "delegated"
`protect control decryption = (activity == simulation) ? "false" : "true"
`protect end_commonblock
`protect begin_toolblock
`protect rights_digest_method="sha256"

and after the key

`protect control xilinx_configuration_visible = "false"
`protect control xilinx_enable_modification = "false"
`protect control xilinx_enable_probing = "false"
`protect control xilinx_enable_bitstream = "true"
`protect control decryption = (xilinx_activity == simulation) ? "true" : "true"
`protect end_toolblock = ""

This control the whole encryption process as explained in the IP packaging user guide (UG1118, chapter 6). To add these extra lines, I add to create my own key file. Same procedure with the verilog key (although not exactly the same syntax).

View solution in original post

4 Replies
Participant
Participant
366 Views
Registered: ‎11-21-2020

I had a similar problem. I was trying to encrypt with an old IEEE 1735 v1 public key. Once I changed for the proper key delivered in the xilinx path, it worked.

Explorer
Explorer
314 Views
Registered: ‎05-03-2018

Hello,
attached the message that I receive.

BR
Andrea

temix_encryption.JPG
0 Kudos
Reply
Participant
Participant
306 Views
Registered: ‎11-21-2020

@andreac_avnet 

I had a similar issue which puzzled me quite a lot You have to had a couple of lines before the key

`protect version = 2
`protect encrypt_agent = "XILINX"
`protect encrypt_agent_info = "Xilinx Encryption Tool 2017"
`protect begin_commonblock
`protect control error_handling = "delegated"
`protect control decryption = (activity == simulation) ? "false" : "true"
`protect end_commonblock
`protect begin_toolblock
`protect rights_digest_method="sha256"

and after the key

`protect control xilinx_configuration_visible = "false"
`protect control xilinx_enable_modification = "false"
`protect control xilinx_enable_probing = "false"
`protect control xilinx_enable_bitstream = "true"
`protect control decryption = (xilinx_activity == simulation) ? "true" : "true"
`protect end_toolblock = ""

This control the whole encryption process as explained in the IP packaging user guide (UG1118, chapter 6). To add these extra lines, I add to create my own key file. Same procedure with the verilog key (although not exactly the same syntax).

View solution in original post

Explorer
Explorer
282 Views
Registered: ‎05-03-2018
Hello,
Ok I'll try this one and let you know.

Thanks a lot.
BR
Andrea
0 Kudos
Reply