UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor
Contributor
550 Views
Registered: ‎01-25-2018

Error opening SDK 2018.2 "Intializing s/w repositories"

Jump to solution

Whenever I launch SDK (either from command line or Vivado) I get an error: SDK error "initialize s/w repositories"

In the SDK Log, I get the following:

13:39:53 INFO : Registering command handlers for SDK TCF services
13:39:53 INFO : Launching XSCT server: xsct -n -interactive /home/sl31870/sdk_2018_workspace/temp_xsdb_launch_script.tcl
13:39:53 INFO : XSCT server has started successfully.
13:39:53 INFO : Successfully done setting XSCT server connection channel 
13:39:53 ERROR : Failed to call init_repo
Reason: no files matched glob pattern "*"
13:39:53 ERROR : Exception raised in executing the command =Failed to call init_repo
Reason: no files matched glob pattern "*" 
13:39:53 INFO : Successfully done setting SDK workspace 

Also, I can't close SDK because of:

An error has occurred. See error log for more details.
Could not initialize class com.xilinx.sdk.sw.SwDbUtils$SwReposManHolder

Any help would be greatly appreciated.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Contributor
Contributor
528 Views
Registered: ‎01-25-2018

Re: Error opening SDK 2018.2 "Intializing s/w repositories"

Jump to solution

Clearing out .Xilinx in my home directory didn't fix it.  Re-installing the entire Xilinx Design Suite did.

Things are now working.

View solution in original post

2 Replies
Highlighted
Contributor
Contributor
529 Views
Registered: ‎01-25-2018

Re: Error opening SDK 2018.2 "Intializing s/w repositories"

Jump to solution

Clearing out .Xilinx in my home directory didn't fix it.  Re-installing the entire Xilinx Design Suite did.

Things are now working.

View solution in original post

Newbie ashanuom
Newbie
310 Views
Registered: ‎06-18-2019

Re: Error opening SDK 2018.2 "Intializing s/w repositories"

Jump to solution

I had the same issue. Turned out that the antivirus and specially the firewall was blocking the SDK from accessing online repositries and several other urls which are required for the initialization of it.

Hence, disable your antivirus and firewall then mark the the already blocked xilinx content in your antivirus vault as exceptions and try opening SDK. But the most reliable way would be to reinstall Vivado by disabling your firewall and antivirus and give full permission to access online resources during install. (A message will generally pop up asking for permission). 

Hope this helps!