UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor acleone
Visitor
18,143 Views
Registered: ‎05-07-2010

Guide for ISE 12.1 on 64-bit Ubuntu 10.04

Installation

  1. Save the downloaded 12.1 archive anywhere (it's just the setup/install files)
  2. Extract the archive (right click -> Extract here)
  3. Open a terminal (Ctrl + Alt + t), navigate to the folder, and run xsetup as root:
    cd Xilinx_ISE_DS_Lin_12.1_M.53d.0.4/
    sudo ./xsetup
  4. Follow the instructions in the setup wizard that pops up, and use the default install location

 

 

run_ise.sh Script and Adding the Launcher to the Applications Menu

  1. Create a new file in your home folder, run_ise.sh, containing:
    #!/bin/bash
    
    ISE_DS_DIR=/opt/Xilinx/12.1/ISE_DS
    
    cd "$ISE_DS_DIR"
    source "$ISE_DS_DIR"/settings64.sh
    
    export LANG=''  # reset locale to English to fix decimal/comma seperation
    
    "$ISE_DS_DIR"/ISE/bin/lin64/ise
  2. Make the run_ise.sh script executable:
    chmod u+x run_ise.sh
  3. Create an applications menu launcher for the run_ise.sh script:
    1. Right click "Applications" on the top bar and then "Edit Menus"
    2. Click the Programming Category on the Left and then "New Item" on the right
    3. Change Type: to "Application in Terminal", Name: Xilinx ISE 12.1, Command: point to the run_ise.sh script

 

 

64-bit Fix for PlanAhead

  1. By default, PlanAhead will try to use 32-bit executables.
    1. Open /opt/Xilinx/12.1/ISE_DS/PlanAhead/bin/rdiArgs.sh in gedit as root:
      sudo gedit /opt/Xilinx/12.1/ISE_DS/PlanAhead/bin/rdiArgs.sh
    2. Change lines 7-11 from
      #
      # Default to 32bit platform options
      #
      RDI_PLATFORM=lnx32
      RDI_JAVA_PLATFORM=i386
      to
      #
      # Default to 64bit platform options
      #
      RDI_PLATFORM=lnx64
      RDI_JAVA_PLATFORM=amd64

 

 

Change PDF Viewer to evince

  1. Create a symbolic link from /usr/bin/evince to /usr/bin/acroread:
    sudo ln -s /usr/bin/evince /usr/bin/acroread
Tags (1)
19 Replies
Adventurer
Adventurer
18,037 Views
Registered: ‎05-11-2010

Re: Guide for ISE 12.1 on 64-bit Ubuntu 10.04

Instead of creating the acroread script, you can just make a softlink:

sudo ln -s /usr/bin/evince /usr/bin/acroread

(it would be a better idea to create the link on /usr/local/bin instead of /usr/bin, but I don't know if Xilinx runs `/usr/bin/acroread document.pdf` or just `acroread document.pdf`)

 

0 Kudos
Visitor acleone
Visitor
18,026 Views
Registered: ‎05-07-2010

Re: Guide for ISE 12.1 on 64-bit Ubuntu 10.04

Good catch.  A symbolic link is much cleaner.

0 Kudos
Adventurer
Adventurer
17,579 Views
Registered: ‎05-11-2010

Re: Guide for ISE 12.1 on 64-bit Ubuntu 10.04

I've just noticed that XPS 12.1 BSB wizard (and maybe some other products of the Xilinx suite) doesn't work if your system uses a locale that uses commas instead of periods as decimal separator ("3,14" instead of "3.14"). If this is your case, you may want to add this somewhere on your .sh script:

export LANG=''

This removes the locale for the program, and makes it use the default one (English, decimal period).

 

0 Kudos
Visitor teun.compen
Visitor
17,383 Views
Registered: ‎05-12-2010

Re: Guide for ISE 12.1 on 64-bit Ubuntu 10.04

I installed ISE 12.1 on a Centos 5.4 PC, but how do I start it? With 11.5 I could start XPS or ISE by executing 'xps' or 'ise' on the commandline after running the scripts. For some reason this won't work with 12.1. What am I doing wrong?

0 Kudos
Xilinx Employee
Xilinx Employee
17,332 Views
Registered: ‎08-03-2007

Re: Guide for ISE 12.1 on 64-bit Ubuntu 10.04

Did you source the settings script within the Xilinx directory?  Should be in the same level as ISE, EDK, PlanAhead...

0 Kudos
Visitor teun.compen
Visitor
17,238 Views
Registered: ‎05-12-2010

Re: Guide for ISE 12.1 on 64-bit Ubuntu 10.04

When I run the scripts I am able to run ISE. For some reason I cannot run XPS. This is what I did:

 

 

[teun@bdaz1100 ~]$ cd /opt/Xilinx/12.1/ISE_DS/
[teun@bdaz1100 ISE_DS]$ source settings32.sh 
[teun@bdaz1100 ISE_DS]$ cd PlanAhead/
[teun@bdaz1100 PlanAhead]$ source settings32.sh 
[teun@bdaz1100 PlanAhead]$ cd ../ISE/
[teun@bdaz1100 ISE]$ source settings32.sh 
[teun@bdaz1100 ISE]$ cd ../EDK/
[teun@bdaz1100 EDK]$ source settings32.sh 
[teun@bdaz1100 EDK]$ cd bin/lin/
[teun@bdaz1100 lin]$ ./xps
[teun@bdaz1100 lin]$ 

 

 

0 Kudos
Visitor reconfig15
Visitor
17,207 Views
Registered: ‎06-13-2010

Re: Guide for ISE 12.1 on 64-bit Ubuntu 10.04

And how should one start Coregen in Ubuntu? On windows you can simply go to the program folder in the start menu and you can start it but I haven't  yet found any executable file named "coregen" in the installation directory in Ubuntu.

0 Kudos
Visitor reconfig15
Visitor
17,206 Views
Registered: ‎06-13-2010

Re: Guide for ISE 12.1 on 64-bit Ubuntu 10.04

@teun, try running the settings.sh file in the "common" directory as well. It may help.

0 Kudos
Visitor teun.compen
Visitor
17,151 Views
Registered: ‎05-12-2010

Re: Guide for ISE 12.1 on 64-bit Ubuntu 10.04

Yesterday I installed 12.1 on a 64bit Red Hat Enterprise Linux PC. After running the settings64.sh script I could start ISE or XPS just like I could start it on my own pc with 11.5. Just type 'xps' or 'ise' on the command line of the terminal and the tool starts. Running settings32.sh script makes no difference, it just works as it should.

 

I reinstalled 12.1 on my own pc (Centos 5.4) but it won't make any difference. For some reason I can not start XPS or ISE. Could the installation of 11.5 have any influence? 11.5 is not installed on the Red Hat PC.

0 Kudos
Adventurer
Adventurer
15,008 Views
Registered: ‎05-29-2009

Re: Guide for ISE 12.1 on 64-bit Ubuntu 10.04

Thanks, that's helpful. I'm still having a problem with Chipscope 12.1 on Ubuntu 10.04 64-bit though. Is there a chance it's having a 32-bit vs. 64-bit executable issue as well? When I double click Analyze Design Using Chipscope from ISE I get the following message:

 

 

Running analyzer...
Command Line: -cwd "/fpga/VHDLRef/mig_v3_4/example_design/par" analyzer -intstyle ise -project "/fpga/VHDLRef/mig_v3_4/example_design/par/example_top.cpj" -bit_default "/fpga/VHDLRef/mig_v3_4/example_design/par/example_top.bit"
Process "Analyze Design Using Chipscope" launched successfully

 

Running analyzer...Command Line: -cwd "/fpga/VHDLRef/mig_v3_4/example_design/par" analyzer -intstyle ise -project "/fpga/VHDLRef/mig_v3_4/example_design/par/example_top.cpj" -bit_default "/fpga/VHDLRef/mig_v3_4/example_design/par/example_top.bit"Process "Analyze Design Using Chipscope" launched successfully

 

Of course, nothing actually opens. On Red Hat RHEL 5 64-bit this works.

 

Also, is there any way to prevent the Terminal window from appearing/lingering after ISE's done launching, or have it not show all-together? Thanks.

Running analyzer...Command Line: -cwd "/fpga/VHDLRef/mig_v3_4/example_design/par" analyzer -intstyle ise -project "/fpga/VHDLRef/mig_v3_4/example_design/par/example_top.cpj" -bit_default "/fpga/VHDLRef/mig_v3_4/example_design/par/example_top.bit"Process "Analyze Design Using Chipscope" launched successfully

0 Kudos
Visitor sonson170
Visitor
14,764 Views
Registered: ‎07-24-2010

Re: Guide for ISE 12.1 on 64-bit Ubuntu 10.04

Hi all

I made all procedure mentioned by acleone, but it dosenot work.

Here is my script as mentioned in this post:

 cd Xilinx_ISE_DS_Lin_12.1_M.53d.0.4/
sudo ./xsetup
 sudo: ./xsetup: command not found

Then I tried:

sudo bash xsetup
 xsetup: line 25: ./bin/lin/xsetup: Permission denied

 

And also tried:
 sudo dash xsetup
 xsetup: 32: ./bin/lin/xsetup: Permission denied
 
I'm using Ubuntu 10.04 LTS on 32-bit machine.

 

can anyone help me?

0 Kudos
Adventurer
Adventurer
14,755 Views
Registered: ‎05-29-2009

Re: Guide for ISE 12.1 on 64-bit Ubuntu 10.04

Are you doing this from a section of your drive where you have write permission? The Xilinx setup software needs to be able to write to wherever it's being launch from. This makes for a hard time installing from the CD directly :) If that's what you were trying to do, copy the contents of the CD/DVD to your hard drive first.

0 Kudos
Visitor sonson170
Visitor
14,742 Views
Registered: ‎07-24-2010

Re: Guide for ISE 12.1 on 64-bit Ubuntu 10.04

Thank you 

 

Xilinx_ISE_DS_Lin_12.1_M.53d.0.4.tar

0 Kudos
Newbie ilghiz
Newbie
14,728 Views
Registered: ‎07-25-2010

Re: Guide for ISE 12.1 on 64-bit Ubuntu 10.04

Hi,

 

I recently installed ISE Web eddition at my Ubuntu 10.04 on amd64 platform, register my web licence, followed by instructions on this topic to generate run_ise and start the ISE. It is starteb, but it produce:

 

./run_ise: line 10:  5675 Segmentation fault      "$ISE_DS_DIR"/ISE/bin/lin64/ise

any time when I try to create new project. I am trying to allocate new dir in my home like: ~/FPGA/first, set everything to Spartan 3a DSP, and when I press the button "Finish" it waits... waits a lot, and when I press this button again or any other buttons, it crashes.

 

Please, advice me what to do!

 

Sincerely,

 

Ilghiz

0 Kudos
Newbie ilghiz
Newbie
14,726 Views
Registered: ‎07-25-2010

Re: Guide for ISE 12.1 on 64-bit Ubuntu 10.04

At the concole it writes:

 

(x) ERROR: unknown project version :.

(x) ERROR: project cannot be migrated.

0 Kudos
Visitor jurban15
Visitor
14,340 Views
Registered: ‎06-22-2010

Re: Guide for ISE 12.1 on 64-bit Ubuntu 10.04

Thanks a lot for this tip. The instructions work in Linux Mint 9 Isadora as well, except for a small change to step 3. To create a shortcut, drag run_ise.sh to the Linux Mint icon in the main toolbar.

0 Kudos
Adventurer
Adventurer
13,800 Views
Registered: ‎05-11-2010

Re: Guide for ISE 12.1 on 64-bit Ubuntu 10.04

Just found out that

export LC_NUMERIC=C

also works for the decimal comma bug, and doesn't cause child processes (evince, firefox...) use English when the locale is set to another language.

 

I'm working on a post-installation script to automate everything (creation of wrapper script, bash completion, cable drivers, installation of dependencies, symbolic links...). Attached to this message.

I haven't tested it, but it may work on Ubuntu and maybe Debian. It's more like a list of steps I've followed myself. I recommend to check it before running it, just in case.

 

By the way, is editing PlanAhead/bin/rdiArgs.sh the only way around for the 64-bit problem? That script is supposed to work for 64-bit architectures if you call it with the -m64 command line option. No clue where's that script called from, though.

 

EDIT: Attachment updated; there was a bad mistake on line 45.

 

0 Kudos
Adventurer
Adventurer
12,076 Views
Registered: ‎05-11-2010

Re: Guide for ISE 12.1 on 64-bit Ubuntu 10.04


@cousteau wrote:

I've just noticed that XPS 12.1 BSB wizard (and maybe some other products of the Xilinx suite) doesn't work if your system uses a locale that uses commas instead of periods as decimal separator ("3,14" instead of "3.14").


As of Xilinx 14.1, this bug seems to persist.

0 Kudos
Newbie ljubo
Newbie
6,377 Views
Registered: ‎03-27-2015

Re: Guide for ISE 12.1 on 64-bit Ubuntu 10.04

hello!

I've set the right path but can't run sudo ./xsetup. It says sudo: ./xsetup: command not found.
I've seen previous solution by sonson, but I've downloaded tar file and extracted it on desktop.
Do you have any idea what's going on?
Thanks in forward.

0 Kudos