UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor ikpdarmstadt
Visitor
16,859 Views
Registered: ‎05-17-2011

ISE 13.1 on kubuntu 11.04

Jump to solution

Hi,

 

I've installed an ISE 13.1 on a new kubuntu 11.04 (32 bit). The installation went fine, and ISE starts, but if I try to compile a project (through a makefile) the compilation stops with an error. The procedure is as follows:

 

 

.  /opt/Xilinx/13.1/ISE_DS/settings32.sh
make
gcc sourcecode.c -options
/usr/lib/i386-linux-gnu/gcc/i686-linux-gnu/4.5.2/cc1: /opt/Xilinx/13.1/ISE_DS/common/lib/lin/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib/libppl_c.so.2)
/usr/lib/i386-linux-gnu/gcc/i686-linux-gnu/4.5.2/cc1: /opt/Xilinx/13.1/ISE_DS/common/lib/lin/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/libppl_c.so.2)
/usr/lib/i386-linux-gnu/gcc/i686-linux-gnu/4.5.2/cc1: /opt/Xilinx/13.1/ISE_DS/common/lib/lin/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/libppl_c.so.2)
/usr/lib/i386-linux-gnu/gcc/i686-linux-gnu/4.5.2/cc1: /opt/Xilinx/13.1/ISE_DS/common/lib/lin/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib/libppl_c.so.7)
/usr/lib/i386-linux-gnu/gcc/i686-linux-gnu/4.5.2/cc1: /opt/Xilinx/13.1/ISE_DS/common/lib/lin/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/libppl_c.so.7)
/usr/lib/i386-linux-gnu/gcc/i686-linux-gnu/4.5.2/cc1: /opt/Xilinx/13.1/ISE_DS/common/lib/lin/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/libppl_c.so.7)
/usr/lib/i386-linux-gnu/gcc/i686-linux-gnu/4.5.2/cc1: /opt/Xilinx/13.1/ISE_DS/common/lib/lin/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/libppl_c.so.4)

 

 

These errors won't appear, if one don't source the settings32.sh, but then the coregen breaks with an error, which may be caused by the inapprobiate libraries.

The same project compiled fine on a kubuntu 10.10(64bit), so I wonder, if there might be an issue with the new ubuntu version and ISE?

 

Has somebody else tried something similar and succeeded? Is this problem known?

 

Thanks for all answers

1 Solution

Accepted Solutions
Visitor jo21053
Visitor
19,747 Views
Registered: ‎05-25-2011

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

Update to my fix above:

 

I started having libstdc++ issues again when running some very particular features. While tracking the source of the problems down I discovered that there are more stdc libraries hidden in other folders. Also, it turns out linking is unnecessary. If the libraries are moved or renamed to soming the Xilinx programs are not expecting they'll give up and search for your system libraries and locate them just fine. Here is the revised solution with new directories and no links:

cd /opt/Xilinx/13.1/ISE_DS/ISE/lib/lin/
mkdir orig && mv libstdc++* orig
cd /opt/Xilinx/13.1/ISE_DS/ISE/lib/lin64/
mkdir orig && mv libstdc++* orig
cd /opt/Xilinx/13.1/ISE_DS/common/lib/lin/
mkdir orig && mv libstdc++* orig
cd /opt/Xilinx/13.1/ISE_DS/common/lib/lin64/
mkdir orig && mv libstdc++* orig

 

View solution in original post

21 Replies
Teacher drjohnsmith
Teacher
16,856 Views
Registered: ‎07-09-2009

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

In know a lot of people who would be very happy if xilinx officialy supported ubunto,

 

but till then,

 

good luck, and post if you get it working,

 

<== If this was helpful, please feel free to give Kudos, and close if it answers your question ==>
0 Kudos
Voyager
Voyager
16,853 Views
Registered: ‎01-28-2008

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

Hi Kubuntuer,

 

  It seems ISE adds its library path in from of the system libraries in the $LD_LIBRARY_PATH environment variable, like:

 

 

/opt/xilinx_13.1/ISE_DS/common/lib/lin64:/opt/xilinx_13.1/ISE_DS/ISE/sysgen/lib:/opt/xilinx_13.1/ISE_DS/ISE/lib/lin64:/opt/xilinx_13.1/ISE_DS/ISE/smartmodel/lin64/installed_lin64/lib:/opt/xilinx_13.1/ISE_DS/EDK/lib/lin64:/opt/xilinx_13.1/ISE_DS/common/lib/lin64:/opt/xilinx_13.1/ISE_DS/ISE/sysgen/lib:/opt/xilinx_13.1/ISE_DS/ISE/lib/lin64:/opt/xilinx_13.1/ISE_DS/ISE/smartmodel/lin64/installed_lin64/lib:/opt/xilinx_13.1/ISE_DS/EDK/lib/lin64

 and this possibly affects the gcc compiler by looking into ISE paths before the system paths. You may have to hide this variable before running gcc and then bring it back after gcc is done. Something like:

 

LD_LIBRARY_PATH_SAVE=$LD_LIBRARY_PATH

export LD_LIBRARY_PATH=

gcc ...

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH_SAVE

 

  I haven't tried this and you may have to play around with it. Please post if you get it working.

 

Good luck,

-Pat

 

 

https://tuxengineering.com
Visitor ikpdarmstadt
Visitor
16,837 Views
Registered: ‎05-17-2011

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

Thanks for the suggestion. After some try and error I've managed to include this into my makefile. But unfortunately this hasn't solved my problem with the coregen. It seems, that coregen won't work correctly under natty.

 

I will fall back to maverick, for now.

 

Thanks to all, who replied.

0 Kudos
Visitor jo21053
Visitor
16,765 Views
Registered: ‎05-25-2011

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

Is there any particular reason you're running a 32bit ISE and a 32bit kubuntu?

 

Currently I'm successfully running 64bit ISE 13.1 on 64bit Ubuntu Natty 11.04. Below is a solution that may still work to fix those nasty libstdc++ errors, even on 32bit software.

 

There was one trick I needed to get rid of similar errors like: ERROR: libstdc++.so.6: version `GLIBCXX_3.4.14' not found

 

First change to the appropriate ISE library directory. Move the original libstdc++.so.6 that's giving us problems to a safe backup location. Then create a link to the host system's libstdc++. Depending on whether your ISE and linux is 32 or 64bits the directories will be slightly different, lin vs lin64... etc. The following is the exact set of commands which fixed mine. I was surprised that in my 64bit Ubuntu the only stdc++ was in lib32 so make sure you check it's location before linking.

 

 

cd /opt/Xilinx/13.1/ISE_DS/ISE/lib/lin64/
mv libstdc++.so.6 libstdc++.so.6.orig
ln -s /usr/lib32/libstdc++.so.6 libstdc++.so.6
Newbie waldek85
Newbie
16,605 Views
Registered: ‎06-16-2011

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

Thanks a lot. It helped me to fix it up in OpenSUSE 11.4. This is a good way to resolve that problem.

0 Kudos
Visitor jo21053
Visitor
19,748 Views
Registered: ‎05-25-2011

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

Update to my fix above:

 

I started having libstdc++ issues again when running some very particular features. While tracking the source of the problems down I discovered that there are more stdc libraries hidden in other folders. Also, it turns out linking is unnecessary. If the libraries are moved or renamed to soming the Xilinx programs are not expecting they'll give up and search for your system libraries and locate them just fine. Here is the revised solution with new directories and no links:

cd /opt/Xilinx/13.1/ISE_DS/ISE/lib/lin/
mkdir orig && mv libstdc++* orig
cd /opt/Xilinx/13.1/ISE_DS/ISE/lib/lin64/
mkdir orig && mv libstdc++* orig
cd /opt/Xilinx/13.1/ISE_DS/common/lib/lin/
mkdir orig && mv libstdc++* orig
cd /opt/Xilinx/13.1/ISE_DS/common/lib/lin64/
mkdir orig && mv libstdc++* orig

 

View solution in original post

Newbie grant.271
Newbie
16,514 Views
Registered: ‎06-29-2011

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

Thanks for posting this. The "no links" solution worked perfectly for me in Ubuntu 11.04 x86_64.

0 Kudos
Newbie cgreco
Newbie
16,311 Views
Registered: ‎11-21-2008

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

Not surprising, the "no links" method works for ISE 13.2 on ubuntu 11.04 x86_64 as well.  How can this solution be made more visible?  I searched several days and encounted several deadends before finding this thread.

0 Kudos
Explorer
Explorer
16,160 Views
Registered: ‎12-08-2007

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

Solved my problem with the simulator on Ubuntu 11.04, Design Suite 13.1

 

thanks !

 

Dag

0 Kudos
Visitor inye
Visitor
10,750 Views
Registered: ‎08-02-2010

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

works for Ubuntu 11.04 with ISE 13.2

but files are in another directory with the command: "locate libstdc + +" found them.

0 Kudos
Newbie mateevici
Newbie
10,665 Views
Registered: ‎03-08-2012

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

Thank you very much!

I've been hitting my head against the wall all morning to fix this problem and you solution did the trick!

By the way, it works on Ubuntu 11.10 and ISE 13.4.

0 Kudos
Visitor lyttlec
Visitor
10,648 Views
Registered: ‎03-20-2012

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

This fixed all my report problems for 10.1 - 13.4

0 Kudos
Explorer
Explorer
9,980 Views
Registered: ‎12-08-2007

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

But on 13.3  (and Ubuntu 11.04)  I now get the following error when using the simulator

 

gcc: isim/precompiled.exe.sim/ieee/p_2592010699.lin64.o: No such file or directory

gcc: isim/precompiled.exe.sim/ieee/p_3499444699.lin64.o: No such file or directory

ERROR:Simulator:861 - Failed to link the design

 

 

It does not look like the libstdc++ issue, right ?

 

Any idea how to solve this bug ?

 

Dag

0 Kudos
Newbie gautam_bhat
Newbie
9,862 Views
Registered: ‎07-08-2013

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

Go to process properties and remove incremental compilation. Compile. The problem should go away. Then enable it for faster builds.

0 Kudos
Newbie kiredeid
Newbie
9,268 Views
Registered: ‎12-29-2013

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

This worked like a charm. Thank you so much!

0 Kudos
Newbie psilord
Newbie
9,093 Views
Registered: ‎02-27-2014

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

This worked for me on Linux Mint 15 running on an x86_64 box with ISE 14.7.

 

I realize that shipping a binary only product with system libraries embedded in it is difficult in the linux world. Thank you for supporting ISE Design on linux!

0 Kudos
Explorer
Explorer
8,040 Views
Registered: ‎11-21-2013

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

The unlinked way by moving libstdc++* into orig folder resolved my problem on ISE14.4 on Opensuse12.*

0 Kudos
Explorer
Explorer
8,008 Views
Registered: ‎11-21-2013

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

Actually the unlinked way will cause iMPACT fail to launch without any errors and infors explicitly

0 Kudos
Visitor aaron1
Visitor
7,495 Views
Registered: ‎06-18-2014

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

This worked for me with Error: SIGSEGV 776.

I am using VM Workstation 10 with ISE 14.3.

Thanks _bhat

 

0 Kudos
Participant vbarsoum
Participant
2,863 Views
Registered: ‎09-15-2014

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

The only solution I can find to solve this is to keep switching between Xilinx "libstdc++.so.6" ans system "libstdc++.so.6", and that's a very bad solution for that. moving Xilinx "libstdc++.so.6"  to "libstdc++.so.6.orig" will cause other problems as well.

I am using ISE 14.7 with opensuse 13.1.

0 Kudos
Participant vbarsoum
Participant
2,793 Views
Registered: ‎09-15-2014

Re: ISE 13.1 on kubuntu 11.04

Jump to solution

I finally found a solution for this complicated problem on opensuse 13.1. I simply install another user interface called "Enlightenment". This user interface doesn't require (libstdc++) too much, so most of the applications can work.

0 Kudos