cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
8,368 Views
Registered: ‎08-04-2014

ISE 17.7 Webpack: ngdbuild.exe has stopped working - APPCRASH in libUtilC_MessageDispatcher.dll

Hallo,

 

can anybody help me with this issue. I installed ISE 14.7 Webpack on a Win 7 Enterprise SP1 64 bit computer, but I am unable to build any project. Even the example projects are not working, regardless if I try the 32 or 64 bit Version of the program:

 

Problem signature:

  Problem Event Name: APPCRASH

  Application Name: ngdbuild.exe

  Application Version: 0.0.0.0

Application Timestamp: 525ad60c

  Fault Module Name: libUtilC_MessageDispatcher.dll

  Fault Module Version: 0.0.0.0

  Fault Module Timestamp: 525ace07

  Exception Code: c0000005

  Exception Offset: 0000000000013eda

  OS Version: 6.1.7601.2.1.0.256.4

  Locale ID: 1031

  Additional Information 1: 020e

  Additional Information 2: 020e9c9ae0a112d20ab2161a962b669c

  Additional Information 3: 136e

  Additional Information 4: 136e798186f1eca886ca9465da6be1e3

0 Kudos
8 Replies
Highlighted
Xilinx Employee
Xilinx Employee
8,364 Views
Registered: ‎04-16-2012

Re: ISE 17.7 Webpack: ngdbuild.exe has stopped working - APPCRASH in libUtilC_MessageDispatcher.dll

Hi,

 

Check this thread: http://forums.xilinx.com/t5/Embedded-Development-Tools/Failed-to-read-dll-file-during-Project-gt-Generate-Netlist-for/td-p/67453

 

It may help you.

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
8,360 Views
Registered: ‎02-16-2014

Re: ISE 17.7 Webpack: ngdbuild.exe has stopped working - APPCRASH in libUtilC_MessageDispatcher.dll

Hi,

 

Looks like machine specific issue.

 

Can you try replacing that error causing dll with the working dll and check if that helps?

Before replcing the dll please make sure that you may have a copy of the dll that already exists in your machine.

 

 For 64-bit system you can try replacing this dll with the attached dll in your  ISE installed folder.(C:\Xilinx\14.7\ISE_DS\ISE\lib\nt64)

 

Please make sure that you will copy the existing dll before you replace with the attached dll.

 

0 Kudos
Highlighted
Visitor
Visitor
8,324 Views
Registered: ‎08-04-2014

Re: ISE 17.7 Webpack: ngdbuild.exe has stopped working - APPCRASH in libUtilC_MessageDispatcher.dll

@vuppala 

Thanks for your hint. I checked the PATH enviroment and found no reference to the ISE installation. Also there was not older ISE version installed on this computer. What I did is, that I installed vivado before and uninstalled it after I learned that it does not support the Spartan-6 anymore, that I need for this project.

 

@pulim 

I downloaded your dll and renamed ever dll with this name I found. There are 3 in the 32 bit and also 3 in the 64 bit installation path. From the size I guessed that yours is the 64 bit version, so I copied it to all 3 folders and started the 64 bit Project Navigator, but I got the same issue. You seem to be also right, that it is a computer specific issue, it works on an older computer with Vista using the same installation media.

 

Thank you for your quick responses!

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
8,318 Views
Registered: ‎02-16-2014

Re: ISE 17.7 Webpack: ngdbuild.exe has stopped working - APPCRASH in libUtilC_MessageDispatcher.dll

 

Hi,

 

Did you give a try uninstalling the software and re-installing it from scratch?

 

 

0 Kudos
Highlighted
Visitor
Visitor
8,314 Views
Registered: ‎08-04-2014

Re: ISE 17.7 Webpack: ngdbuild.exe has stopped working - APPCRASH in libUtilC_MessageDispatcher.dll

yes, I also tried a reinstallation. And  I repeated the installation on the other computer from the same media, since I first assumed something got corrupted because of  the big download.

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
8,307 Views
Registered: ‎04-16-2012

Re: ISE 17.7 Webpack: ngdbuild.exe has stopped working - APPCRASH in libUtilC_MessageDispatcher.dll

Hi,

Try running ngdbuild in command line mode and see if this helps.

Thanks,
Vinay
--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Highlighted
Visitor
Visitor
8,296 Views
Registered: ‎08-04-2014

Re: ISE 17.7 Webpack: ngdbuild.exe has stopped working - APPCRASH in libUtilC_MessageDispatcher.dll

if i start it from the dos command shell without any arguments I get a slightly different error message, if I add C:\Xilinx\14.7\ISE_DS\.xinstall\bin\nt64 to the PATH enviroment I get the same  error as in my first message.

 

Problem Event Name: BEX64

  Application Name: ngdbuild.exe

  Application Version: 0.0.0.0

Application Timestamp: 525ad60c

  Fault Module Name: btprof64.dll_unloaded

  Fault Module Version: 0.0.0.0

  Fault Module Timestamp: 4bf687cc

  Exception Offset: 0000000006653ed8

  Exception Code: c0000005

  Exception Data: 0000000000000008

  OS Version: 6.1.7601.2.1.0.256.4

  Locale ID: 1031

  Additional Information 1: e520

  Additional Information 2: e520f4d54c8f98dfbb942580624b81f9

  Additional Information 3: 98e8

  Additional Information 4: 98e87225aa28635e49f0d5554edf9d18

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
8,294 Views
Registered: ‎04-16-2012

Re: ISE 17.7 Webpack: ngdbuild.exe has stopped working - APPCRASH in libUtilC_MessageDispatcher.dll

Hi,

I suspect the issue is due to corrupt install.
Do you have any other machine that has ISE installed and working without any issue?

Thanks,
Vinay
--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos