cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
muneet
Visitor
Visitor
2,073 Views
Registered: ‎06-18-2018

Kintex-7 ffg900 -2 board license issue in vivado 2018.1.

Jump to solution

Hi,

Our server has valid license for vivado 2018.1. But it is giving license error in case we use Kintex-7 ffg900 -2 board for synthesis. Other licensed boards are working fine. Is there a solution for this or is it the issue of vivado version and will be fixed in the upcoming releases?

0 Kudos
1 Solution

Accepted Solutions
anatoli
Moderator
Moderator
2,311 Views
Registered: ‎06-14-2010

Hello @muneet,

 

Thanks for sharing this info.

 

As correctly indicated by @nupurs, from this Answer Record: https://www.xilinx.com/support/answers/69377.html, you can read that Vivado 2017.3 (and newer Vivado releases, e.g. 2017.4, 2018.x etc.) now uses FlexLM 11.14.1.0, which older floating server machines cannot provide licenses to unless the license utilities version matches or is newer.

Therefore, all of the floating license users must upgrade their license utilities in order for licenses to be picked up in Vivado 2018.x.

 

As such, please obtain these utilities from the downloads page (https://www.xilinx.com/support/download.html) and provide the .zip file to your floating license admin (please note that there are utilities specifically for Windows OS and also separately – for Linux). Then ask the admin to unzip this anywhere on the server. Then he needs to start the floating license server using the lmgrd from this location where he has just unzip these. It will then in turn will call the xilinxd vendor daemon (also found from the same location as lmgrd v11.14).  And that is it then, your Vivado 2018.1 will then be able to successfully detect and check out the necessary license and your issue will be resolved then.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------

View solution in original post

13 Replies
devinl
Community Manager
Community Manager
2,010 Views
Registered: ‎05-08-2017

Hi @muneet,

 

It sounds like the Vivado tools license is not being pulled on your machine or possible is not a compatible version for your tools. Can I have you run the below command and see if your see if your synthesis feature shows and has a version limit of 2018.04 or higher?

 

lmutil lmstat -a -c 1700@my_license_server 

 

https://www.xilinx.com/support/answers/33770.html

 

Thank you,
Devin

0 Kudos
anatoli
Moderator
Moderator
1,991 Views
Registered: ‎06-14-2010

Hello @muneet,

 

Also, in addition to what @devinl has suggested, when you run lmutil lmstat -a -c 1700@my_license_server, see if lmgrd and xilinxd are both v11.14. Can you confirm on this please?

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------
muneet
Visitor
Visitor
1,967 Views
Registered: ‎06-18-2018

Hi @devinl @anatoli,

Thank you for quick reply. Ran the above mentioned commands on the license server. It is not showing any version limit. The version of the server tool is 11.13. I have attached screenshot of the window when command is run on the server.

vivado_license.JPG
0 Kudos
nupurs
Moderator
Moderator
1,960 Views
Registered: ‎06-24-2015

@muneet

 

Since Vivado 2017.3, it is compulsory to use Flexlm tools version 11.14 on the server.

Hence, you can download, install and use the License Management tools given at end of this page : https://www.xilinx.com/support/download.html

Thanks,
Nupur
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (click on the 'thumbs-up' button).
anatoli
Moderator
Moderator
2,312 Views
Registered: ‎06-14-2010

Hello @muneet,

 

Thanks for sharing this info.

 

As correctly indicated by @nupurs, from this Answer Record: https://www.xilinx.com/support/answers/69377.html, you can read that Vivado 2017.3 (and newer Vivado releases, e.g. 2017.4, 2018.x etc.) now uses FlexLM 11.14.1.0, which older floating server machines cannot provide licenses to unless the license utilities version matches or is newer.

Therefore, all of the floating license users must upgrade their license utilities in order for licenses to be picked up in Vivado 2018.x.

 

As such, please obtain these utilities from the downloads page (https://www.xilinx.com/support/download.html) and provide the .zip file to your floating license admin (please note that there are utilities specifically for Windows OS and also separately – for Linux). Then ask the admin to unzip this anywhere on the server. Then he needs to start the floating license server using the lmgrd from this location where he has just unzip these. It will then in turn will call the xilinxd vendor daemon (also found from the same location as lmgrd v11.14).  And that is it then, your Vivado 2018.1 will then be able to successfully detect and check out the necessary license and your issue will be resolved then.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------

View solution in original post

muneet
Visitor
Visitor
1,943 Views
Registered: ‎06-18-2018

Hi @anatoli,

Tried all the steps as mentioned in your latest reply. The license limit is 2019.06 for all the tools including synthesis tool and 2018.1 version is detecting them as well(checked in license manager after upgrading the flex tool to version 11.14). But still the mentioned device is throwing the same error.

0 Kudos
anatoli
Moderator
Moderator
1,940 Views
Registered: ‎06-14-2010

Hello @muneet,

 

Can you please now run this below command similar to mine and share a screenshot of the output you'd get:

 

E.g.

 

lmutil lmstat -a -c 2100@XIRANATOLI31 -f Synthesis

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------
0 Kudos
muneet
Visitor
Visitor
1,932 Views
Registered: ‎06-18-2018

Hi @anatoli,

The screenshot of the window when the command ran on server.

vivado_syn.JPG
0 Kudos
anatoli
Moderator
Moderator
1,925 Views
Registered: ‎06-14-2010

Thanks @muneet,

 

As you can see, your xilinxd is still v11.13, where as both lmgrd and xilinxd must be v11.14

Fixing this, will fix your licensing issue.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------
license
Newbie
Newbie
1,618 Views
Registered: ‎07-04-2018

Hi @anatoli,

We followed your steps and LMTOOLs version changes to 11.14 but XILINXD is still 11.13. Could you please provide a guideline for upgrading the version of XILINXD tool?

0 Kudos
anatoli
Moderator
Moderator
1,616 Views
Registered: ‎06-14-2010

Hello @license,

 

Are you specifically pointing to the xilinxd v11.13 within your license file? If so, edit your lic file and update to point to v11.14 version of xilinxd.

If not, then have you obtained these utilities from the downloads page (https://www.xilinx.com/support/download.html)?

If so, if you unzip this.zip file and then start the floating license server using the lmgrd from this location where you've just unzip these, it will then in turn call the xilinxd vendor daemon (also found from the same location as lmgrd v11.14).

If further help is needed, please let me know.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------
anatoli
Moderator
Moderator
1,615 Views
Registered: ‎06-14-2010

also, @license, if you are using lmtools, the location where you've specified where to look for lmgrd v11.14, is xiilnxd v11.14 also in the same location?

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------
muneet
Visitor
Visitor
1,601 Views
Registered: ‎06-18-2018

Hi @anatoli@nupurs@devinl,

Thank you for providing to the point guidelines for resolving the issue.

0 Kudos