cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
2,784 Views
Registered: ‎12-16-2016

Problem with upgrading to Vivado 2015.4.2 from Vivado 2015

Jump to solution

Hi,

 

I'm currently trying to upgrade to Vivado 2015.4.2 from Vivado 2015.4 Webpack.

My Vivado 2015.4 build is located in /opt/Xilinx and all environment path variables set correctly. No issues there. For the purposes of my project, it requires 2015.4.2.

 

When I run sudo ./xsetup, I get the following output after Vivado install starts:

 

"There is no valid Xilinx installation that this Update can be applied to"

 

When Googled, I arrived at this thread How to Update to 2015.4.2. Here, the thread states that I need the Design Edition.


However, the Download page here 2015.4.2 Update for Vivado states: "Vivado Design Suite HLx Editions (All Editions)"

This leads me to believe that I can install the upgrade for my Webpack edition of 2015.4. Since 2016.4 is written in the same "All Editions" that includes Webpack.

 

Would someone be able to clarify whether or not I'd be able to upgrade? If no, is there any workaround?

Thank you.

 

Regards,

 

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Observer
Observer
4,699 Views
Registered: ‎09-15-2016

Re: Problem with upgrading to Vivado 2015.4.2 from Vivado 2015

Jump to solution

@nocturnalpea

Refer to AR#66246 and see if you get any additionaly information on this.

https://www.xilinx.com/support/answers/66246.html

 

Regards,

Asit

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
---------------------------------------------------------------------------------------------

View solution in original post

3 Replies
Highlighted
Moderator
Moderator
2,745 Views
Registered: ‎09-15-2016

Re: Problem with upgrading to Vivado 2015.4.2 from Vivado 2015

Jump to solution

Hi @nocturnalpea

 

You should be able to upgrade the Vivado 2015.4.2 from Vivado 2015.4. As mentioned in the download link  "This update must be applied to an existing installation of either Vivado 2015.4 or Vivado 2015.4.1.  After updating, the Vivado version will be 2015.4.2". Try upgrading with the download page link and let us know if you go through any problem.

 

Regards

Rohit

Regards
Rohit
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

Highlighted
Observer
Observer
4,700 Views
Registered: ‎09-15-2016

Re: Problem with upgrading to Vivado 2015.4.2 from Vivado 2015

Jump to solution

@nocturnalpea

Refer to AR#66246 and see if you get any additionaly information on this.

https://www.xilinx.com/support/answers/66246.html

 

Regards,

Asit

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
---------------------------------------------------------------------------------------------

View solution in original post

Highlighted
Visitor
Visitor
2,660 Views
Registered: ‎12-16-2016

Re: Problem with upgrading to Vivado 2015.4.2 from Vivado 2015

Jump to solution

Thank you to you both - it worked. I tried it again and it upgraded. Although I'm pretty sure I did the same (ie upgrading through the download link etc), it didn't work the first time. In any case, it's 2015.4.2 now so all's good.

 

Regards,

 

0 Kudos