cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
anton2
Contributor
Contributor
323 Views
Registered: ‎05-28-2019

Required Dongle details for Xilinx Vivado node-locked license

Jump to solution

Hi,

Recently I'm considering to use Xilinx Vivado (node-locked license) with a Dongle from Flexera.

The Vivado version would be a version between 2018.3 and 2020.2  (not decided yet)

May I know the detailed specification of this "Dongle"?

A "model number" would be the best.  Requirements like "HASP HL", etc. are also appreciated.

(Actually Flexera asked me about the detailed specification needed for a quote, but I was not able to answer.)

Thanks a lot.

0 Kudos
1 Solution

Accepted Solutions
anatoli
Moderator
Moderator
270 Views
Registered: ‎06-14-2010

Hello @anton2 ,

Here is an example of a Flexnet dongle:

image.png

Please note that these come as an older dongles (HASP4 dongle) and new ones (HASP HL dongle)

What you need is HASP HL dongle for 2018.3 and newer versions of Vivado.

Please also check (Xilinx Answer 70201) for the following issue:

If the FlexNet dongle is an older HASP4 dongle and not a newer HASP HL dongle, then Vivado 2017.3 (and later Vivado releases) will not be able to detect this dongle and the license will not get checked out.

If an older Dongle (i.e. HASP4) is used, the options are:

  • Order a newer HASP HL dongle to use with the newer tools
  • Re-generate your license to target a NIC ID (Network Interface Card ID) or a DISK_SERIAL_NUM instead of your dongle’s ID.

This and more info can be found in my blog here: https://forums.xilinx.com/t5/Design-and-Debug-Techniques-Blog/How-to-debug-licensing-related-issues/ba-p/1045006

Hope this helps.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
1 Reply
anatoli
Moderator
Moderator
271 Views
Registered: ‎06-14-2010

Hello @anton2 ,

Here is an example of a Flexnet dongle:

image.png

Please note that these come as an older dongles (HASP4 dongle) and new ones (HASP HL dongle)

What you need is HASP HL dongle for 2018.3 and newer versions of Vivado.

Please also check (Xilinx Answer 70201) for the following issue:

If the FlexNet dongle is an older HASP4 dongle and not a newer HASP HL dongle, then Vivado 2017.3 (and later Vivado releases) will not be able to detect this dongle and the license will not get checked out.

If an older Dongle (i.e. HASP4) is used, the options are:

  • Order a newer HASP HL dongle to use with the newer tools
  • Re-generate your license to target a NIC ID (Network Interface Card ID) or a DISK_SERIAL_NUM instead of your dongle’s ID.

This and more info can be found in my blog here: https://forums.xilinx.com/t5/Design-and-Debug-Techniques-Blog/How-to-debug-licensing-related-issues/ba-p/1045006

Hope this helps.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos