UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Reply

Run Vivado 2013.4 on Debian

Highlighted
Observer
Posts: 36
Registered: ‎06-16-2008

Run Vivado 2013.4 on Debian

Although Debian is a non supported platform for the Xilinx tools, it is a distribution widley used if we count with its derivatives (Ubuntu, et al). After some work I have been able to use Vivado on Debian. Here is what I have done in case somebody is in the same situation

1) Setup bash as default shell  instead of dash

Xilinx uses some bashishm on its scripts and does not specify bash on the script :/. To solve this issue run:

dpkg-reconfigure dash

and select bash as your default shell

2) Use system jvm instead of the provided jvm.

For some reason the provided jvm sigsegv, this can be solved by installing gopenjdk-7-jdk on your system and running

mv /opt/Xilinx/Vivado/2013.4/tps/lnx64/jre/lib/amd64/server/libjvm.so /opt/Xilinx/Vivado/2013.4/tps/lnx64/jre/lib/amd64/server/libjvm.so.old
ln -s /usr/lib/jvm/java-7-openjdk-amd64/jre/lib/amd64/server/libjvm.so  /opt/Xilinx/Vivado/2013.4/tps/lnx64/jre/lib/amd64/server/libjvm.so

3) Replace udev_device_new_from_syspath from udev

When the tool is checking the license of my system it is sigsegv.

To solve it I have created a library that replaces the funcion udev_device_new_from_syspath with an empty one. I LD_PRELOAD it before calling the tool.


The library:
define _GNU_SOURCE

#include <sys/ioctl.h>

#include <dlfcn.h>
#include <stdio.h>
#include <stdarg.h>
#include <stdlib.h>
#include <string.h>
#include <stdint.h>
#include <signal.h>
#include <execinfo.h>

void *udev_device_new_from_syspath(void *null, char *name){
return NULL;
}

How to build:

gcc -shared -o lib.so lib.c -fPIC -O2 -Wall -Werror -Wstrict-prototypes  -Wall -ldl

 
To run:
 
LD_PRELOAD=lib.so vivado
 
3) Replace provided libstdc++ with system libstdc++
 
When calling the browser the provided libstdc++ does not work with the system browser
 
cd /opt/Xilinx/Vivado/2013.4/lib/lnx64.o
 
mv libstdc++.so.6 libstdc++.so.6.old
ln /usr/lib64/libstdc++.so.6
 
And now you can use vivado :)
 
I would strongly recommend Xilinx to consider also Debian as a supported distro, or at least try to run it on Debian before to relase it. Some of this bugs could be solved very easily on your side without ugly workarounds.
 
Xilinx Employee
Posts: 3,596
Registered: ‎08-02-2011

Re: Run Vivado 2013.4 on Debian

Great! Thanks very much for posting this so the rest of the community can also benefit from it.
www.xilinx.com
Participant
Posts: 31
Registered: ‎03-18-2014

Re: Run Vivado 2013.4 on Debian

Hello every body,

 

I am trying to install Vivado 2013.2  on Ubuntu 13.10 I hace followed steps described ( sudo apt-get install openjdk-7-jre,    sudo mv /opt/Xilinx/Vivado/2013.2/tps/lnx64/jre/lib/amd64/server/libjvm.so
/opt/Xilinx/Vivado/2013.2/tps/lnx64/jre/lib/amd64/server/libjvm.so.old

sudo ln -s /usr/lib/jvm/java-7-openjdk-amd64/jre/lib/amd64/server/libjvm.so
/opt/Xilinx/Vivado/2013.2/tps/lnx64/jre/lib/amd64/server/

 

but when i try to "add Ip" and i choose a block i have this ERROR : 

ERROR: [Vivado 12-106] *** Exception: java.lang.NumberFormatException: For input string: "1,08846" (See /home/sabeur/vivado_pid3993.debug)

 


Some one can help me ? Thanks a lot

 

Best regards

Xilinx Employee
Posts: 3,773
Registered: ‎04-16-2012

Re: Run Vivado 2013.4 on Debian

Hi,

 

Try setting the environmental variables LANG and LC_ALL to your locale.

 

Thanks

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
Moderator
Posts: 3,028
Registered: ‎10-24-2013

Re: Run Vivado 2013.4 on Debian

Hi,
The supported list are
Microsoft Windows Support
• Windows XP Professional (32-bit and 64-bit), English/Japanese
• Windows 7 Professional (32-bit and 64-bit), English/Japanese
• Windows Server 2008 (64-bit)
Linux Support
• Red Hat Enterprise Workstation 5 (32-bit and 64-bit)
• Red Hat Enterprise Workstation 6 (32-bit and 64-bit)
• SUSE Linux Enterprise 11 (32-bit and 64-bit)

Additional support of OS are customer usage driven. We dont have much customers using Debian.
Thanks,Vijay
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
Observer
Posts: 36
Registered: ‎06-16-2008

Re: Run Vivado 2013.4 on Debian

You cant have customers using Debian, your product does not work out of the box there :).

 

There are many distros based on Debian, you could get much more compatibitly just by supporting it. If you dont plan to support it at least it would be nice to fix the problems reported.

 

Cheers

Observer
Posts: 40
Registered: ‎04-24-2012

Re: Run Vivado 2013.4 on Debian

I am running Vivado 2013.4 and 2014.1 using Ubuntu 13.10 and 14.04 in my "Zynq Design From Scratch" blog without any problems so far.

 

Sven

Visitor
Posts: 8
Registered: ‎04-15-2014

Re: Run Vivado 2013.4 on Debian

Over in this thread I describe a problem installing Vivado 2014.2 on an up-to-date Debian Jessie system.  Actually the same problem happens when I try to run vivado (2014.1) or run the installer for 2014.2.  I see the small splash window, then the large window appears, but it remains blank white, and the system sits idle forever with zero CPU usage, until the process is killed.

 

I cannot explain why I was able to install 2014.1 but three months later could not run it.  The biggest change on my system was going from the GNOME desktop environment to a stripped down X plus tiling window manager (highly recommended btw), but my best guess is that it has something to do with java.

 

The OP in this thread recommends changing java from the Xilinx-installed version to the Debian-provided one.  My question is, if the Xilinx java doesn't play well with Debian, how did you get Vivado installed in the first place?  I would like to try this but the installer runs java from a directory off of /tmp and I don't see how to change that.

 

Any other Debian users experiencing the zero-CPU-freeze problem?  It really has me baffled.

 

Xilinx Employee
Posts: 1,103
Registered: ‎11-28-2007

Re: Run Vivado 2013.4 on Debian


vijayak wrote:
Hi,
The supported list are
Microsoft Windows Support
• Windows XP Professional (32-bit and 64-bit), English/Japanese
• Windows 7 Professional (32-bit and 64-bit), English/Japanese
• Windows Server 2008 (64-bit)
Linux Support
• Red Hat Enterprise Workstation 5 (32-bit and 64-bit)
• Red Hat Enterprise Workstation 6 (32-bit and 64-bit)
• SUSE Linux Enterprise 11 (32-bit and 64-bit)

Additional support of OS are customer usage driven. We dont have much customers using Debian.

Correction, Vivado 2014.1 and 2014.2 support:

 

Microsoft Windows Support
• Windows XP Professional (32-bit and 64-bit), English/Japanese
• Windows 7 and 7 SP1 Professional (32-bit and 64-bit), English/Japanese
• Windows 8.1 Professional (64-bit), English/Japanese
Linux Support
• Red Hat Enterprise Workstation 5.8 - 5.10 (32-bit and 64-bit)
• Red Hat Enterprise Workstation 6.4 - 6.5 (32-bit and 64-bit)
• SUSE Linux Enterprise 11 (32-bit and 64-bit)
• Cent OS 6.4 and 6.5 (64-bit)

 

(UG973 Release notes userguide)

--------------------------------------------------------------------------------------------------------------------
Please mark the Answer as "Accept as solution" if the information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented by clicking the star next to the post.