UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor lpacphantom
Visitor
31,235 Views
Registered: ‎10-16-2010

Running ISE in Linux

Jump to solution

I'm a fairly new user of Linux and I need to use the ISE for a class. I'm trying to run the program off a 16gb flash drive loaded with a full installation of Fedora 13.

I got the program installed fine in the default directory /opt/Xilinx/12.3/

Problem is now I can't launch the application. I feel incredibly stupid for not being able to locate the file the starts the ISE. I've searched a number of directories for something that resembles a shell script, but to no avail.

 

Any help is appreciated, thank you.

1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
40,491 Views
Registered: ‎11-28-2007

Re: Running ISE in Linux

Jump to solution

You should see a directory ISE_DS under /opt/Xilinx/12.3/ . In /opt/Xilinx/12.3/ISE_DS, there are several settings32(64).(c)sh files. Source the one for your OS/Shell. e.g. if you use C-shell on a 64-bit machine, run

 

source settings64.csh

 

which sets the environment for running all IDS tools.

 

Below are several useful commands you may want to take a note:

 

ise            - Project Navigator
xps            - EDK Platform Studio
planAhead      - PlanAhead
fpga_editor    - FPGA editor
coregen        - Core Generator
timingan       - Timing Analyzer
smartxplorer   - SmartXplorer
sysgen         - System Generator
analyzer       - Chipscope Analyzer

Cheers,
Jim
Tags (1)
10 Replies
Xilinx Employee
Xilinx Employee
40,492 Views
Registered: ‎11-28-2007

Re: Running ISE in Linux

Jump to solution

You should see a directory ISE_DS under /opt/Xilinx/12.3/ . In /opt/Xilinx/12.3/ISE_DS, there are several settings32(64).(c)sh files. Source the one for your OS/Shell. e.g. if you use C-shell on a 64-bit machine, run

 

source settings64.csh

 

which sets the environment for running all IDS tools.

 

Below are several useful commands you may want to take a note:

 

ise            - Project Navigator
xps            - EDK Platform Studio
planAhead      - PlanAhead
fpga_editor    - FPGA editor
coregen        - Core Generator
timingan       - Timing Analyzer
smartxplorer   - SmartXplorer
sysgen         - System Generator
analyzer       - Chipscope Analyzer

Cheers,
Jim
Tags (1)
Visitor lpacphantom
Visitor
31,218 Views
Registered: ‎10-16-2010

Re: Running ISE in Linux

Jump to solution

I believe my shell is bash, and it's a 32 bit install. My IDE_DS directory has these:

common  EDK  ISE  PlanAhead  readme.txt  settings32.csh  settings32.sh

I've tried running the command:

source settings32.sh

but nothing happens. I'm used to running the Project Navigator on Windows, and I expect to get much the same GUI in Linux. Am I right about that?

0 Kudos
Xilinx Employee
Xilinx Employee
31,214 Views
Registered: ‎11-28-2007

Re: Running ISE in Linux

Jump to solution

"source settings32.sh" only sets up the environement (i.e. necessary environment variables, PATH to IDS commands, etc). You need to run the actual command to start the tool: From the same terminal your sourced settings32.sh, run

 

ise

 

which will start Project Navigator.

 

 


@lpacphantom wrote:

I believe my shell is bash, and it's a 32 bit install. My IDE_DS directory has these:

common  EDK  ISE  PlanAhead  readme.txt  settings32.csh  settings32.sh

I've tried running the command:

source settings32.sh

but nothing happens. I'm used to running the Project Navigator on Windows, and I expect to get much the same GUI in Linux. Am I right about that?


 

Cheers,
Jim
0 Kudos
Visitor lpacphantom
Visitor
31,211 Views
Registered: ‎10-16-2010

Re: Running ISE in Linux

Jump to solution

Ok, that makes sense. It still does nothing useful though. SELinux logs errors each time. It recommends commands to fix it, but it just leads me around in circles. Any ideas? I've tried su and running it as root to no avail.

 

Error summary:

 

Summary:

SELinux is preventing /opt/Xilinx/12.3/ISE_DS/ISE/bin/lin/ise from loading
/opt/Xilinx/12.3/ISE_DS/ISE/lib/lin/libMiniZip.so which requires text
relocation.

Detailed Description:

The ise application attempted to load
/opt/Xilinx/12.3/ISE_DS/ISE/lib/lin/libMiniZip.so which requires text
relocation. This is a potential security problem. Most libraries do not need
this permission. Libraries are sometimes coded incorrectly and request this
permission. The SELinux Memory Protection Tests
(http://www.akkadia.org/drepper/selinux-mem.html) web page explains how to
remove this requirement. You can configure SELinux temporarily to allow
/opt/Xilinx/12.3/ISE_DS/ISE/lib/lin/libMiniZip.so to use relocation as a
workaround, until the library is fixed. Please file a bug report.

Allowing Access:

If you trust /opt/Xilinx/12.3/ISE_DS/ISE/lib/lin/libMiniZip.so to run correctly,
you can change the file context to textrel_shlib_t. "chcon -t textrel_shlib_t
'/opt/Xilinx/12.3/ISE_DS/ISE/lib/lin/libMiniZip.so'" You must also change the
default file context files on the system in order to preserve them even on a
full relabel. "semanage fcontext -a -t textrel_shlib_t
'/opt/Xilinx/12.3/ISE_DS/ISE/lib/lin/libMiniZip.so'"

Fix Command:

chcon -t textrel_shlib_t '/opt/Xilinx/12.3/ISE_DS/ISE/lib/lin/libMiniZip.so'

 

Edit: I just ran the installation again and read the final page where it describes sourcing the settings files. My bad on missing that the first time. But the issue remains: I can't launch the ISE.

 

0 Kudos
Xilinx Employee
Xilinx Employee
31,136 Views
Registered: ‎11-28-2007

Re: Running ISE in Linux

Jump to solution

Sorry I am not very familiar with SELinux, so I can't be of too much help on that. Having said that, I normally disable SELinux. (Disclaimer: I'm NOT suggesting you do one way or the other. You will need to make your own decision and proceed at your own risk).

 

 

 

Cheers,
Jim
0 Kudos
Visitor lpacphantom
Visitor
31,130 Views
Registered: ‎10-16-2010

Re: Running ISE in Linux

Jump to solution

Thanks for you help Jim. I'll keep looking into my options, I'll get it working eventually.

0 Kudos
30,925 Views
Registered: ‎10-24-2010

Re: Running ISE in Linux

Jump to solution

Hi,

 

i also was trying to use ISE (12.3) on a linux system but without any succes to start it.

This Topic helped me with the source settings32.ch issue but after i also couldn't start the ISE software.

 

I found on a ubuntu forum something that helped to launch the ISE.

 

In the terminal i had to go to the following place:

 

/opt/Xilinx/12.3/ISE_DS/bin/lin

 

Then run following command:  ./ise

 

And the ise software came up.

 

Maybe that's your solution too? :)

 

 

Mark

Visitor lpacphantom
Visitor
30,574 Views
Registered: ‎10-16-2010

Re: Running ISE in Linux

Jump to solution

I've had success with both the methods provided. I ended up having to disable SELinux and chmod-ing the opt directory to make it easier to use. For some reason, sourcing the settings file only worked on my normal desktop which is running 64-bit Fedora. However, using ./ise in /opt/.../bin/lin/ worked on my flash drive (which has been upgraded to a 32gb drive due to a memory error while trying to install on the 16gb) Thank you for all your help.

0 Kudos
Newbie zt1
Newbie
29,020 Views
Registered: ‎04-07-2011

Re: Running ISE in Linux

Jump to solution

Hi Mark,

 

I managed to get ISE running using your advice. Just to clarify that the bin folder is in the ISE folder in ISE_DS, and not in ISE_DS itself.

0 Kudos
Newbie xbartek
Newbie
5,274 Views
Registered: ‎11-06-2011

Full path to Xilinx ISE

Jump to solution

/opt/Xilinx/13.3/ISE_DS/ISE/bin/lin/ise 

 

For 100% it'll be working :)

 

B. Ojmuciański

0 Kudos