UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
667 Views
Registered: ‎04-03-2017

SDK license error although i have a vivado license and its working fine.

I installed 2014.3.1 vivado which came along with KC705 board which we bought. We got node locked license with that board and installed vivado and SDK 2018.1. Then SDK opened and didnt show any error. But as my vivado is 2014.3.1 i am unable to use 2018.1 SDK so i uninstalled SDK 2018.1 and installed SDK 2014.3.1 and tried to open but it is giving following error.

 

sdk license error.png

 

Then googled and searched in community and checked lot of things my license is fine n i found SDK has different license and  can be obtain free but i didnt find any link in xilinx website in this case. 

 

So pls let me clarify below points.

 

1) Why SDK 2014.3.1 doen't getting licensed although we have complete vivado license?

2) As SDK 2018.1 doesnt given any error i want to switch my vivado to 2018.1 from 2014.3.1, then can i use same license file for activating vivado and SDK?

3) If i want to use vivado 2014.3.1 then how  can i solve this issue?

 

Please remind that i searched complete forum and did some of the solutions  you made but it doesn't work in my case so im writing in a new thread. Please  provide links if necessary...

 

 

Thank you,

 

Mahesh

Radar Systems Engineer

 

 

0 Kudos
2 Replies
Moderator
Moderator
615 Views
Registered: ‎06-14-2010

Re: SDK license error although i have a vivado license and its working fine.

Hello @maheshkumar0459,

 

Please note that SDK feature would be included in the purchased license file or in the Device Locked license that came with the board.

To me, for some reason, your license can't be detected.

What type is your license? Is it a Node-Locked or a Floating?

If you open VLM (Vivado License Manager), do you see an SDK feature listed?

Please note that this SDK feature is also included in the Vivado WebPACK (free) license file.

As now a days (from 2016.4 release of Vivado) Vivado WebPACK license is built into Vivado and users don't need to go now and generate this license, therefore, that is the reason why everything working in 2018.1.

If things are not working in 2014.3.1., that means the license can't be found. Therefore, can you please share your license file and also please send me your Xinfo report generated on the machine where you are seeing this licensing issue, for examination.

 

If you have any questions for me, please let me know.

 

Xinfo.txt can be generated by running the "report_environment –file xinfo.txt" command in Vivado TCL console.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Moderator
Moderator
589 Views
Registered: ‎06-14-2010

Re: SDK license error although i have a vivado license and its working fine.

Hello @maheshkumar0459,

 

This topic is still open and is waiting for you.

 

If your question is answered and/or your issue is solved, please mark a response that resolved your issue, as Accepted Solution (more info on this can be found here: https://forums.xilinx.com/t5/help/faqpage/faq-category-id/solutions#solutions). This way, the topic can be completed then. 

 

If this is not solved/answered, please reply in the thread.

 

Thanks in advance and have a great day.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos