cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
polaris042
Observer
Observer
14,584 Views
Registered: ‎08-20-2015

Segmentation Fault Error when starting Vivado v2015.2 (64-bit)

Jump to solution

 

Hello,

 

I installed Vivado v2015.2 (64-bit) in CentOS 7.

However, Vivado tool is disappeared in a second with the following error message.

 

   /opt/Xilinx/Vivado/2015.2/bin/loader: line 157: 3687 Segmentation fault (core dumped) "$RDI_PROG" "$@"

 

Please, let me know what I have to do.

 

 

Thanks,

Chorong Kim

 

 

0 Kudos
1 Solution

Accepted Solutions
vuppala
Xilinx Employee
Xilinx Employee
25,352 Views
Registered: ‎04-16-2012

Hi @polaris042

 

I still observe that the environmental variable GNOME_DESKTOP_SESSION_ID is set. Can you try unsetting it?

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.

View solution in original post

0 Kudos
14 Replies
vuppala
Xilinx Employee
Xilinx Employee
14,583 Views
Registered: ‎04-16-2012

Hi @polaris042

 

unset the environmental variable GNOME_DESKTOP_SESSION_ID and try?

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
polaris042
Observer
Observer
14,576 Views
Registered: ‎08-20-2015

Yes, I tried it but it doesn't worked.  

 

Hmm.. what is the result after 'unset GNOME_DESKTOP_SESSION_ID' ? 

When I tried 'echo $GNOME_DESKTOP_SESSION_ID' after that, I got 'this-is-depreated'. 

Is it a correct result?

 

Thanks,

Chorong Kim

 

2015-09-02 19 21 52.png
0 Kudos
vuppala
Xilinx Employee
Xilinx Employee
14,571 Views
Registered: ‎04-16-2012

Hi @polaris042

 

Share the output of the command: env

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
balkris
Xilinx Employee
Xilinx Employee
14,560 Views
Registered: ‎08-01-2008
You may open with new project inplace of current project.
The current project may be the root cause of this issue
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
polaris042
Observer
Observer
14,547 Views
Registered: ‎08-20-2015

 

I make a new user account and try again, but the same error is reported. 

I attatched env.log file. Please, check it. 

 

Thanks,

Chorong Kim

0 Kudos
dwisehart
Scholar
Scholar
14,540 Views
Registered: ‎06-23-2013

What is returned by:

 

ldd /opt/Xilinx/Vivado/2015.2/bin/unwrapped/lnx64.o/vivado

 

See if any "not found" libraries are available under the 2015.2/lib/lnx64.0/ directory.

 

Daniel

 

0 Kudos
polaris042
Observer
Observer
14,536 Views
Registered: ‎08-20-2015

 

I got the following report.

 

linux-vdso.so.1 => (0x00007ffec71cf000)
libtcmalloc.so.4 => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libtcmalloc.so.4 (0x00007fe6afb02000)
libboost_signals.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libboost_signals.so (0x00007fe6af8eb000)
librdi_common.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/librdi_common.so (0x00007fe6aed38000)
librdi_commonmain.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/librdi_commonmain.so (0x00007fe6aeb2c000)
libstdc++.so.6 => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libstdc++.so.6 (0x00007fe6ae829000)
libgcc_s.so.1 => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libgcc_s.so.1 (0x00007fe6ae613000)
libc.so.6 => /lib64/libc.so.6 (0x00007fe6ae23f000)
libm.so.6 => /lib64/libm.so.6 (0x00007fe6adf3c000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fe6add20000)
libCOIN-all.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libCOIN-all.so (0x00007fe6ad650000)
libXil_lmgr11.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libXil_lmgr11.so (0x00007fe6ad2e8000)
libboost_date_time.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libboost_date_time.so (0x00007fe6ad0d8000)
libboost_filesystem.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libboost_filesystem.so (0x00007fe6acec2000)
libboost_program_options.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libboost_program_options.so (0x00007fe6acc52000)
libboost_regex.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libboost_regex.so (0x00007fe6ac96c000)
libboost_system.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libboost_system.so (0x00007fe6ac769000)
libboost_thread.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libboost_thread.so (0x00007fe6ac549000)
libhdlpsolve.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libhdlpsolve.so (0x00007fe6ac2a6000)
libhdxml.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libhdxml.so (0x00007fe6abffc000)
libisl_iostreams.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libisl_iostreams.so (0x00007fe6ab7c3000)
libisl_iosutils.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libisl_iosutils.so (0x00007fe6ab5aa000)
libisl_sysinfo.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libisl_sysinfo.so (0x00007fe6ab377000)
libprotobuf.so.7 => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libprotobuf.so.7 (0x00007fe6ab085000)
librdi_commonxillic.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/librdi_commonxillic.so (0x00007fe6aae25000)
librdi_curl.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/librdi_curl.so (0x00007fe6aaa16000)
librdiconfig.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/librdiconfig.so (0x00007fe6aa7fd000)
librdizlib.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/librdizlib.so (0x00007fe6aa5d7000)
libtcl8.5.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libtcl8.5.so (0x00007fe6aa2b5000)
libxerces-c-3.1.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libxerces-c-3.1.so (0x00007fe6a9d0a000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007fe6a9b06000)
libgomp.so.1 => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libgomp.so.1 (0x00007fe6a98f8000)
librdi_commonversion.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/librdi_commonversion.so (0x00007fe6a96f4000)
/lib64/ld-linux-x86-64.so.2 (0x00007fe6afd75000)
librt.so.1 => /lib64/librt.so.1 (0x00007fe6a94ec000)
libboost_iostreams.so => /opt/Xilinx/Vivado/2015.2/lib/lnx64.o/libboost_iostreams.so (0x00007fe6a92d8000)

 

 

0 Kudos
dwisehart
Scholar
Scholar
14,520 Views
Registered: ‎06-23-2013
OK, it does not appear you are missing any libraries.

Next thought is to run:

strace -f vivado -o /tmp/vivado.strace.out

That will show you what system calls are made just before the program crashes.
0 Kudos
vuppala
Xilinx Employee
Xilinx Employee
25,353 Views
Registered: ‎04-16-2012

Hi @polaris042

 

I still observe that the environmental variable GNOME_DESKTOP_SESSION_ID is set. Can you try unsetting it?

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.

View solution in original post

0 Kudos
polaris042
Observer
Observer
11,274 Views
Registered: ‎08-20-2015

 

 

It works! 

 

I used wrong a command for unsetting GNOME_DESKTOP_SESSION_ID variable. 

I should 'unsetenv' command instead of 'unset' because I use c-shell environment. 

Thank you for your supports!

 

 

Thanks, 

Chorong Kim 

 

0 Kudos
kevinkeryk
Participant
Participant
11,175 Views
Registered: ‎05-29-2009

I stumbled across this forum post which shows a workaround for unsetting the environment variable GNOME_DESKTOP_SESSION_ID.

 

I confirmed that this workaround indeed does work and if you add the following command to your .bashrc file, you won’t need to run the command each time you restart your machine.  

unset GNOME_DESKTOP_SESSION_ID

That information came from this thread here:

http://stackoverflow.com/questions/21261616/ubuntu-13-04-gnome-desktop-session-id

Hopefully this thread helps if you ever run into this issue while setting up Vivado Design Suite 2015.2.1 under Desktop Linux using CentOS 7 (with both the 1406 and 1503 releases).  It certainly helped me!

 

Regards,

 

-Kevin

0 Kudos
jrp
Explorer
Explorer
1,698 Views
Registered: ‎01-24-2018

I get basically the same error. on 2018.2.

Nice to see they have made a lot of improvements to the product since.

My line number is different.

Vivado-2018-2/SDK/2018.2/bin/loader: line 194: 4530 Segmentation Fault (core dumped) "sRDI_PROG" "$@"

Yes, I am on a supported OS.

I have been building code and designs with this installation for over a year.

One day it just up and does this because of something that broke.

 

0 Kudos
dwisehart
Scholar
Scholar
1,678 Views
Registered: ‎06-23-2013

If you don't see any other replies, start a new topic.  Old topics are often not monitored (and I do not have anything to add).

Daniel

 

0 Kudos
jrp
Explorer
Explorer
1,633 Views
Registered: ‎01-24-2018

I have something to add...

I went into the SDK project .metadata directory and removed the .lock file and now the error is gone.

 

Your welcome!