cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
466 Views
Registered: ‎11-03-2020

Sysgen license checkout failed with floating licence problem

Jump to solution

Hello,

I installed Vivado 2018.2 with a floating licence. I attached the VLM window and I can see all licences (at least I hope). 

VLM.PNG

Nevertheless, when I build an FPGA project from Matlab 2018a, I receive the following error:

--------------------------------- Version Log ----------------------------------
Version Path
System Generator 2018.2 C:/Xilinx/Vivado/2018.2
Matlab 9.4.0.813654 (R2018a) C:\Program Files\MATLAB\R2018a
Vivado 2018.2 C:/Xilinx/Vivado/2018.2
--------------------------------------------------------------------------------
Summary of Errors:
Error 0001: Sysgen license checkout failed.
XILINXD_LICENSE_FILE = 2...
Block: Unspecified
--------------------------------------------------------------------------------

Error 0001:

Reported by:
Unspecified

Details:
Sysgen license checkout failed.
XILINXD_LICENSE_FILE = 2100@svrmicro.dei.unipd.it;C:/Xilinx/Vivado/2018.2/data/sysgen/hwcosim_compiler/pp_ethernet
LM_LICENSE_FILE = Xilinx.lic
License search path: C:\Users\ludovico.ortombina\AppData\Roaming\XilinxLicense;C:\.Xilinx;2100@svrmicro.dei.unipd.it;C:\Xilinx\Vivado\2018.2\data\sysgen\hwcosim_compiler\pp_ethernet;Xilinx.lic;C:\Xilinx\Vivado\2018.2\data\ipcore_licenses

 

and it seems that it cannot find the sysgen licence despite I can see it in VLM window.

Do you know how to solve with this problem or what is it due to?

Thank you,

Best regards, Ludovico

0 Kudos
1 Solution

Accepted Solutions
ansarimo
Xilinx Employee
Xilinx Employee
367 Views
Registered: ‎12-04-2019

Hi @LudovicoOrtombi ,

From the shared snapshot of VLM, I see that you have a license for the SysGen feature, check if its license CRC is okay to be used and confirm on this?

Please check if you are using the supported OS for Vivado 2018.2 and also, let me know the same.

Run the below command to make sure the license server is up and running, also share the snapshot of it:

lmutil lmstat -a -c port@server

If your license server is up and running then make sure to set the only XILINXD_LICENSE_FILE environment variable, the license file which is serving the floating server should not be pointed directly from VLM as it is already being served to the floating server, in this cases tools get confused which license to be used.

If still issue persists then share the following files to check this issue:

  1. The complete license file(xilinx.lic).
  2. Run the below command from Vivado TCL console and share the generated xinfo.txt file, run pwd to know the location if this file.

report_environment -file xinfo.txt

 

Thanks & Regards,

Ansari Hunen

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as a solution.
-------------------------------------------------------------------------

 

View solution in original post

0 Kudos
2 Replies
ansarimo
Xilinx Employee
Xilinx Employee
368 Views
Registered: ‎12-04-2019

Hi @LudovicoOrtombi ,

From the shared snapshot of VLM, I see that you have a license for the SysGen feature, check if its license CRC is okay to be used and confirm on this?

Please check if you are using the supported OS for Vivado 2018.2 and also, let me know the same.

Run the below command to make sure the license server is up and running, also share the snapshot of it:

lmutil lmstat -a -c port@server

If your license server is up and running then make sure to set the only XILINXD_LICENSE_FILE environment variable, the license file which is serving the floating server should not be pointed directly from VLM as it is already being served to the floating server, in this cases tools get confused which license to be used.

If still issue persists then share the following files to check this issue:

  1. The complete license file(xilinx.lic).
  2. Run the below command from Vivado TCL console and share the generated xinfo.txt file, run pwd to know the location if this file.

report_environment -file xinfo.txt

 

Thanks & Regards,

Ansari Hunen

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as a solution.
-------------------------------------------------------------------------

 

View solution in original post

0 Kudos
anatoli
Moderator
Moderator
172 Views
Registered: ‎06-14-2010

Hello @LudovicoOrtombi ,

Is there any further assistance required in relation to this matter? If so, please let us know and we will be glad to help you further then.

However if your issue is resolved now, please mark a response as 'Accepted Solution' (more info on this can be found here: https://forums.xilinx.com/t5/help/faqpage/faq-category-id/solutions#solutions), so that the topic can be completed then.

We appreciate your help.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------
0 Kudos