cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
salgat1507
Newbie
Newbie
37,305 Views
Registered: ‎09-26-2009

Trying to run ISE Webpack (Linux)

The script installs everything fine, was able to successfully update to 11.3. However, I can't for the life of me figure out how to run the actual program. Running the settings32.sh returns no prompt, and seemingly does nothing.
0 Kudos
25 Replies
davidch
Xilinx Employee
Xilinx Employee
37,281 Views
Registered: ‎08-10-2007

You need to source settings32.sh to setup your environment and then run "ise".
0 Kudos
zaxis
Visitor
Visitor
35,809 Views
Registered: ‎11-13-2010

I actually have this same problem. I don't think this topic has been solved yet so I will "reawaken" it by posting here

 

I am running Ubuntu 10. I do the following in the /opt/Xilinx/12.3/ISE_DS/ folder, where I installed it:

 

export DISPLAY=:0

source settings32.sh

./settings32.sh

ise

 

./settings32.sh yields these messages:

. /opt/Xilinx/12.3/ISE_DS/EDK/settings32.sh /opt/Xilinx/12.3/ISE_DS/EDK
. /opt/Xilinx/12.3/ISE_DS/ISE/settings32.sh /opt/Xilinx/12.3/ISE_DS/ISE
. /opt/Xilinx/12.3/ISE_DS/PlanAhead/settings32.sh /opt/Xilinx/12.3/ISE_DS/PlanAhead
. /opt/Xilinx/12.3/ISE_DS/common/settings32.sh /opt/Xilinx/12.3/ISE_DS/common

When I run "ise" it tells me that the command is not found and then suggests some packages that I could apt-get.

 

I can't find anything that explains what is wrong. I'd appreciate the help. Thanks!

0 Kudos
awillen
Mentor
Mentor
35,806 Views
Registered: ‎11-29-2007

Please post the output of

 

echo $PATH

 after you sourced the appropriate settings??.sh

 



Please google your question before asking it.
If someone answers your question, mark the post with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (the star on the left).
0 Kudos
zaxis
Visitor
Visitor
35,756 Views
Registered: ‎11-13-2010

Sorry about the late reply. This has been a busy few days for me...

 

The output off echo $PATH gives me this:

/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games

 

Note that this is after I source and run the settings32.sh script. It doesn't look like anything xilinx specific has been added.

 

I did figure out how to run the programs, though! The programs reside in the folders [path to xilinx install containing the settings32.sh file]/IDE/bin/lin and [path to xilinx install containing the settings32.sh file]EDK/bin/lin.

 

Just change to those directories and run the scripts. For example, I would go to the ISE/bin/lin folder and type in ./ise to run the Project Navigator. For some reason, all the guides tell you to just type in "ise" as if it were a command. Maybe this has to do with the settings32.sh script not working properly.

 

Now if only I could get the license manager to show up...

0 Kudos
zaxis
Visitor
Visitor
35,733 Views
Registered: ‎11-13-2010

I found that too. It's in [xilinx installation directory]/common/bin/lin.

 

Then do this: ./xlcm. However in linux you can't use the Xilinx License Configuration Manager. You have to set one of XILINXD_LICENSE_FILE or LM_LICENSE_FILE environment variables to the location of your license.

 

You can do this by setting an environmental variable normally in linux:

 

export XILINXD_LICENSE_FILE=place@asdf

 

for a floating license, for example.

 

Also, I think this might have to be done every time you restart the computer or xorg (the GUI). You can put this in a bash script called startise, though, and put that script in /usr/local/bin so that whenever you want to start ise, it'll source your settings variables, load the license file and then run ise.

 

If you want an outline of startise, I might put one up later. If you ask nicely. :D

0 Kudos
Anonymous
Not applicable
35,304 Views

I've just reinstalled ISE 12.3 after moving from a Windows to a Linux machine and thought I'd only have to drop the license file in an appropriate place and tell ISE where to find it.. But the menu item 'Help > Manage License' doesn't do or launch anything, and upon checking the tips above, I found that there is no 'xlcm' command or file at all in the 'lin' directory. There is one 'xlicmgr', but that doesn't appear to be the thing talked about, is it? Is there a better way than having to manually add environment variables?

 

TIA

0 Kudos
Anonymous
Not applicable
35,303 Views

Aye, spoke too soon. I was in the 'ISE/bin/lin/' directory, not in 'common/bin/lin/'. There's my xlcm. But upon trying to pick the license file, it keeps freezing, even when run as root. Not sure what about that. However, turned out it's not needed at all: Manually creating a '.Xilinx' directory in my home location and dropping the license file there fixed the problem.

Good day :)
0 Kudos
gremplar
Newbie
Newbie
34,829 Views
Registered: ‎01-09-2011

Under Ubuntu 10.4, I have created the following script file in my home directory to try to get this to work:

 

#startise - Starts the Xilinx ISE app
cd Xilinx/12.4/ISE_DS
source settings64.sh
. ./settings64.sh
ise &

I run the script file using '. ./startise', and ISE seems to start OK and run.  I haven't written any code with the ISE yet, since I'm new to all of this.

 

Does this seem logical?  What is everyone else out there doing?

 

 

0 Kudos
alkopop79
Visitor
Visitor
31,980 Views
Registered: ‎02-02-2012

Could you guys explain me how to install Webpack? I just installed Ubuntu, I only used Linux years ago for a research on singleboards. I have no idea how to install it. I mean, i don't even know where to start. There are multiple .xinstall folders... Could you help me get started? Thank you for the help in advance!

0 Kudos
alkopop79
Visitor
Visitor
24,575 Views
Registered: ‎02-02-2012

Apologies, found a great tutorial that should work:

 

http://www.philpem.me.uk/elec/fpga/ise12ubuntu/

0 Kudos
alkopop79
Visitor
Visitor
24,572 Views
Registered: ‎02-02-2012

The more research I do, the more confused I am. Apparently Xilinx only supports Red Hat and Suse Linux. None of them are free unfortunately, while the link in the previous post is about installing Webpack on Ubuntu - which is not supported but it's free. So which OS should I use? I'm skint and would rather use Ubuntu... Any ideas?

0 Kudos
kepsz
Visitor
Visitor
24,570 Views
Registered: ‎01-02-2012

ISE Webpack installs and runs well for me in Debian squeeze (wheezy repos) 32bit and Chakra Project 32 bit.

 

 

Btw, platform cabel driver fails to install in both platforms, so u need to use alternate programing solutions for your devices if exists.

0 Kudos
alkopop79
Visitor
Visitor
24,567 Views
Registered: ‎02-02-2012

Some reported success with Ubuntu. Might download Debian then. I had partial success with the install: managed to get xsetup running and everything went fine till the end where I got the following error:

 

Could not create destination path /opt/Xilinx/13.4/ISE_DS

 

I went back to the 'Select Destination Dierctory' where /opt/Xilinx/13.4 is chosen by default. Any ideas? 

0 Kudos
alkopop79
Visitor
Visitor
24,563 Views
Registered: ‎02-02-2012

I've tried to find Debian's 32 bit version but the source pages no longer exists. After a long and extensive research it seems Debian Squeeze is no longer available. I still can't install Webpack, please help!!!!!

0 Kudos
kepsz
Visitor
Visitor
24,561 Views
Registered: ‎01-02-2012

U can download every version of Squeeze in debian.org's download page: squeeze download page

 

 

In my installs, i installed ISE webpack to a directory in a mounted NTFS drive, because of the enormous storage space  requirements. This drive is mounted with R/W premissions to ordinary users, no SU required.

0 Kudos
alkopop79
Visitor
Visitor
24,530 Views
Registered: ‎02-02-2012

Managed to install webpack after several operating system re-installs. Sticked with Ubuntu, it seems to work fine! T

0 Kudos
fperal
Newbie
Newbie
23,840 Views
Registered: ‎05-29-2012

>  Apparently Xilinx only supports Red Hat and Suse Linux. None of them are free

 

SuSE     IS     free:  www.opensuse.org

 

regards

0 Kudos
cousteau
Adventurer
Adventurer
23,837 Views
Registered: ‎05-11-2010


@fperal wrote:

SuSE     IS     free: www.opensuse.org


That's not SuSE, that's OpenSUSE.  It's not the same, although OpenSUSE is based on SuSE.  Xilinx specifically requires "SUSE Linux Enterprise 11 (32-bit and 64-bit)".  Xilinx may or may not work on other versions due to version changes, missing programs, etc.

0 Kudos
nefeesro
Visitor
Visitor
23,266 Views
Registered: ‎08-08-2012

I'm stuck in the same part you were, I managed to run the xsetup, but I cannot make the part of the settings32.sh . Once I type "ise" on the terminal, nothing happens.
Can you tell me what steps did you use?

 

Thanks in advance

0 Kudos
koates
Visitor
Visitor
12,418 Views
Registered: ‎08-19-2012

To clarify for others in this same predicament.

The settings32.sh (or whatever applies to your system) only seems to set up some Environment variables that (presumably) the Xilinx tools need. It does NOT add any of the executables you need to the path (I think it should, or at least should be documented better).

On my system (Ubuntu12.04, but ISE Embedded, not WebPack) it installed to

/opt/Xilinx/14.2/ISE_DS

 

The executables are scattered about under that directory, specifically;

(tip, if you're a linux newbie, try something like

> find /opt/Xilinx/14.2/ISE_DS -executable -name "ise"

)

 

for a 32bit system;

/opt/Xilinx/14.2/ISE_DS/ISE/bin/lin/ise

 

for a 64bit system;

/opt/Xilinx/14.2/ISE_DS/ISE/bin/lin64/ise

 

The others are in similar sorts of places, eg PlanAhead

/opt/Xilinx/14.2/ISE_DS/PlanAhead/bin/planAhead

 

I figure there is probably a good reason (maybe?) for this bin paths not being added to the path, so probably the easiest way forward would be to either creates links to the relevant exe's in somewhere like /usr/bin/

eg 

> sudo ln -s /opt/Xilinx/14.2/ISE_DS/PlanAhead/bin/planAhead /usr/bin/planAhead

or create an alias in your (equivilent of) .bashrc, eg

alias planAhead=/opt/Xilinx/14.2/ISE_DS/PlanAhead/bin/planAhead

 

my 2c

0 Kudos
tj.tr33
Visitor
Visitor
11,249 Views
Registered: ‎03-17-2013

Hello,

I cannot get the tutorials to run the examples.

 

Trying to get started with FPGA's, I've installed both 14.4 and 9.2i sp4.

14.4 because its newest latest greatest,

and 9.2i sp4 because iof 2 days failure with 14.4, and others said they had success with 9.2

 

Both 'run' but do not 'work'

meaning neither can run the supplied tutorials, and both open up the app.

 

It's now been several days now of carefully plodding thru the tutorials.

But they always fail.

 

The web is chock full of advise that doesnt work. ( run sudo , change the supplied ld libraries... blah blah blah)

 

The supplied tutorials should 'just work' .

So something else, pretty basic is wrong

 

I use ubuntu 12.04 LTS ( the Lonf Term Support, supposedly the most stabile fork )

I have it installed on an ext3 partition and mounted,  

The install directory is /media/34Gbulk/opt/Xilinx92i

 

I run the ISE by sourcing the script

. ./settings.sh

then i type

ise

runs fine, I see lotsa neat stuff

but

IPs fail and Timing fails.

 

Adding any IP fails:

 If I add any IP it fails saying the IP is not supported ,

  but gives a nice spin box full of devices where that IP >IS< supported

 and I try one of the supported devices...

 that newly suggested device fails same way, 

 and interestingly, hides itself from the valid list and offers others

 This is a ruse, they all are unsupported.

 IP just doesnt work for me

 This was experienced on 14.4, using the stopwatch tutorial, i didnt have the energy to try it on 9.2i

 

Timing fails:

 If I try the bulit in (menu bar)  tutorial for 92.i with service pack 4 installed

 I get errors at  Project | New Source | Add New Source | Test Bench Waveform | counter_tbw

 the error occurs when I accept the new file

 and the app tells me

  """

  Project Navigator will now create a new skeleton source with the following specifications:

 

  Add to Project: Yes
  Source Directory: /media/34Gbulk/opt/Xilinx92i/tutorial
  Source Type: Test Bench WaveForm
  Source Name: counter_tbw.tbw

  Association: counter

  """


 when I click on FINISH

 the app tells me

  """

  The Directory

  /media/34Gbulk/opt/Xilinx92i/tutorial

  does not exist, Would you like to create it?

  """

  WHAT???

 that directory does exist

 another terminal can prove it, i leave the ISE app waiting for YES | NO ...

  """"

  tomp@dm510-1204:/media/34Gbulk/opt/Xilinx92i$
  tomp@dm510-1204:/media/34Gbulk/opt/Xilinx92i$ cd tutorial/
  tomp@dm510-1204:/media/34Gbulk/opt/Xilinx92i/tutorial$ ls
  counter.prj  counter_summary.html  counter.xst                          templates     tutorial.ise_ISE_Backup  _xmsgs
  counter.stx  counter.vhd           __ISE_repository_tutorial.ise_.lock  tutorial.ise  tutorial.restore         xst
  tomp@dm510-1204:/media/34Gbulk/opt/Xilinx92i/tutorial$

  """

  the ISE has a different idea of 'exists' from the OS

  the directory premisiions are rwxrw-rw-, i've even forced then to rwxrwxrwx and gotten same result

 

  so

  the ISE is hung at this point

  if I say NO, it loops backs to same point

  if I say YES, it says the direcotry doesnt exist

 

 

Has anyone ever gotten the Xilink tutorials to work under Ubuntu 12.04?

if so, please tell me how.

 

I know people have said that the Webpack or ISE 'works'

but my definition is different, it has to be able to complete the tutorial.

 

regards

TomP

 

0 Kudos
tj.tr33
Visitor
Visitor
11,241 Views
Registered: ‎03-17-2013

I tried installing once more, the single pkg linux installl on 17mar2013.

Dload was fine, install was ok.

But it still cant process the standard tutorial.

The 'stopwatch' tutorial fails to add the IP asked fro in the tutorial.

"""

INFO:ProjectMgmt - Parsing design hierarchy completed successfully.
INFO:HDLCompiler:1061 - Parsing VHDL file
   "/home/tomp/xilinx_tutorial/wtut_vhd/debounce.vhd" into library work
INFO:ProjectMgmt - Parsing design hierarchy completed successfully.
ERROR:encore:372 - Failed to set default project options.
Loaded all available family support information.
ERROR:sim:569 - Failed to set default project options.
ERROR:encore:268 - Project
   /home/tomp/xilinx_tutorial/wtut_vhd/coregen_xil_3tcbIP.cgc could not be
   opened
ERROR:encore:312 - Couldn't create new project.
The IP Catalog has been reloaded.
[fopen]: No such file or directory

"""

ok, the err points to AR#53695

and that says...

"""

Solution


In the WebPACK tool install, the CORE Generator tool is not properly loading the available device families for the IP catalog. This prevents a device family from being loaded and causes all IP in the catalog to be listed as unavailable for the current device (greyed out).

To work around this issue, perform one of the following:

  • Use a full install of the ISE tools. The full install is larger, but uses the same executables as the WebPACK tool install. Devices and feature access will be controlled by the license available.
  • Set Environment variable XIL_CG_LOAD_ALL_FAMILIES=true

"""

please tell me how to proceed with this 'use a full install' ?

do i wipe the 7Gig i had installed and download something other than the 'linux full install'?

this is my 3rd install over a period nearing one week trying to get this to complete the tutorials.

btw: this time i sourced the tcl script to make the project

same result

 

regards

TomP

 

 

0 Kudos
kelvin80
Newbie
Newbie
10,936 Views
Registered: ‎05-16-2013

Thanks... I had the same problem.

0 Kudos
nathanluke
Newbie
Newbie
7,808 Views
Registered: ‎10-17-2014

This worked for me while installing the license manually. (the license which i got over my email and is named 'Xilinx.lic'

 

Thank you very much for the tip.

 

Cheers

0 Kudos
left4bagels
Newbie
Newbie
5,361 Views
Registered: ‎12-27-2015

Thanks a ton. I was having a really hard time getting this running.
0 Kudos