cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Anonymous
Not applicable
6,473 Views

Unknown XILINX device. Driver issue

After a recent reformat of the hard drive of our computer, the Platform Cable USB II (DLC10) no longer functions. The installation appears to go OK (when manually typing in the code from the batch file into the command prompt - the automatic version cannot find a file), and there is an amber light on the unit. However when connecting to the target device the programmer no longer turns green.

 

Windows 7 does not seem able to find the drivers for the unit, and we end up with the error displayed in the picture.

 Error message.jpg

Windows is unable to offer any indication as to what this device is, other than labelling it XILINX - even after searching online.

 

We are using Webpack ISE 8.2i (yes we know it's old), which was installed on a fresh copy of Windows.

 

I'd appreciate any suggestions

Thanks

Andy

0 Kudos
2 Replies
gszakacs
Professor
Professor
6,471 Views
Registered: ‎08-14-2007

ISE 8.2i does not support Windows 7.  If you have already tried loading the drivers with XP compatibility mode,

then my other suggestion would be to download just the "Lab Tools" for the lates revision ISE 13.2 and install those.

You may have better luck, and it's possible that ISE 8.2i will run after the newer drivers are installed.  Otherwise

you could always use the latest version of Impact regardless of the version of ISE that built the design.

 

-- Gabor

-- Gabor
hdehdast
Newbie
Newbie
5,208 Views
Registered: ‎04-16-2014

This Problem Was solved.

I use ISE14.4 and windows 7 64 bit.

 

In this case iMPACT reports that it cannot find the cable and the Jungo driver never appears in device manager and Windrvr6.sys is not copied to the system32 directory. The driver cannot be manually installed either.

 

solution:

 

This has been seen on some Windows 7 machines due to an issue with the difxapi.dll file supplied by Jungo. The workaround is to manually install using the -compat option to bypass this. You will need to uninstall and reinstall the cable driver to achieve this.



(1) In a command prompt browse to your C:\Xilinx\13.2\ISE_DS\ISE\bin\nt64 directory on 64-bit installs or C:\Xilinx\13.2\ISE_DS\ISE\bin\nt on 32-bit installs
(2) To uninstall type the command: wdreg -compat -inf %cd%\windrvr6.inf uninstall
(3) To reinstall type the command:  wdreg -compat -inf %cd%\windrvr6.inf install

 

Refrence:

AR# 44397
13.x/14.x iMPACT - Cable Driver Installation - Installation passes on Windows 7 but the Jungo driver Windrvr6 does not operate or appear in the device manager

 

http://www.xilinx.com/support/answers/44397.html

 

0 Kudos