cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
618 Views
Registered: ‎01-24-2020

Versal ES part synthsize issue

Jump to solution

Hello,

I am trying to create a project with Versal engineering sample part. I got a license and I enable beta devices and I can choose the Versal ES part for my project, but when I run synthesis is giving me an error. I tried with the newest and older version of Vivado, still the same. The IP is not the issue because I tried with different ones and also very simple design and still I get an error.

I will add some images so you can se the error.

 

Thanks

Tags (1)
ES_part_error.png
0 Kudos
1 Solution

Accepted Solutions
anatoli
Moderator
Moderator
564 Views
Registered: ‎06-14-2010

Hello @alexandros-kapouranis ,

The reason for this behaviour is that you've ran the enable_beta_device Tcl command AFTER you've opened the GUI.

You see, you need to have a Vivado_init.tcl file (with this enable_beta_device Tcl command in it) that needs to be executed PRIOR the Vivado GUI opens.

Therefore, do you have Vivado_init.tcl file with this command in it: enable_beta_device* set?

e.g.:

image.png

You would then need to put this Vviado_init.tcl file into the location such as C:\Users\<user_name>\AppData\Roaming\Xilinx\Vivado

E.g.:

image.png

With the required license and with this Vviado_init.tcl file in place, if you’d open Vivado then, the required ES devices would be enabled for you then.

Hope this help.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------

View solution in original post

1 Reply
anatoli
Moderator
Moderator
565 Views
Registered: ‎06-14-2010

Hello @alexandros-kapouranis ,

The reason for this behaviour is that you've ran the enable_beta_device Tcl command AFTER you've opened the GUI.

You see, you need to have a Vivado_init.tcl file (with this enable_beta_device Tcl command in it) that needs to be executed PRIOR the Vivado GUI opens.

Therefore, do you have Vivado_init.tcl file with this command in it: enable_beta_device* set?

e.g.:

image.png

You would then need to put this Vviado_init.tcl file into the location such as C:\Users\<user_name>\AppData\Roaming\Xilinx\Vivado

E.g.:

image.png

With the required license and with this Vviado_init.tcl file in place, if you’d open Vivado then, the required ES devices would be enabled for you then.

Hope this help.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------

View solution in original post