UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor _baciek
Visitor
511 Views
Registered: ‎10-04-2018

Vivado 2015.4 Color Fillter Array Interpolation licensing error

Jump to solution

Hello!

 

I'm working on Avnet's MicroZed Embedded Vision Kit with a ON-PYTHON-1300c Camera Module.

Trying to create a Camera -> HDMI_OUT passthrough design (to add some more IP later). I need to use Color Filter Array Interpolation IP from Xilinx. I'm trying to acquire a license for this block.

I've filled all the boxes on License Manager (on website) and finally got my Xilinx.lic file (the one that is for free). Then I've tried to install it in License Manager on my computer. By viewing all my licenses I can tell it was succesful. Unfortunatly when I try to add CFA Interpollation IP to my project and run report_ip_status I get an error - missing license. What's the reason? What have I done wrong?

 

Device I'm working on: MicroZed 7020 Board (xc7z020clg400-1), Windows 7 64bit ver, Vivado 2015.4, License version I need and (probably have): 7.0

 

Thanks :)

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
473 Views
Registered: ‎06-14-2010

Re: Vivado 2015.4 Color Fillter Array Interpolation licensing error

Jump to solution

Hello @_baciek,

 

It looks like Vivado can’t detect or see where exactly this license is located.

 

Therefore, please follow the below steps and see if this helps:

 

Set XILINXD_LICENSE_FILE to specifically tell Vivado where to look for this license (e.g. C:\.Xilinx);

Open Vivado and do Report IP Status;

Check if for all of the IPs found in the design, you are seeing either Purchased/Bought or HW_Eval and not Design_Linking; 

 

Hope this helps.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
4 Replies
Visitor _baciek
Visitor
510 Views
Registered: ‎10-04-2018

Re: Vivado 2015.4 Color Fillter Array Interpolation licensing error

Jump to solution
I'm using Vivado Webpack - the free one.
0 Kudos
Moderator
Moderator
478 Views
Registered: ‎03-16-2017

Re: Vivado 2015.4 Color Fillter Array Interpolation licensing error

Jump to solution

Hi @_baciek,

 

Reset output products and regenerate it after adding the license of CFA IP. If it does not help :

 

1. Provide snapshot of error message. 

2. Provide license file of this IP.

3. And run "report_environment -file <filepath>/env.txt" and provide env.txt to evaluate.

 

Regards,

hemangd

Regards,
hemangd

Don't forget to give kudos and mark it as accepted solution if your issue gets resolved.
0 Kudos
Moderator
Moderator
474 Views
Registered: ‎06-14-2010

Re: Vivado 2015.4 Color Fillter Array Interpolation licensing error

Jump to solution

Hello @_baciek,

 

It looks like Vivado can’t detect or see where exactly this license is located.

 

Therefore, please follow the below steps and see if this helps:

 

Set XILINXD_LICENSE_FILE to specifically tell Vivado where to look for this license (e.g. C:\.Xilinx);

Open Vivado and do Report IP Status;

Check if for all of the IPs found in the design, you are seeing either Purchased/Bought or HW_Eval and not Design_Linking; 

 

Hope this helps.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Visitor _baciek
Visitor
457 Views
Registered: ‎10-04-2018

Re: Vivado 2015.4 Color Fillter Array Interpolation licensing error

Jump to solution

Hello :)

 

Thanks you for your really quick response.

 

I have solved my problem a little bit diffrent, probably more roughly. I've decided to delete all Xilinx files from my computer and reinstall Vivado 2015.4 (and the rest of Xilinx programs). This time I've installed them on my OS volume (I didn't want to do this previously). I've also generated a new license and moved the .lic file to Xilinx dir.

 

I don't know how, but it helped. Now I just keep my fingers crossed that it won't break after turning off/on the computer again :)

0 Kudos