UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Reply

Vivado 2017.1 not enabling beta devices

Accepted Solution Solved
Highlighted
Visitor
Posts: 8
Registered: ‎04-21-2017
Accepted Solution

Vivado 2017.1 not enabling beta devices

Hi,

 

I seem to have a licensing problem with Vivado 2017.1 not enabling beta devices.

When I open Vivado the command line shows

 

Sourcing tcl script 'C:/Xilinx/Vivado/2017.1/scripts/Vivado_init.tcl'
52 Beta devices matching pattern found, 0 enabled.
52 Beta devices matching pattern found, 0 enabled.
218 Beta devices matching pattern found, 0 enabled.

 

So I have the initialization script correct but none of the beta devices are enabled.

 

When I run "report_environment" it shows that I have licenses for the beta devices.

| xczu9eg-es1                | Tools             | 2017.12 | Permanent | 20-Apr-2017 | Nodelocked              | Uncounted |            | FLEXID=9-3740be7b | Yes             |                                                                                                                                                                                                                            | Xilinx Inc                   | 181           | Okay             | Not Applicable  | C:\.Xilinx\Xilinx_21-04-17a.lic                              | hughlewisuk,xczu9eg-es1,software,permanent,_177164068_1777521186_210643621_505          |
| xczu9eg-es1                | Tools             | 2017.12 | Permanent | 20-Apr-2017 | Nodelocked              | Uncounted |            | FLEXID=9-3740be7b | Yes             |                                                                                                                                                                                                                            | Xilinx Inc                   | 182           | Okay             | Not Applicable  | C:\.Xilinx\Xilinx_21-04-17a.lic                              | hughlewisuk,xczu9eg-es1,software,permanent,_177164068_1777521186_210647009_469          |
| xczu9eg-es1                | Tools             | 2018.04 | Permanent | 20-Apr-2017 | Nodelocked              | Uncounted |            | FLEXID=9-3740be7b | Yes             |                                                                                                                                                                                                                            | Xilinx Inc                   | 183           | Okay             | Not Applicable  | C:\.Xilinx\Xilinx_21-04-17a.lic                              | hughlewisuk,xczu9eg-es1,software,permanent,_177164068_1777521186_0_363                  |
| xczu9eg-es1                | Tools             | 2020.12 | Permanent | 20-Apr-2017 | Nodelocked              | Uncounted |            | FLEXID=9-3740be7b | Yes             |                                                                                                                                                                                                                            | Xilinx Inc                   | 184           | Okay             | Not Applicable  | C:\.Xilinx\Xilinx_21-04-17a.lic                              | hughlewisuk,xczu9eg-es1,software,permanent,_177164068_1777521186_210641614_946          |

 

Any ideas as to why I can't enable them?

 


Accepted Solutions
Xilinx Employee
Posts: 689
Registered: ‎11-09-2015

Re: Vivado 2017.1 not enabling beta devices

Hi Hugh @hughlewisuk,

 

We were about to ask you to check if the beta devices were correctly installed (I missed that it was @cone83 who said that he had a full installation).

 

I guess you have missed this because 2017.1 is the first version in which you have to enable the ES devices separately.

 

As the issue is solved, could you mark the post as solved? It could help others ;-)

 

Regards,

 

Florent

--------------------------------------------------------------------------------------------
Please mark an answer "Accept as solution" if a post has the solution to your issue.

--------------------------------------------------------------------------------------------

View solution in original post


All Replies
Xilinx Employee
Posts: 689
Registered: ‎11-09-2015

Re: Vivado 2017.1 not enabling beta devices

Hi @hughlewisuk,

 

The steps are not really defined yet so I am not sure but did you first enable them when installing Vivado 2017.1?

 

ES.JPG

 

Regards,

 

Florent

--------------------------------------------------------------------------------------------
Please mark an answer "Accept as solution" if a post has the solution to your issue.

--------------------------------------------------------------------------------------------
Xilinx Employee
Posts: 131
Registered: ‎09-15-2016

Re: Vivado 2017.1 not enabling beta devices

Hi @hughlewisuk

 

Can you share the license and the xinfo file?

 

Regards

Rohit

Visitor
Posts: 8
Registered: ‎04-21-2017

Re: Vivado 2017.1 not enabling beta devices

Here are the two files.

Everything works fine with  Vivado 2016.4

 

Sourcing tcl script 'C:/Xilinx/Vivado/2016.4/scripts/init.tcl'
16 Beta devices matching pattern found, 16 enabled.
16 Beta devices matching pattern found, 16 enabled.
144 Beta devices matching pattern found, 144 enabled.
start_gui

 

But as you can see not with 2017.1

 

Sourcing tcl script 'C:/Xilinx/Vivado/2017.1/scripts/Vivado_init.tcl'
52 Beta devices matching pattern found, 0 enabled.
52 Beta devices matching pattern found, 0 enabled.
218 Beta devices matching pattern found, 0 enabled.

 

Thanks

 

 

Participant
Posts: 43
Registered: ‎04-23-2014

Re: Vivado 2017.1 not enabling beta devices

I have exactly the same problem with Vivado 2017.1 on Linux. Running the init script also outputs "0 enabled". I have done a complete install enabling everything, including engineering sample devices. In the list of available devices I can see ES2 devices, but no ES1.

Xilinx Employee
Posts: 131
Registered: ‎09-15-2016

Re: Vivado 2017.1 not enabling beta devices

Hi @hughlewisuk

 

You have license for the XCZU* devices

Can you write " enable_beta_device xczu*" command in the Vivado_init.tcl and then launch the Vivado and see if it helps?

 

Regards

Rohit

 

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

Visitor
Posts: 8
Registered: ‎04-21-2017

Re: Vivado 2017.1 not enabling beta devices

That is exactly what I have in the Vivado_init.tcl already. So that is not the problem.

 

The problem seems to be with the license as the same script and licenses work with 2016.4.

 

It is very frustrating to not be able to proceed with 2017.1. But I guess Xilinx will sort the problem in due course and I will have to wait for 2017.2 to use the latest features.

Xilinx Employee
Posts: 689
Registered: ‎11-09-2015

Re: Vivado 2017.1 not enabling beta devices

Hi @hughlewisuk,

 

I was able to enable the ES1 devices on my computer using enable_beta_device* directly in Vivado. Could you try it?

-> open vivado (without any project)

-> type "enable_beta_device*" in the tcl console (you should have 529 Beta devices matching pattern found, 56 enabled.)

 

I will try in the init.tcl file

 

Regards,

 

Florent

--------------------------------------------------------------------------------------------
Please mark an answer "Accept as solution" if a post has the solution to your issue.

--------------------------------------------------------------------------------------------
Visitor
Posts: 8
Registered: ‎04-21-2017

Re: Vivado 2017.1 not enabling beta devices

I get

 

"

start_gui
enable_beta_device*
218 Beta devices matching pattern found, 0 enabled.

"

I then deleted my init.tcl file and tried again with the same result.

 

I have also just run "report_environment" and again it is showing the licenses for xczu9eg-es1

 

So still no joy. Weird.

 

Xilinx Employee
Posts: 689
Registered: ‎11-09-2015

Re: Vivado 2017.1 not enabling beta devices

Hi @hughlewisuk,

 

Did you already try to regenerate your license for the early access devices? If not could you try?

 

I have tried with both init.tcl and Vivado_init.tcl and it is working for me. I have a customer license (not an internal one). So I am not sure about what is the issue for you.

 

Regards,

 

Florent

--------------------------------------------------------------------------------------------
Please mark an answer "Accept as solution" if a post has the solution to your issue.

--------------------------------------------------------------------------------------------