cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
afilgueras
Contributor
Contributor
2,526 Views
Registered: ‎03-05-2014

Vivado 2017.4 does not find zynq ultrascale es1 devices

Jump to solution

Hi,

 

I'm trying to use a zynq ultrascale es1 device (xczu9eg-ffvc900-1-i-es1) but for some reason vivado does not find it.

I've been using it with vivado 2017.3 without any problem, but zynqmp es1 devices do not appear in 2017.4 version.

 

I'm using the same licenses in the same machine in both cases. es1 licenses for this device are 2017.10 so as long as I know, there should not be any license problem.

 

I've also set up the init file in ~/.Xilinx/Vivado/2017.4/Vivado_init.tcl to enable beta devices

enable_beta_device xczu9eg*

When I start vivado, it does not enable any device.

16 Beta devices matching pattern found, 0 enabled.

Any idea why I cannot use es1 devices?

 

Thank you

0 Kudos
1 Solution

Accepted Solutions
devinl
Community Manager
Community Manager
2,898 Views
Registered: ‎05-08-2017

Hi @afilgueras,

 

I see your issue now. The Vivado 2017.4 version requires a license version limit of 2017.12 to be compatible. Below is our version limit chart.

 

https://www.xilinx.com/support/answers/33770.html

 

Thank you,

Devin

View solution in original post

6 Replies
devinl
Community Manager
Community Manager
2,511 Views
Registered: ‎05-08-2017

Hi @afilgueras,

 

Have you verified that the device MPSoC ES devices box was checked during the installer? You can verify this by going into the Vivado GUI and selecting help > add design tools or devices.

 

Thank you,

Devin

0 Kudos
afilgueras
Contributor
Contributor
2,476 Views
Registered: ‎03-05-2014

As long as I can tell, ES devices are installed.

In fact zynqmp ES2 devices do show up.

 

Here are my currently installed components, just in case there's something missing that I did not notice.

 

vivado install new devices.png

 

Than you

0 Kudos
devinl
Community Manager
Community Manager
2,899 Views
Registered: ‎05-08-2017

Hi @afilgueras,

 

I see your issue now. The Vivado 2017.4 version requires a license version limit of 2017.12 to be compatible. Below is our version limit chart.

 

https://www.xilinx.com/support/answers/33770.html

 

Thank you,

Devin

View solution in original post

anatoli
Moderator
Moderator
2,450 Views
Registered: ‎06-14-2010

Hello @afilgueras,

 

As correctly indicated by @devinl, your current ES license is not valid for 2017.4 version of Vivado.

In this case, you should be able to log in to www.xilinx.com/getlicenses and in here, you should now be able to select and generate the same license file (but with a newer/updated version limit) and this should fix your issue.

 

If you have any further questions for us, please let us know.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------
afilgueras
Contributor
Contributor
2,429 Views
Registered: ‎03-05-2014

I've checked,  the licenses, and they are 2017.10.

 

Thank you

0 Kudos
rayhoare
Observer
Observer
2,399 Views
Registered: ‎03-26-2008

I am having this same issue.  My license version is > 2017.12, and I see all the ES2 devices when I go to "Select Device".  There are no ES1 devices listed.  Please advise.

0 Kudos