UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer transamdan
Observer
335 Views
Registered: ‎12-11-2017

Vivado 2019.1 timeout when starting

Jump to solution

I had a simuilar issue on 2017 and also 2018 where the application will time out after clicking on the icon. Finding help on forums fixed my problem. However those fixes are not working for 2019.1

 

#-----------------------------------------------------------
# Vivado v2019.1 (64-bit)
# SW Build 2552052 on Fri May 24 14:49:42 MDT 2019
# IP Build 2548770 on Fri May 24 18:01:18 MDT 2019
# Start of session at: Thu Jun  6 15:13:22 2019
# Process ID: 14904
# Current directory: C:/Xilinx/Vivado/2019.1/bin
# Command line: vivado.exe
# Log file: C:/Xilinx/Vivado/2019.1/bin/vivado.log
# Journal file: C:/Xilinx/Vivado/2019.1/bin\vivado.jou
#-----------------------------------------------------------
couldn't load library "librdi_vivadotasks.dll": this library or a dependent library could not be found in library path
Could not load library 'librdi_vivadotasks' needed by 'vivado', please check installation.
    while executing
"error "$result\nCould not load library '$library' needed by '$feature', please check installation.""
    (procedure "rdi::load_library" line 4)
    invoked from within
"rdi::load_library vivado librdi_vivadotasks"
    (file "C:/Xilinx/Vivado/2019.1\lib\scripts\rdi\features\vivado\vivado.tcl" line 40)
ERROR: [Common 17-217] Failed to load feature 'vivado'.
INFO: [Common 17-206] Exiting Vivado at Thu Jun  6 15:13:25 2019...

I have installed the Visual C 2015 redistributable and still the same error. Spent a number of days trying to resolve this. I'm still stuck.

 

0 Kudos
1 Solution

Accepted Solutions
Observer transamdan
Observer
260 Views
Registered: ‎12-11-2017

Re: Vivado 2019.1 timeout when starting

Jump to solution

Made progress. Been working on this most of the weekend. I have made a breakthrough. 

I know someone else was having isues. So wanted to post my findings.

I was getting a couple of lines saying

'MySQL' is not recognised as an internal or external command, operable program or batch file.

After coming to many dead end with the DLL's. I thought I'd best concentrate on the SQL errors as they appear first. modifying many batch files to fill with Echo comments to know what is executing what. I ended up in the Loader.bat file.

Around line 510 (I've added comments so my line count is off now) of Loader.bat is:-

set PATH=%PATH:"=%

I commented this out, and now the GUI starts from the command prompt. What does this mean? Well there is probably something wrong with my path settings in the Environment settings. 

environment_settings.png

Now I tried removing many paths settings, just left with Modeltech MobelSim, however this didn't make any different. The only solution for me appears to be commenting out that one line in Loader.bat. This dosn't appear to have any negative effect.

rem #set PATH=%PATH:"=%

Hope this helps someone out.

9 Replies
Observer cesar_kwan
Observer
330 Views
Registered: ‎10-31-2007

Re: Vivado 2019.1 timeout when starting

Jump to solution

I have the same problem.

0 Kudos
Scholar drjohnsmith
Scholar
321 Views
Registered: ‎07-09-2009

Re: Vivado 2019.1 timeout when starting

Jump to solution

problems like this in the past

'get arounds'

a) Do yo have multipel versoin of vivado installed ?

b) clean up the registery

c) ensure you installed to all the default folders

d) ensure you are administartor if its a windows machine

 

Agree, none of this should make any difference,

     but , experiance over the years has shown "otherwise" in all CAE tools.. 

 

 

0 Kudos
Observer transamdan
Observer
309 Views
Registered: ‎12-11-2017

Re: Vivado 2019.1 timeout when starting

Jump to solution
Thanks for the info. That gave me something to try.

I have had multiple versions of Vivado installed in the past, Installed new and uninstall the old. I am the only user on the PC and am the administrator.
Uninstalled all versions, and then went through the registry, ripping out any reference to Xilinx and Vivado. then ran a registry Clean.
So at this point, all nice and clean, looking in add/remove programs, there is no trace of xilinx, no files on the machine from xilinx.
Rebooted, then installed 2019.1, rebooted.
Ran by clicking on the icon, and it still timed out. I had my fingers crossed, knowing I have a clean registry, and I thought this could be it. It failed :(, so back to the command prompt, and the exact same error. Same Library error.

I have installed this on another PC at work, and it is running, but its not ideal, as need it on this particular PC. It is almost tempting to buy another PC, but extra expense. Even gone though the idea of reformatting and reinstalling windows, but soo many applications on here for PCB design, Visual Studio, Office and Actel. Its also a route in not too in favour of and its not guaranteed that path will work.

I have tried uninstalling the Visual C libraries 2015 and reinstalling but that didn't help either.
Scholar drjohnsmith
Scholar
305 Views
Registered: ‎07-09-2009

Re: Vivado 2019.1 timeout when starting

Jump to solution
sorry to hear no improvment,
one last question,
it is windows 10, 64 bit you have ?

its also interesting that the "/" in this line you shared is in different directions ?

"C:/Xilinx/Vivado/2019.1\lib\scripts\rdi\features\vivado\vivado.tcl"
0 Kudos
Observer transamdan
Observer
304 Views
Registered: ‎12-11-2017

Re: Vivado 2019.1 timeout when starting

Jump to solution

Windows 10 Pro 64 bit.

Well spotted on the '/' I didn't notice that. I wonder if that has an effect.

That was a pure copy and paste from the log file vivado.bat creates in the same directory. Just checked the latest log files, and yes there is a mismatch in '/'s. I havn't changed any directories/preferences, just a complete reinstall with all default settings. 

 

0 Kudos
Scholar drjohnsmith
Scholar
298 Views
Registered: ‎07-09-2009

Re: Vivado 2019.1 timeout when starting

Jump to solution
dont know if its significant / normal or what , but thougth I'd mention,
0 Kudos
Observer transamdan
Observer
290 Views
Registered: ‎12-11-2017

Re: Vivado 2019.1 timeout when starting

Jump to solution

Tried looking into the reversal of the back slashes.I beleive its in setupEnv.bat which appears to have some sort of reversal code in it. I have been experimenting in other ares like copying the DLL's to other locations. Also trying to see what dependancies that DLL had that comes up with the error, but my DLL inspector couldn't tell me.

Spent many hours on this and still no closer, well I guess it is closer as eliminated a few things Ihave tried. 

Observer transamdan
Observer
261 Views
Registered: ‎12-11-2017

Re: Vivado 2019.1 timeout when starting

Jump to solution

Made progress. Been working on this most of the weekend. I have made a breakthrough. 

I know someone else was having isues. So wanted to post my findings.

I was getting a couple of lines saying

'MySQL' is not recognised as an internal or external command, operable program or batch file.

After coming to many dead end with the DLL's. I thought I'd best concentrate on the SQL errors as they appear first. modifying many batch files to fill with Echo comments to know what is executing what. I ended up in the Loader.bat file.

Around line 510 (I've added comments so my line count is off now) of Loader.bat is:-

set PATH=%PATH:"=%

I commented this out, and now the GUI starts from the command prompt. What does this mean? Well there is probably something wrong with my path settings in the Environment settings. 

environment_settings.png

Now I tried removing many paths settings, just left with Modeltech MobelSim, however this didn't make any different. The only solution for me appears to be commenting out that one line in Loader.bat. This dosn't appear to have any negative effect.

rem #set PATH=%PATH:"=%

Hope this helps someone out.

Observer cesar_kwan
Observer
187 Views
Registered: ‎10-31-2007

Re: Vivado 2019.1 timeout when starting

Jump to solution

It does not work for me.


****** Vivado v2019.1 (64-bit)
**** SW Build 2552052 on Fri May 24 14:49:42 MDT 2019
**** IP Build 2548770 on Fri May 24 18:01:18 MDT 2019
** Copyright 1986-2019 Xilinx, Inc. All Rights Reserved.

couldn't load library "librdi_vivadotasks.dll": file busy
Could not load library 'librdi_vivadotasks' needed by 'vivado', please check ins
tallation.
while executing
"error "$result\nCould not load library '$library' needed by '$feature', please
check installation.""
(procedure "rdi::load_library" line 4)
invoked from within
"rdi::load_library vivado librdi_vivadotasks"
(file "C:/Xilinx/Vivado/2019.1\lib\scripts\rdi\features\vivado\vivado.tcl" l
ine 40)
ERROR: [Common 17-217] Failed to load feature 'vivado'.
INFO: [Common 17-206] Exiting Vivado at Wed Jun 12 16:51:19 2019...

0 Kudos