cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
pholcomb
Visitor
Visitor
666 Views
Registered: ‎12-10-2018

Vivado 2021.1 web installer batch mode: unexpected condition from server

Jump to solution

I got this error running xsetup on a Red Hat 7.9 system:

./xsetup --agree XilinxEULA,3rdPartyEULA,WebTalkTerms --batch Install --config /<LOCATIOn>/2021.1_install_config.txt
Running in batch mode...
Copyright (c) 1986-2021 Xilinx, Inc. All rights reserved.

INFO : Log file location - /<LOCATION>/.Xilinx/xinstall/xinstall_1624561739644.log
INFO : Internet connection validated, can connect to internet.
ERROR: The server encountered an unexpected condition which prevented it from fulfilling the request.

Is this "unexpected condition" coming from the Xilinx side or from my own computer?

 

These are the steps I took to get here (which are the similar steps I took to install previous versions) are:

  1. Download the "Xilinx_Unified_2021.1_0610_2318_Lin64.bin" linux Web installer
  2. Run it ./Xilinx_Unified_2021.1_0610_2318_Lin64 --noexec --target Xilinx_Unified_2021.1_0610_2318_Lin64
  3. From that directory run ./xsetup --batch ConfigGen, chose "Vivado ML Enterprise"
  4. Edit the install_config.txt to point to the correct installation location
  5. Run ./xsetup --batch AuthTokenGen
  6. Run ./xsetup --agree XilinxEULA,3rdPartyEULA,WebTalkTerms --batch Install --config path/<LOCATION>/2021.1_install_config.txt

I attached the xinstall.log file that was generated from this command.

0 Kudos
1 Solution

Accepted Solutions
anatoli
Moderator
Moderator
520 Views
Registered: ‎06-14-2010

Hello @pholcomb,

I've just checked your profile, and it is indeed not blocked or was blocked by the Export Compliance checks.

I would assume there was a glitch coming from the server side, as it is normally seen a similar behaviour when too many people (Xilinx internal and external users) are trying to obtain 2021.1 that just got releases yesterday, so on the first day of release.

If you can try today, once again, do you still see the same error? If so, please let us know, and i can ping out dev team then. Thanks 

 

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
6 Replies
watari
Professor
Professor
642 Views
Registered: ‎06-16-2013

Hi @pholcomb 

 

I guess it seems export compliance alert issue.

Would you refer the following AR ?

 

https://www.xilinx.com/support/answers/44043.html

 

Best regards,

0 Kudos
pholcomb
Visitor
Visitor
624 Views
Registered: ‎12-10-2018

I didn't see any "export compliance alert" messages in my log.

0 Kudos
watari
Professor
Professor
607 Views
Registered: ‎06-16-2013

Hi @pholcomb 

 

Unfortunately, this error ("ERROR: The server encountered an unexpected condition which prevented it from fulfilling the request.") is related with AR #44043.

So, would you refer this AR ?

 

Best regards,

0 Kudos
pholcomb
Visitor
Visitor
600 Views
Registered: ‎12-10-2018

I can download the web installer or the unified installer just fine from the Xilinx web site. Through that process I confirm my address and location each time on the web site before I click the download button. Based on that, I think that my profile information is known by Xilinx and that there are no export compliance issues associated with my account.

It is only when I run the web installer that I get this issue. So I still don't see the link between AR44043 and the issue I am seeing.

By the way, I was able to download and run the full unified installer without any errors.

0 Kudos
anatoli
Moderator
Moderator
521 Views
Registered: ‎06-14-2010

Hello @pholcomb,

I've just checked your profile, and it is indeed not blocked or was blocked by the Export Compliance checks.

I would assume there was a glitch coming from the server side, as it is normally seen a similar behaviour when too many people (Xilinx internal and external users) are trying to obtain 2021.1 that just got releases yesterday, so on the first day of release.

If you can try today, once again, do you still see the same error? If so, please let us know, and i can ping out dev team then. Thanks 

 

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
pholcomb
Visitor
Visitor
490 Views
Registered: ‎12-10-2018

I tried again today, and I no longer see this error.