cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Observer
Observer
12,126 Views
Registered: ‎03-02-2015

Vivado Ubuntu installation error - java.lang.ClassCastException

Jump to solution

Hi All,

 

I am currently in the process of installing Vivado on to Ubuntu 14.04 LTS. I am following a video tutorial that I found on Youtube:-

 

 

www.youtube.com/watch?v=iwVd4TIB0ME

 

I managed to get up to 26 minutes and 10 seconds in the tutorial with no problems but when I go to launch Vivado the error occurs.

 

When I type vivado into the terminal and press enter I get the following appear in the terminal:

 

****** Vivado v2015.2 (64-bit)
  **** SW Build 1266856 on Fri Jun 26 16:35:25 MDT 2015
  **** IP Build 1264090 on Wed Jun 24 14:22:01 MDT 2015
    ** Copyright 1986-2015 Xilinx, Inc. All Rights Reserved.

CRITICAL WARNING: [Common 17-741] No write access right to the local Tcl store at '/home/lincoln/.Xilinx/Vivado/2015.2/XilinxTclStore'. XilinxTclStore is reverted to the installation area. If you want to use local Tcl Store, please change the access right and relaunch Vivado.
ERROR: [Common 17-1257] Failed to create directory '/opt/Xilinx/Vivado/2015.2/tclapp'.
start_gui
Error: Failed to save the Vivado user preferences file. Reason: '/home/lincoln/.Xilinx/Vivado/2015.2/vivado.ini (Permission denied)'
Failed to create the shortcut directory: '/home/lincoln/.Xilinx/Vivado/2015.2/shortcuts'
Failed to create the layout directory: '/home/lincoln/.Xilinx/Vivado/2015.2/layouts/application'
Failed to create the commands directory: '/home/lincoln/.Xilinx/Vivado/2015.2/commands'
Failed to create the layout directory: '/home/lincoln/.Xilinx/Vivado/2015.2/layouts/'
Failed to create directory: /home/lincoln/.profile

 

The Vivado gui appears but it reports two errors:

 

[Common 17-1257] Failed to create directory '/opt/Xilinx/Vivado/2015.2/tclapp'.

[Vivado 12-106] *** Exception: java.lang.ClassCastException: javax.swing.text.PlainDocument cannot be cast to javax.swing.text.html.HTMLDocument (See /home/lincoln/vivado_pid2841.debug)

 

An error log is produced and the contents of the error log are:-

 

#-------------------------------------------------------------------------------
# Vivado v2015.2 (64-bit)
# SW Build 1266856 on Fri Jun 26 16:35:25 MDT 2015
# Current time: 7/14/15 12:14:27 PM EST
# Process ID: 2841
# Platform: Unix
#
# This report is an indication that an internal application error occurred.
# This information is useful for debugging. Please open a case with Xilinx
# Technical Support with this file and a testcase attached.
#-------------------------------------------------------------------------------
java.lang.ClassCastException: javax.swing.text.PlainDocument cannot be cast to javax.swing.text.html.HTMLDocument
at ui.b.b.a.a.bf.<init>(SourceFile:418)
at ui.b.b.a.a.bf.<init>(SourceFile:401)
at ui.b.b.a.a.aT.<init>(SourceFile:277)
at ui.b.b.a.a.cpr(SourceFile:166)
at ui.b.b.a.a.access$100(SourceFile:43)
at ui.b.b.a.c.ct(SourceFile:1142)
at ui.frmwork.r.run(SourceFile:191)
at java.lang.Thread.run(Thread.java:745)

 

 

Could any one please point me in the right direction.  I have Googled around but have had no luck with solving this problem. If you need further information please ask.

 

Thank you very much,

 

Lincoln

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
21,886 Views
Registered: ‎04-16-2012

Hi @lbpxilinx

 

It looks like you do not have sufficient permissions to access the location mentioned in error message.

Can you try invoking the vivado with proper permissions and let us know whether java error occurs still.

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.

View solution in original post

0 Kudos
8 Replies
Highlighted
Xilinx Employee
Xilinx Employee
21,887 Views
Registered: ‎04-16-2012

Hi @lbpxilinx

 

It looks like you do not have sufficient permissions to access the location mentioned in error message.

Can you try invoking the vivado with proper permissions and let us know whether java error occurs still.

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.

View solution in original post

0 Kudos
Highlighted
Observer
Observer
12,099 Views
Registered: ‎03-02-2015

Hi Vinay,

 

Thanks for the reply.

 

I have installed Vivado 2015.2 using root privilages and the following command:-

 

sudo ./Xilinx_Vivado_SDK_2015.2_0626_1_Lin64.bin

 

It has installed Vivado 2015.2 into:-

 

/opt/Xilinx

 

which has the follwing privilages:-

 

drwxr-xr-x 9 root root 4096 Jul 14 10:51 Xilinx

 

The tutorial I am following then says to nagivate to home directory which in may case is:-

 

/home/lincoln

 

At this point the tutorial then says to type:-

 

source /opt/Xilinx/Vivado/2015.2/settings64.sh

 

and then type:-

 

vivado

 

After this the following errors occur as given above.

 

In the tutorial I was following he did not get any of these errors.

 

"Can you try invoking the vivado with proper permissions and let us know whether java error occurs still".

 

Where / how do I do this?

 

Thanks very much,

 

Lincoln.

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
12,097 Views
Registered: ‎08-01-2008
For the Digilent cable, please follow the steps in (Xilinx Answer 59128)

Note: This method will work for the Digilent cable but not for the Xilinx USB cable.


For the Xilinx USB Cable, please follow the steps at the link below.

http://www.george-smart.co.uk/wiki/Xilinx_JTAG_Linux

Note: this method has been tested with both Vivado and ISE installed on the Ubuntu OS, it has not been tested with only Vivado installed.



http://www.xilinx.com/support/answers/59128.html
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Highlighted
Observer
Observer
12,078 Views
Registered: ‎03-02-2015

Hi Balkrishan,

 

Thanks for the reply.

 

The message you posted above does not seemed to be related to this problem or any I wrong?

 

Thanks.

 

Lincoln

0 Kudos
Highlighted
Observer
Observer
12,007 Views
Registered: ‎03-02-2015

Hi All,

 

I still have not been able to resolve this problem. I followed the given advice from another thread on the Xilinx User Community Forum but still no luck. Below is the advice I followed:-

 

Typically what I do is:

 

sudo mkdir /home/Xilinx

sudo chmod 777 /home/Xilinx

sudo ln -s /home/Xilinx /opt/Xilinx

<install Vivado, but not Cable Drivers, as a normal user>

 

The /opt directory is normally on the root partition, which does not have tons of empty space, but /home is usually in its own partition with lots of empty space.  You can replace /home/Xilinx with whatever location you like that has lots of space.  To start over and re-install Vivado:

 

sudo rm -rf /opt/Xilinx

<use above instructions>

 

If you want to try to reinstall using your existing download, I am not sure on Ubuntu, but on Centos when I do a download from the browser, the Vivado download and installation executable is under /home/username/Downloads.  That program downloads additional components, which are stored under /opt/Xilinx/.xinstall/.

 

To use your current download without removing everything and starting over you could:

 

sudo find /opt/Xilinx/ -exec chmod 777 {} \; -print

/opt/Xilinx/.xinstall/Vivado_2014.4/xsetup

 

Cable Drivers will still need to be installed by root if that did not complete the first time:

 

sudo  /opt/Xilinx/Vivado/2014.4/data/xicom/cable_drivers/lin64/install_script/install_drivers/install_drivers

 

Let us know if you need further help.

 

This did not solve the problem. I still get the same errors occur.

 

I am installing Vivado 2015.2 on a freshly installed Ubuntu 14.04 LTS and I have been using on the default settings when I installed Ubuntu.

 

Thanks very much,

 

Lincoln

0 Kudos
Highlighted
Observer
Observer
11,987 Views
Registered: ‎03-02-2015

Hi Vinay,

 

By changing permission I was able to get Vivado gui to run.

 

Thanks for that.

 

Lincoln

0 Kudos
Highlighted
Newbie
Newbie
11,320 Views
Registered: ‎09-13-2015

Hi~

 

I'm running into the same situation in my VM. Can you tell me how you change the permission ? 

 

Thank you 

0 Kudos
Highlighted
Visitor
Visitor
10,572 Views
Registered: ‎07-27-2012