cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
50,623 Views
Registered: ‎04-19-2014

Vivado/Xilinx SDK Error Incorrect Visual C++ Version

Jump to solution

I just installed Vivado using the Web installer. I'm running Windows 8.1 x64. When I try and open either Vivado 2014.1 or Xilinx SDK 2014.1 I get a Visual Studio 2012 Visual C++ Runtime installation window. The Xilinx SDK console says I have the incorrect version. I have tried installing the version located C:\Xilinx\Vivado\2014.1\tps\win64 as well but that just opens up the same window. I have attached the error I get. Does any one know how to fix this?

 

Thanks

 

SDK Error.jpg
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Visitor
Visitor
81,478 Views
Registered: ‎04-19-2014

I tried the repair option and it didn't change anything. I did find a work around looking at the .bat file. If I just rename xvcredist.exe then it won't run at start up and Vivado opens up. It seems like there is a bug with xvcredist.exe. I do have VIsual Studio 2012 installed which insalled all the Visual C++ Redistributable Packages from 2005-2012. So maybe xvcredist.exe is finding one of the other packages.

View solution in original post

34 Replies
Highlighted
Xilinx Employee
Xilinx Employee
50,535 Views
Registered: ‎09-20-2012

Hi,

 

Run vcredist.exe from C:\Xilinx\Vivado\2014.1\tps\win64. If it prompts you with the same message,

Can you try "repair" it?

 

Thanks,

Deepika.

 

Thanks,
Deepika.
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (the star on the left)
0 Kudos
Highlighted
Visitor
Visitor
81,479 Views
Registered: ‎04-19-2014

I tried the repair option and it didn't change anything. I did find a work around looking at the .bat file. If I just rename xvcredist.exe then it won't run at start up and Vivado opens up. It seems like there is a bug with xvcredist.exe. I do have VIsual Studio 2012 installed which insalled all the Visual C++ Redistributable Packages from 2005-2012. So maybe xvcredist.exe is finding one of the other packages.

View solution in original post

Highlighted
50,251 Views
Registered: ‎06-16-2014

I have now the same issue with Vivado 2014.2. Proviously I have used version 2014.1 and had not prloblem.

Running xvcredist.exe does not help. Any ides to solve this issue?

 

 I'm using Windows 8.1 x64

 

Thanks,

Adam

0 Kudos
Highlighted
Visitor
Visitor
50,248 Views
Registered: ‎04-19-2014

 If I just rename xvcredist.exe then it won't run at start up and Vivado opens up


 

Highlighted
50,242 Views
Registered: ‎06-16-2014
It works,

Thanks,
Adam
0 Kudos
Highlighted
Anonymous
Not applicable
49,570 Views

That hack works, but I'd like to know why I have to do that. I install 2014.2 and it ran fine until randomly it would seem, the redistrubtable error started to pop up. Like I said the hack seems to work but why does the error occur? 

 

Also what features might this effect?

0 Kudos
Highlighted
Visitor
Visitor
48,512 Views
Registered: ‎02-21-2014

I came across this thread after while installing Vivado 2014.4. I had the 2012 Visual C++ installation popup giving me the option to repair or remove during installation. After reading this thread I ended up renaming the vcredist.exe for both x86 and x64 - that got me through the installation. After that I found that the SDK separately would try to launch the vcredist.exe and renaming it didn't help. I had a newer version of the 2012 redistributable installed already. What ultimately fixed it for me was to make sure I only had the x86 and x64 11.0.61030 version of the 2012 redistributable installed. Then I went to the MS website and found the x86 and x64 redistributable that matched my already installed versions. I ran them each, did a repair, I have not had the popup since and all the Xilinx tools are working without having to rename any vcredist.exe's.

 

The version that comes with the Xilinx tools is 11.0.60610. The vcredist.exe is in several locations of the Xilinx installation. Renaming didn't help with the SDK because it looks like the SDK itself looks for a proper installation of the 2012 C++ redistributable. At least for 2014.4.

 

Hope his helps anybody else that comes across this.

 

Lenny

_______________________
Baker Process & Engineering
http://www.bakerpe.com
0 Kudos
Highlighted
Visitor
Visitor
48,435 Views
Registered: ‎03-09-2015

I am new to Xilinx, and Vivado, but I am no novice to MCU development.  I seem to have issues with everything, this being one of them.  This is an incredibly difficult system to learn.

0 Kudos
Highlighted
Visitor
Visitor
46,687 Views
Registered: ‎04-29-2015

That was a valid solution if and only if the problem occurred *after* Vivado had been installed properly on my workstation.

 

I have replicated the error by doing this setup sequence:

1) Vivado 2014.3.1

2) MS Visual Studio 2013 Ultimate (w/ Update 2)

3) MS Visual Studio 2013 Ultimate Update 4

4) Vivado 2014.4

 

It turned out that this install sequence caused my Vivado 2014.4 xsetup to fail with the same error *during* the VLM launching phase. Then the installer failed to handled the timeout error and hung for more than 1 hour without resuming.

 

I digged into the batch files in C:\Xilinx\Vivado\2014.4\bin starting from vlm.bat and going backwards, and I found that the error is generated in loader.bat, lines 115-140.

 

[...]

set XVREDIST=%RDI_APPROOT%\tps\%RDI_PLATFORM%\xvcredist.exe
if not [%XIL_PA_NO_REDIST_CHECK%] == [1] (
if exist "%XVREDIST%" (
"%XVREDIST%" -check
if [!ERRORLEVEL!] == [1] (
echo.
echo ERROR: This host does not have the appropriate Microsoft Visual C++
echo redistributable packages installed.
echo.

[...]

 

Then I found this durable solution:

 

a) Kill the Vivado installer to ensure the xvcredist.exe to be kept on the disk at its path.

b) Manually launching xvcredist.exe, repairing the actual install if any or install it from scratch

c) Uninstall Vivado 2014.4 from Control Panel if present, or manually delete C:\Xilinx\Vivado\2014.4 files (as the installer did not end gracefully, your registry is still not properly setup)

d) Set the environment variable XIL_PA_NO_REDIST_CHECK to value "1". I added it at Computer level, not user.

e) Restart Vivado 2014.4 setup

 

Now it works as a breeze. 

 

Hope this helps,

Mario

 

Highlighted
Visitor
Visitor
25,588 Views
Registered: ‎04-29-2015
Just tested with Vivado 2015.1. Works as well.
0 Kudos
Highlighted
Visitor
Visitor
25,498 Views
Registered: ‎04-01-2008

I've had this exact same error appear when I upgraded to the new Vivado 15.1. It appears that the Microsoft Visual C++ 2012 Redistributable (x64) version 11.0.60610 installation fails if you have a newer version of the Visual C++ 2012 Redistributable already installed, i.e., version 11.0.61030. Repair or Uninstall and then Install of 11.0.60610 completes quickly but it still does not work. Uninstalling and reinstalling Vivado 15.1 results in the same error.

 

The solution that worked for me was:

 

1. Uninstall Microsoft Visual C++ 2012 Redistrutable (x64) version 11.0.60610.

2. Uninstall Microsoft Visual C++ 2012 Redistrutable (x86) version 11.0.61030.

3. Uninstall Microsoft Visual C++ 2012 Redistrutable (x64) version 11.0.61030.

4. Reboot.

5. Install Microsoft Visual C++ 2012 Redistrutable (x64) version 11.0.60610 from the <xilinx install path>\Vivado\2015.1\tps\win64\xvcredist.exe.

6. Reboot (required after install).

7. Start up Vivado to test it -- now it runs without issues.

8. Exit Vivado.

8. Install Microsoft Visual C++ 2012 Redistrutable (x86) version 11.0.61030 (or latest).

9. Install Microsoft Visual C++ 2012 Redistrutable (x64) version 11.0.61030 (or latest).

10. Start up Vivado to test it again -- it still works.

 

Basically what was done is all versions of Microsoft Visual C++ 2012 Redistributable were uninstalled. Then the version supplied by Xilinx Vivado 2015 was installed, followed by reinstalling the other (later) versions.

 

Hope this helps others in the same predicament.

Cheers!

 

Highlighted
Participant
Participant
25,265 Views
Registered: ‎04-16-2014
For me ist worked simply uninstall all Uninstall Microsoft Visual C++ 2012 Redistrutable versions 11.0.61030 It seems no version newer than version 11.0.61010 shoud be installed when installing Vivado 2014.4 Thank you.
Highlighted
Newbie
Newbie
24,843 Views
Registered: ‎08-28-2015

Do you the exact syntax to set XIL_PA_NO_REDIST_CHECK to value "1 ?

 

example(would it be something like this):

 

set XIL_PA_NO_REDIST_CHECK = [1]

0 Kudos
Highlighted
Newbie
Newbie
24,809 Views
Registered: ‎08-29-2015

Using Vivado 2015.2 on Win8.1.

What worked for me was installing the latest VCRedist.

 

1. Uninstall the redist installed by Vivado (go to add remove, sort by date and pick the latest installed VC Redist)

2. Install http://www.microsoft.com/en-us/download/details.aspx?id=30679

 

0 Kudos
Highlighted
Visitor
Visitor
24,658 Views
Registered: ‎08-07-2015

Hey,

 

I faced the very same issue with Windows 8.1 x64. Easy solution is

 

*checking the "Programmes and Features" and in the "Installations"

*if there are several "Microsoft Visual C++ 2012 Redistributable (x64)" uninstalling all

*double click to vivado icon

*accepting the installation of "Microsoft Visual C++ 2012 Redistributable (x64)" again

 

Then it should work.

Bests,

 

Highlighted
21,990 Views
Registered: ‎02-07-2008

oncu's easy solution worked for me with Windows 10 and Vivado 2016.1.

 

Thanks.

 

0 Kudos
Highlighted
Newbie
Newbie
21,986 Views
Registered: ‎04-22-2016

Thanks for posting this! It works on 2014.2 as well.

0 Kudos
Highlighted
Newbie
Newbie
21,662 Views
Registered: ‎05-17-2016
That is what changed that ?
0 Kudos
Highlighted
Newbie
Newbie
20,075 Views
Registered: ‎10-12-2016
Thanks for posting this ! Really helps a lot !
0 Kudos
Highlighted
14,251 Views
Registered: ‎02-09-2012

This problem still occurs even when installing 2016.3 (upgrading from 2015.4) on my Win 8.1 64 laptop. So far I haven't been able to get the proposed solution to work (using the env variable).

0 Kudos
Highlighted
13,935 Views
Registered: ‎02-01-2009

Thanks - you're so clever!!- this solved my problem with 2016.4 install.

0 Kudos
Highlighted
Newbie
Newbie
13,650 Views
Registered: ‎08-11-2011

this solution works for my vivado system edition 2016.2

0 Kudos
Highlighted
Visitor
Visitor
13,265 Views
Registered: ‎06-05-2017

I've just encountered this issue in 2017.1 (although previous versions of Vivado installed just fine)

 

Can fundamental issues like these that are three years old be prioritized in new releases?

 

0 Kudos
Highlighted
13,035 Views
Registered: ‎06-17-2017

renaming worked!! thank you.

0 Kudos
Highlighted
Adventurer
Adventurer
13,001 Views
Registered: ‎03-17-2017

I too just began to encounter this issue in 2017.1 I've been using it since the day it released without issue and just all of a sudden it won't work. I've tried uninstalling and reinstalling the Microsoft C++ redist packages from Xilinx and Microsoft to no avail. Word to the wise, be very cautious uninstalling your C++ redist packages as other software you have may rely on them, including your anti-virus. 

 

Can someone from Xilinx please comment on this issue and provide some instruction on how we can fix this immediately?

0 Kudos
Highlighted
Moderator
Moderator
12,987 Views
Registered: ‎06-24-2015

@baf2099,

 

Do you have Microsoft Visual C++ REdistributables 2015 installed?

Thanks,
Nupur
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (click on the 'thumbs-up' button).
0 Kudos
Highlighted
Adventurer
Adventurer
12,887 Views
Registered: ‎03-17-2017

Yes, after talking with our FAE, I was told that Xilinx is aware of this issue, and that the official recommendation is to bypass the vcredist check with the environment variable as described in this answer record

 

https://www.xilinx.com/support/answers/69076.html

0 Kudos
Highlighted
Adventurer
Adventurer
11,633 Views
Registered: ‎02-04-2008

I've been running 2017.2 for months, and today I started my computer and tried to launch, and it wants to install MVC++ 2015 x64 package. WTH? Why all of a sudden?? And of course it fails as described on this forum post.

0 Kudos
Highlighted
Adventurer
Adventurer
10,408 Views
Registered: ‎11-04-2010

I had 2018.1 installed then had to install 2017.1 because my customer can't get 2018.1 to work with their license server. Now this redistributable C++ issue has come up, preventing me from using 2017.1.

 

Xilinx, this is a NIGHTMARE. Please fix your software.

0 Kudos