UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Moderator
Moderator
572 Views
Registered: ‎06-14-2010

Xilinx Documentation Navigator - Catalog update is no longer possible with 2018.3 and earlier versions of Documentation Navigator

Due to a change on Xilinx.com, 2018.3 and earlier versions of Documentation Navigator will no longer allow the user to update the documentation catalog starting in late August 2019.

As shown in the following screenshot, the catalog update button will become orange and show Check Catalog Status when you open Documentation Navigator or when you click the catalog refresh button. 

You will also no longer be able to open the Catalog Manager dialog.

 

The solution and the necessary patch files for a specific version of Documentation Navigator can be found in the following Answer Record, AR#72554

Hope this helps.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
3 Replies
Scholar ronnywebers
Scholar
187 Views
Registered: ‎10-10-2014

Re: Xilinx Documentation Navigator - Catalog update is no longer possible with 2018.3 and earlier versions of Documentation Navigator

thanks @anatoli for the quick reply. I followed the instructions in the AR.

One of my 2 problems is fixed now : I got DocNav update working again after some furhter tweaks, so I'm posting these here :

1) I had to add my proxy information in the preferences

2) I had to quit DocNav, and relaunch before the proxy info was picked up

I must note that the font is (a lot) less readable than the previous font ... maybe something to pass on to the DocNav team? Picking up the proxy without quiting DocNav is minor, but could be fixed too I think.

Also upon launching DocNav I still see this in the terminal:

zynqdev@zynqdev-VM:~$ docnav
QSslSocket: cannot resolve SSLv2_client_method
QSslSocket: cannot resolve SSLv2_server_method

But .. I still have the issue of launching DocNav from Vivado -> customize IP -> documentation -> product guide.

The error still says :

/opt/Xilinx/Vivado/2018.2/ids_lite/ISE/lib/lin64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/x86_64-linux-gnu/libproxy.so.1)
Failed to load module: /usr/lib/x86_64-linux-gnu/gio/modules/libgiolibproxy.so
/usr/lib/firefox/firefox: /opt/Xilinx/Vivado/2018.2/ids_lite/ISE/lib/lin64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib/firefox/firefox)

Q: any idea how to fix that ?

 

 

** kudo if the answer was helpful. Accept as solution if your question is answered **
0 Kudos
Moderator
Moderator
154 Views
Registered: ‎06-14-2010

Re: Xilinx Documentation Navigator - Catalog update is no longer possible with 2018.3 and earlier versions of Documentation Navigator

Hello @ronnywebers ,

Have a look at the solution provided here:

https://forums.xilinx.com/t5/Embedded-Development-Tools/lbstdc-6-not-found/td-p/767655

 The libproxy library within your OS requires a newer GLIBC version than the one included within the Vivado 2018.2 installation directory. So the solution is just remove (or rename) the built-in library within Vivado and link the library within your OS which is sync with libproxy version.

https://askubuntu.com/questions/699440/version-glibcxx-3-4-20-not-found

 

In relation to QSslSocket: cannot resolve SSLv2_client_method

Please check this forum thread: https://forums.xilinx.com/t5/General-Technical-Discussion/2016-3-Documentation-Navigator-ERROR/td-p/728494

Installing the 32-bit version of openssl-libs fixed this problem for other users.

Hope this helps.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
Scholar ronnywebers
Scholar
113 Views
Registered: ‎10-10-2014

Re: Xilinx Documentation Navigator - Catalog update is no longer possible with 2018.3 and earlier versions of Documentation Navigator

thanks @anatoli, I did the following :

cd /opt/Xilinx/Vivado/2018.2/ids_lite/ISE/lib/lin64/
sudo mv libstdc++.so.6 libstdc++.so.6.orig
sudo ln -s /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.26 libstdc++.so.6

that somehow improved things: now I need to open the product guide twice, to get Firefox to open the document ...

Upon the first click on the product guide (from the customize IP dialog), I can see the following in the terminal where I launched Vivado from.

QLocalSocket::connectToServer: Connection refused

When I click a 2nd time on the product guide, Firefox does open the pdf, and  I can see the following in the terminal :

ERROR: Socket server not listening. QLocalServer::listen: Address in use
 
Restart of the local socket server was successful. 

so ... I currently have a workaround :-) Open the product guide twice ...

However I think I'm almost there, so it would be great to fix this too ... you suggested to 'Installing the 32-bit version of openssl-libs', however I'm not sure how to install these properly. If I search for libssl  get:

sudo apt-cache search libssl
libssl-dev - Secure Sockets Layer toolkit - development files
libssl-doc - Secure Sockets Layer toolkit - development documentation
libssl1.0.0 - Secure Sockets Layer toolkit - shared libraries
libssl1.0.0-dbg - Secure Sockets Layer toolkit - debug information

I don't see a 32-bit version I think (should have i386 in it?). If I try to install libssl-dev, I get:

sudo apt-get install libssl-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libssl-dev : Depends: libssl1.0.0 (= 1.0.2g-1ubuntu4) but 1.0.2g-1ubuntu4.8 is to be installed
              Depends: zlib1g-dev but it is not going to be installed
              Recommends: libssl-doc but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I'm not a linux expert at all, I hope Xilinx can improve the installation hassle on Ubuntu in future versions, that would be really great !

** kudo if the answer was helpful. Accept as solution if your question is answered **