UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
10,725 Views
Registered: ‎01-13-2015

Xilinx SDK 2014.4 installed on Windows 7 in VMWare license error?!

Hi,

 

looking around the forum I found there have been some previous issues with licenses and vm's, but I did not manage to find an answer if this issue is already fixed or whether there is a workaround available.

 

My situation: I have a VMWare Windows 7 machine on which I have installed the Xilinx 2014.4 SDK. I have obtained a 'Get Free Licenses - Vivado webPACK, SDK, free IP and more' using the VIVADO License Manager that was installed and used 'Load license' to add the license send to me by e-mail. When I select 'View license status' in the license manager I see in the list of 'Activation Based Licenses:' that a license with Expiration Date 'Permanent' has been found for 'Embedded_SDK' and 'SDK' (License Vendor String=TRUSTED_STORAGE,....) so as far as I can tell everything should be fine.

 

Now when I double click the 'Xilinx SDK 2014.4' shortcut on my desktop, the eclipse IDE is launched and I see the following messages appear in the SDK Log:

16:23:47 WARN: Unable to obtain port 2478 for use by XSDB Server, java.net.SocketException: Unrecognized Windows Sockets error: 0: JVM_BIND   (And then this message repeated for a list of other ports)

16:23:48 INFO: Launching XSDB server: xsdb.bat -s c:\Xilinx\SDK\2014.4\scripts\xsdb\xsdb\xsdb-server.tcl 2520

16:23:49 ERROR: License Feature SDK is not available.

 

This is then followed by a messagebox with 'SDK requires an evaluation or full license. There is no cost ...'

 

Is this indeed an issue connected to running from within a VM? If not, any hints on what might be causing the problem (the Socket errors would indicate potential network/firewall issues)?

 

Any help will be greatly appreciated!

 

BTW: Unfortunately, not using a VM is not an option for me.

 

Thanks,

 

Philippe

0 Kudos
8 Replies
Xilinx Employee
Xilinx Employee
10,716 Views
Registered: ‎04-16-2012

Re: Xilinx SDK 2014.4 installed on Windows 7 in VMWare license error?!

Hello,

 

Can you share the output of the command: xlicclientmgr -v "format=long"

Run this command after sourcing settings64.bat (from Vivado installed directory) in command prompt.

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
10,703 Views
Registered: ‎01-13-2015

Re: Xilinx SDK 2014.4 installed on Windows 7 in VMWare license error?!

Hi Vinay,

 

here is the output, I hope this helps.

 

Thanks in advance,

 

Philippe

 

C:\Xilinx\SDK\2014.4\bin>xlicclientmgr.bat -v "format=long"
Viewing application trusted storage.
-------------------------------------------------------------------------------
        Fulfillment Id : 211638238
      Fulfillment Type : 6 Publisher Activation
           Trust Flags : 0x7 Fully Trusted
                Status : Enabled
        Entitlement Id :
            Product Id : 209855590
       Expiration Date : permanent
          Server chain : Server1
       Feature Line(s) :
INCREMENT Embedded_SDK xilinxd 2016.01 permanent 9999 935392DBC2DE \
VENDOR_STRING=TRUSTED_STORAGE,philippedirkse,Embedded_SDK,software,permanent,_210992514_0_0_223 \
ISSUER="Xilinx Inc" START=12-Jan-2015 TS_OK
PACKAGE Embedded_SDK xilinxd 2016.01 BCF6B90D946A COMPONENTS=SDK \
OPTIONS=SUITE

-------------------------------------------------------------------------------
        Fulfillment Id : 211638347
      Fulfillment Type : 6 Publisher Activation
           Trust Flags : 0x7 Fully Trusted
                Status : Enabled
        Entitlement Id :
            Product Id : 209855574
       Expiration Date : permanent
          Server chain : Server1
       Feature Line(s) :
INCREMENT Vivado_WebPACK xilinxd 2016.01 permanent 9999 46A1F8ED16DF \
VENDOR_STRING=TRUSTED_STORAGE,philippedirkse,Vivado_WebPACK,software,permanent,_210992514_0_0_117 \
ISSUER="Xilinx Inc" START=12-Jan-2015 TS_OK
PACKAGE Vivado_WebPACK xilinxd 2016.01 2B0AE052A5FA COMPONENTS="SDK \
V_WebPACK" OPTIONS=SUITE


Viewed 2 of 2 fulfillment records.

0 Kudos
Xilinx Employee
Xilinx Employee
10,684 Views
Registered: ‎04-16-2012

Re: Xilinx SDK 2014.4 installed on Windows 7 in VMWare license error?!

Hi Philippe,

 

From the output, I see you have two licenses (SDK and Vivado WebPACK) and they are installed successfully. So tool has to pick these licenses. 

 

Did you install Vivado in your machine? If yes, run the tcl command in Vivado Tcl shell and share the output here.

report_environment -file env.txt

 

If Vivado was not installed, open Vivado License Manager and click on "View Licenses Status" tab and share the snapshot of it.

 

Thanks,

Vinay 

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
10,671 Views
Registered: ‎01-13-2015

Re: Xilinx SDK 2014.4 installed on Windows 7 in VMWare license error?!

Hello Vinay,

 

I only have the SDK installed, so I included the screenshot from the license manager. Hope this helps.

 

Regards,

 

Philippe

 

 

license.png
0 Kudos
Xilinx Employee
Xilinx Employee
10,665 Views
Registered: ‎04-16-2012

Re: Xilinx SDK 2014.4 installed on Windows 7 in VMWare license error?!

Hello Philippe,

 

Thanks for sharing the snapshot.

I see license was installed successfully and the tool was able to pick it. So seems like some other issue (not licensing).

 

Did you observe any other messages while invoking the SDK GUI?

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Highlighted
Observer chengtms
Observer
10,492 Views
Registered: ‎11-24-2012

Re: Xilinx SDK 2014.4 installed on Windows 7 in VMWare license error?!

Hi all,

 

I'm seeing the same problem. I have Webpack 2014.4 and SDK installed on a VMware virtual machine. Webpack seems to work properly but SDK is unable to locate the license.E rror message same as Phillippe's. Has anybody figure out how to fix it? Thanks.

 

Stephen

0 Kudos
Visitor blacdard
Visitor
10,413 Views
Registered: ‎10-16-2009

Re: Xilinx SDK 2014.4 installed on Windows 7 in VMWare license error?!

I am having this problem too.  Same environment... Win 7 in VMWare (Fusion in my case).

 

Vivado works, SDK does not.  Licenses exist for both and LOOK fine in VLM, but the SDK will ask me to acquire a license every time.

0 Kudos
Visitor blacdard
Visitor
10,407 Views
Registered: ‎10-16-2009

Re: Xilinx SDK 2014.4 installed on Windows 7 in VMWare license error?!

By the way, the reported port connection warnings in the SDK window before are just from leftover processes when the licensing fails. If you kill all the "rdi_xsdb.exe" entries in task manager you won't get these.  I was getting more and more until I checked task manager.  It doesn't make a difference.

 

Here's error message from launching the SDK, a screenshot of the VLM entries, the xlicclientmgr dump, and the report created by "report_environment -file env.txt".

 

0 Kudos