cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
cyclopentane
Visitor
Visitor
1,461 Views
Registered: ‎07-23-2020

Xilinx Unified Installer 2020.2 stuck on Ubuntu 20.04

I tried to download the unified installer 2020.2 and install Vitis on Ubuntu 20.04. The installer is stuck on the "Final Processing - Generating installed device list" step. I tried to check on the xinstall_1610422012628.log file, and the last several lines shown as:

2021-01-11 22:28:39,678 DEBUG: com.xilinx.installer.shortcuts.lin.XMLShortcutRoot:? - Checking shortcut file: /home/<user>/.config/menus/applications-merged/Xilinx Design Tools.menu
 
with several identical DEBUG messages above. I have attached the xinstall_1610422012628.log under this question message if further details are needed. 
 
I have already read some related posts, such as "https://forums.xilinx.com/t5/Installation-and-Licensing/Installation-of-Vivado-2020-2-on-Ubuntu-20-04/td-p/1185285", but no essential solution was found. 
 
Please help me with the installation process if you have any ideas. Any help is sincerely appreciated. Thank you very much. 
 
 
13 Replies
watari
Teacher
Teacher
1,440 Views
Registered: ‎06-16-2013

Hi @cyclopentane 

 

Did you make sure permission on this directory ?

 

Best regards,

0 Kudos
cyclopentane
Visitor
Visitor
1,429 Views
Registered: ‎07-23-2020

Hello @watari , thank you very much for your response. 

I sudo'ed the installer. I suppose that will grand the installer over any directory...?

Thank you very much.

0 Kudos
watari
Teacher
Teacher
1,408 Views
Registered: ‎06-16-2013

Hi @cyclopentane 

 

You don't have to install Xilinx tools with root privilege like sudo.

Try to remove installed directory and install tool, again.

 

Best regards,

0 Kudos
cyclopentane
Visitor
Visitor
1,392 Views
Registered: ‎07-23-2020

Hello @watari,

When I was trying to run the installer in the beginning, I did not use the sudo permission to run the installer. However, it soon ran into problems with lack of necessary permissions to make directories and such. 

So far I am more confused with how I can resolve the unexpected suspended installation process. I am not sure why even when I am running the installer with root privilege, the process was still stopped at the "checking shortcut file". 

Thank you very much. 

0 Kudos
ansarimo
Xilinx Employee
Xilinx Employee
1,371 Views
Registered: ‎12-04-2019

Hi @cyclopentane 

Please check this forum topic, which has a workaround that you can use/try at your end that should also help you to overcome your issue:

https://forums.xilinx.com/t5/Installation-and-Licensing/Vivado-2018-3-Final-Processing-hangs-at-Generating-installed/m-p/972114#M25861

Hope this helps.

 

Thanks & Regards,

Ansari Hunen

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as a solution.
------------------------------------------------------------------------

0 Kudos
cyclopentane
Visitor
Visitor
1,324 Views
Registered: ‎07-23-2020

Hello @ansarimo,

Thank you very much for your response.

However, I had tried to reference that question and the related blog document before I submitted this question. Mr. Zundel and I were stuck in different places. His process was suspended at "Executing script Generating installed device list" and mine was suspended on "Checking shortcut file". 

At the current point, my log file does not contain the error message he ran into, i. e. "Executing script Generating installed device list". Besides, under my /.Xilinx/ directory, there is only two other directories so-called "registry" and "xinstall". These could be the pieces of evidence that my installer did not even reach the point where Mr. Zundel's solution can be applied yet, or Xilinx has made some changes to their installer. 

It would be very helpful if you can provide more help with my installation process. Anything would be appreciated. 

Thank you very much. 

0 Kudos
watari
Teacher
Teacher
1,250 Views
Registered: ‎06-16-2013

Hi @cyclopentane 

 

>When I was trying to run the installer in the beginning, I did not use the sudo permission to run the installer. However, it soon ran into problems with lack of necessary permissions to make directories and such.

 

It's easy to resolve it.

I suggest you to create installed directory with proper permission before installing tool.

 

> I am not sure why even when I am running the installer with root privilege, the process was still stopped at the "checking shortcut file".

 

I'm not familiar with install procedure of Xilinx. However, you must take care permission and almost all does not need root privilege.

 

Best regards,

cyclopentane
Visitor
Visitor
1,206 Views
Registered: ‎07-23-2020

Hello @watari

Thank you very much for your response.

However, I am rather confused with this statement ">I suggest you to create installed directory with proper permission before installing tool." I am not entirely sure how I can know what kind of directory structure the installer will create before the installer is being run. Should I perhaps read through the bash script first? 

Thank you.

0 Kudos
joancab
Teacher
Teacher
1,190 Views
Registered: ‎05-11-2015

Ubuntu 20.04 is not supported

0 Kudos
cyclopentane
Visitor
Visitor
1,090 Views
Registered: ‎07-23-2020

Hello @joancab,

Please refer to this installer documentation page. According to the official documentation released by Xilinx, Unbuntu 20.04 is listed as a supported os.

It would be nice if you can list your source of information about Ubuntu 20.04 is no longer supported. 

joancab
Teacher
Teacher
1,085 Views
Registered: ‎05-11-2015

True. I recently wanted to install 2020.2 tools (Vivado, Vitis and Petalinux) on Ubuntu 20.04, and found that Ubuntu 20.04 does not support Petalinux 20.2 but it does Vivado and Vitis. Source: ug1144-petalinux-tools-reference-guide 

cyclopentane
Visitor
Visitor
979 Views
Registered: ‎07-23-2020

Hello @watari,

I have tried to create all the directories and sub-directories beforehand and correctly managed the permission of my installer. However the identical issue occurred again at the same step, and the installation was not successful.

But still, thank you very much for your advice and suggestions. It was better than not knowing what to do whatsoever.

Thank you very much.

0 Kudos
cyclopentane
Visitor
Visitor
979 Views
Registered: ‎07-23-2020

Hello @joancab,

Thank you very much for confirming that. I suspect it was some issue with the incompatibility of the Petalinux as well. I hope we will find a solution soon.

God bless, 

0 Kudos