cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Advisor
Advisor
254 Views
Registered: ‎10-10-2014

cannot setup my floating license in Vivado 2018.3 on Ubuntu VM

Jump to solution

We recently bought a floating license for Vivado. Our flexlm server is up and running correctly (at least, it looks like it's running correctly), I can also ping our flexlm server from my VM.

On my VM with Vivado 2018.3 running Ubuntu:

lsb_release -a
LSB Version:	core-9.20170808ubuntu1-noarch:printing-9.20170808ubuntu1-noarch:security-9.20170808ubuntu1-noarch
Distributor ID:	Ubuntu
Description:	Ubuntu 18.04 LTS
Release:	18.04
Codename:	bionic

I added the environment variable XILINXD_LICENSE_FILE on my VM to my .bashrc:

# Vivado flexlm server
export XILINXD_LICENSE_FILE=36179@flexlm

Vivado license manager seems to confirm this is ok:

Screenshot 2020-01-22 at 15.48.45.png

Guess LM_LICENSE_FILE is a legacy thing (?)

Note that I downloaded Vivado a few weeks ago, and did use a 30-day trial license, which I now hope to replace by our floating license.

If I run report_environment, I think Vivado does not see my floating license, because there are only 'nodelocked' items in the report, nothing 'floating'

Up next I tried - as suggested in this post - to use the lmutil tool to check if the server is correctly running, however if I try to run 'lmutil', I get command not found :

source /opt/Xilinx/Vivado/2018.3/settings64.sh
export LD_LIBRARY_PATH=/opt/Xilinx/Vivado/2018.3/lib/lnx64.o/
cd /opt/Xilinx/Vivado/2018.3/bin/unwrapped/lnx64.o/ lmutil lmstat -a -c 36179@flexlm

-> lmutil: command not found

running ldd lmutil gives:

ldd lmutil
	linux-vdso.so.1 (0x00007ffe1a99e000)
	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f7bfa240000)
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f7bf9ea2000)
	libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f7bf9c8a000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f7bf9899000)
	libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f7bf9695000)
	/lib64/ld-lsb-x86-64.so.3 => /lib64/ld-linux-x86-64.so.2 (0x00007f7bfa45f000)

I also tried to install 'lsb' and 'lsb-core' as suggested in this post, but this doesn't change anything ...

so ... I'm out of options :-) Any suggestions would be very welcome...

 

** kudo if the answer was helpful. Accept as solution if your question is answered **
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Advisor
Advisor
117 Views
Registered: ‎10-10-2014

Re: cannot setup my floating license in Vivado 2018.3 on Ubuntu VM

Jump to solution

@anatoli our problem has been solved in the meantime, there was an issue with the flexlm setup on the server side.

Also, I was calling 'lmutil' in a wrong way, I had to use ./lmutil :

# for Vivado 2018.3 -> change according to your version
cd /opt/Xilinx/Vivado/2018.3/bin/unwrapped/lnx64.o
./lmutil lmstat -a -c 8226@flexlm

 should the settings64.sh script not add these utils to the linux path?

 

** kudo if the answer was helpful. Accept as solution if your question is answered **

View solution in original post

2 Replies
Highlighted
Moderator
Moderator
156 Views
Registered: ‎06-14-2010

Re: cannot setup my floating license in Vivado 2018.3 on Ubuntu VM

Jump to solution

Hello @ronnywebers ,

Have you managed to overcome this issue by now? Are you still having issues with your floating license?

If so, please send us your Xinfo report generated on the PC where you see this licensing issue. 

Xinfo.txt can be generated by running the "report_environment –file xinfo.txt" command in Vivado TCL console.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
Highlighted
Advisor
Advisor
118 Views
Registered: ‎10-10-2014

Re: cannot setup my floating license in Vivado 2018.3 on Ubuntu VM

Jump to solution

@anatoli our problem has been solved in the meantime, there was an issue with the flexlm setup on the server side.

Also, I was calling 'lmutil' in a wrong way, I had to use ./lmutil :

# for Vivado 2018.3 -> change according to your version
cd /opt/Xilinx/Vivado/2018.3/bin/unwrapped/lnx64.o
./lmutil lmstat -a -c 8226@flexlm

 should the settings64.sh script not add these utils to the linux path?

 

** kudo if the answer was helpful. Accept as solution if your question is answered **

View solution in original post